Jump to content

Recommended Posts

  • 1 month later...
  • Replies 94
  • Created
  • Last Reply

Top Posters In This Topic

This installs but doesn't work for me.

Pineapple is 2.8.1 with a 8GB Cruzer Fit (2GB swap).

The install process completes and it looks like it will work but as soon as I select a script the traffic is dropped. Switch the proxy off and I can get traffic through to the computer under test.

I've done a manual install using SSH and this is the output:

Downloading http://cloud.wifipineapple.com/packages/Packages.gz.

Updated list of available packages in /var/opkg-lists/pineapple_packages.
Package python (2.7.3-1) installed in usb is up to date.
Package python-openssl (2.7.3-1) installed in usb is up to date.
Package imagemagick-tools (6.7.8-1) installed in usb is up to date.
ln: /usr/lib/ImageMagick-6.7.8: File exists
mkdir: can't create directory '/usb/usr/lib/ImageMagick-6.7.8/config': No such file or directory
cp: can't create '/usb/usr/lib/ImageMagick-6.7.8/config/': No such file or directory
cp: can't create '/usb/usr/lib/ImageMagick-6.7.8/config/': No such file or directory
Package distribute (0.6.21-1) installed in usb is up to date.
Downloading/unpacking pip
Downloading pip-1.3.1.tar.gz (247Kb): 247Kb downloaded
Running setup.py egg_info for package pip
warning: no files found matching '*.html' under directory 'docs'
warning: no previously-included files matching '*.txt' found under directory 'docs/_build'
no previously-included directories found matching 'docs/_build/_sources'
Installing collected packages: pip
Found existing installation: pip 1.3.1
Uninstalling pip:
Successfully uninstalled pip
Running setup.py install for pip
warning: no files found matching '*.html' under directory 'docs'
warning: no previously-included files matching '*.txt' found under directory 'docs/_build'
no previously-included directories found matching 'docs/_build/_sources'
Installing pip script to /usb/usr/bin
Installing pip-2.7 script to /usb/usr/bin
Successfully installed pip
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): mitmproxy in /usb/usr/lib/python2.7/site-packages
Requirement already satisfied (use --upgrade to upgrade): netlib>=0.9 in /usb/usr/lib/python2.7/site-packages (from mitmproxy)
Downloading/unpacking urwid>=1.1 (from mitmproxy)
Downloading urwid-1.1.1.tar.gz (482kB): 482kB downloaded
Running setup.py egg_info for package urwid
Requirement already satisfied (use --upgrade to upgrade): pyasn1>0.1.2 in /usb/usr/lib/python2.7/site-packages (from mitmproxy)
Downloading/unpacking pyopenssl>=0.12 (from mitmproxy)
Downloading pyOpenSSL-0.13.tar.gz (250kB): 250kB downloaded
Running setup.py egg_info for package pyopenssl
warning: no previously-included files matching '*.pyc' found anywhere in distribution
Downloading/unpacking PIL (from mitmproxy)
Downloading PIL-1.1.7.tar.gz (506kB): 506kB downloaded
Running setup.py egg_info for package PIL
WARNING: '' not a valid package name; please use only.-separated package names in setup.py
Downloading/unpacking lxml (from mitmproxy)
Downloading lxml-3.2.1.tar.gz (3.3MB): 3.3MB downloaded
Running setup.py egg_info for package lxml
/usb/usr/lib/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'bugtrack_url'
warnings.warn(msg)
Building lxml version 3.2.1.
Building without Cython.
ERROR: /bin/sh: xslt-config: not found
** make sure the development packages of libxml2 and libxslt are installed **
Using build configuration of libxslt
warning: no previously-included files found matching '*.py'
warning: no files found matching '*.txt' under directory 'src/lxml/tests'
Downloading/unpacking flask (from mitmproxy)
Downloading Flask-0.9.tar.gz (481kB): 481kB downloaded
Running setup.py egg_info for package flask
warning: no files found matching '*' under directory 'tests'
warning: no previously-included files matching '*.pyc' found under directory 'docs'
warning: no previously-included files matching '*.pyo' found under directory 'docs'
warning: no previously-included files matching '*.pyc' found under directory 'tests'
warning: no previously-included files matching '*.pyo' found under directory 'tests'
warning: no previously-included files matching '*.pyc' found under directory 'examples'
warning: no previously-included files matching '*.pyo' found under directory 'examples'
no previously-included directories found matching 'docs/_build'
no previously-included directories found matching 'docs/_themes/.git'
Downloading/unpacking Werkzeug>=0.7 (from flask->mitmproxy)
Downloading Werkzeug-0.8.3.tar.gz (1.1MB): 1.1MB downloaded
Running setup.py egg_info for package Werkzeug
warning: no files found matching '*' under directory 'werkzeug/debug/templates'
warning: no files found matching '*' under directory 'tests'
warning: no previously-included files matching '*.pyc' found under directory 'docs'
warning: no previously-included files matching '*.pyo' found under directory 'docs'
warning: no previously-included files matching '*.pyc' found under directory 'tests'
warning: no previously-included files matching '*.pyo' found under directory 'tests'
warning: no previously-included files matching '*.pyc' found under directory 'examples'
warning: no previously-included files matching '*.pyo' found under directory 'examples'
no previously-included directories found matching 'docs/_build'
Downloading/unpacking Jinja2>=2.4 (from flask->mitmproxy)
Downloading Jinja2-2.7.tar.gz (377kB): 377kB downloaded
Running setup.py egg_info for package Jinja2
warning: no files found matching '*' under directory 'custom_fixers'
warning: no previously-included files matching '*' found under directory 'docs/_build'
warning: no previously-included files matching '*.pyc' found under directory 'jinja2'
warning: no previously-included files matching '*.pyc' found under directory 'docs'
warning: no previously-included files matching '*.pyo' found under directory 'jinja2'
warning: no previously-included files matching '*.pyo' found under directory 'docs'
Downloading/unpacking markupsafe (from Jinja2>=2.4->flask->mitmproxy)
Downloading MarkupSafe-0.17.tar.gz
Running setup.py egg_info for package markupsafe
Installing collected packages: urwid, pyopenssl, PIL, lxml, flask, Werkzeug, Jinja2, markupsafe
Running setup.py install for urwid
building 'urwid.str_util' extension
ccache_cc -fno-strict-aliasing -Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -msoft-float -DNDEBUG -Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -msoft-float -fPIC -I/usb/usr/include/python2.7 -c source/str_util.c -o build/temp.linux-mips-2.7/source/str_util.o
unable to execute ccache_cc: No such file or directory
error: command 'ccache_cc' failed with exit status 1
Complete output from command /usb/usr/bin/python -c "import setuptools;__file__='/usb/pip-build/urwid/setup.py';exec(compile(open(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-0hssiH-record/install-record.txt --single-version-externally-managed:
running install
running build
running build_py
creating build
creating build/lib.linux-mips-2.7
creating build/lib.linux-mips-2.7/urwid
copying urwid/old_str_util.py -> build/lib.linux-mips-2.7/urwid
copying urwid/wimp.py -> build/lib.linux-mips-2.7/urwid
copying urwid/util.py -> build/lib.linux-mips-2.7/urwid
copying urwid/canvas.py -> build/lib.linux-mips-2.7/urwid
copying urwid/__init__.py -> build/lib.linux-mips-2.7/urwid
copying urwid/display_common.py -> build/lib.linux-mips-2.7/urwid
copying urwid/curses_display.py -> build/lib.linux-mips-2.7/urwid
copying urwid/signals.py -> build/lib.linux-mips-2.7/urwid
copying urwid/vterm_test.py -> build/lib.linux-mips-2.7/urwid
copying urwid/lcd_display.py -> build/lib.linux-mips-2.7/urwid
copying urwid/container.py -> build/lib.linux-mips-2.7/urwid
copying urwid/text_layout.py -> build/lib.linux-mips-2.7/urwid
copying urwid/monitored_list.py -> build/lib.linux-mips-2.7/urwid
copying urwid/main_loop.py -> build/lib.linux-mips-2.7/urwid
copying urwid/raw_display.py -> build/lib.linux-mips-2.7/urwid
copying urwid/treetools.py -> build/lib.linux-mips-2.7/urwid
copying urwid/split_repr.py -> build/lib.linux-mips-2.7/urwid
copying urwid/compat.py -> build/lib.linux-mips-2.7/urwid
copying urwid/escape.py -> build/lib.linux-mips-2.7/urwid
copying urwid/command_map.py -> build/lib.linux-mips-2.7/urwid
copying urwid/widget.py -> build/lib.linux-mips-2.7/urwid
copying urwid/html_fragment.py -> build/lib.linux-mips-2.7/urwid
copying urwid/graphics.py -> build/lib.linux-mips-2.7/urwid
copying urwid/web_display.py -> build/lib.linux-mips-2.7/urwid
copying urwid/listbox.py -> build/lib.linux-mips-2.7/urwid
copying urwid/version.py -> build/lib.linux-mips-2.7/urwid
copying urwid/decoration.py -> build/lib.linux-mips-2.7/urwid
copying urwid/tests.py -> build/lib.linux-mips-2.7/urwid
copying urwid/vterm.py -> build/lib.linux-mips-2.7/urwid
copying urwid/font.py -> build/lib.linux-mips-2.7/urwid
running build_ext
building 'urwid.str_util' extension
creating build/temp.linux-mips-2.7
creating build/temp.linux-mips-2.7/source
ccache_cc -fno-strict-aliasing -Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -msoft-float -DNDEBUG -Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -msoft-float -fPIC -I/usb/usr/include/python2.7 -c source/str_util.c -o build/temp.linux-mips-2.7/source/str_util.o
unable to execute ccache_cc: No such file or directory
error: command 'ccache_cc' failed with exit status 1
----------------------------------------
Command /usb/usr/bin/python -c "import setuptools;__file__='/usb/pip-build/urwid/setup.py';exec(compile(open(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-0hssiH-record/install-record.txt --single-version-externally-managed failed with error code 1 in /usb/pip-build/urwid
Storing complete log in /root/.pip/pip.log
Requirement already satisfied (use --upgrade to upgrade): pyasn1 in /usb/usr/lib/python2.7/site-packages
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): BeautifulSoup in /usb/usr/lib/python2.7/site-packages
Cleaning up...
Requirement already satisfied (use --upgrade to upgrade): upsidedown in /usb/usr/lib/python2.7/site-packages
Cleaning up...

Any ideas?

TS

Link to comment
Share on other sites

  • 1 month later...

Despite my USB being properly formatted to Ex4 and all my other modules being installed are installing properly. MITM module absolutely does not want to install for some reason. I'll click install, and I'll sit there and wait and wait and wait only to find out that my pineapple rebooted, and I have to load it back up to access it through the browser and I check the MITM module and its not installed.

Are the creators of this module aware of this? Or is there a simpler way to perform MITM attack with the pineapple?

Thanks to anyone who can help.

Link to comment
Share on other sites

Despite my USB being properly formatted to Ex4 and all my other modules being installed are installing properly. MITM module absolutely does not want to install for some reason. I'll click install, and I'll sit there and wait and wait and wait only to find out that my pineapple rebooted, and I have to load it back up to access it through the browser and I check the MITM module and its not installed.

(I am using an 8GB USB. There should be enough room for this to install)

Link to comment
Share on other sites

this is how i got MITM module to work 2.8.0

Open pineapple control center shut off any and all running procs wifi ,cron jobs,karma whatever, go to Advanced TAB and clear cache.

Next set up USB partition,make it primary EXT4 and a swap of 2 gig or more, now open USB TAB and under (config swap) change the 0 to a 1 then Update fstab.

Now go to pineapple bar infusions MITM, install to USB wait for download to complete, now install the dependency's this is going to take a few mins so dont leave that page for anything,

It took me 30 mins that could be because im 1/4 mile away from neighbors AP, alpha parabolic antenna & alpha 36h card lol ,

anyway do not leave that page it will install if you follow these directions took me several times to get it to work and reading over this thread 3-4 times before i got it to work now im' sure it will work for all.

hope i have helped in some way.and thanks to all who posted here so i could figure it out.

Seems like a lot of work just to allow it to install. The other modules are simpler to install. Shouldn't the designers be working on a way to make this module easier to install?

Link to comment
Share on other sites

Seems like a lot of work just to allow it to install. The other modules are simpler to install. Shouldn't the designers be working on a way to make this module easier to install?

Not really. It just means you have to set up swap, something you should really have set up already when using USB storage and following Darren's guide.

There isn't really a way around it in this scenario.

Link to comment
Share on other sites

Hmm. Alright then.
Someone told me that all I had to do was format my 8GB USB to Ex4 and all the modules would work fine. Guess its not that simple for the MITM module. I tried using the Ettercap module to do MITM on the pineapple, but I wasn't really seeing that it was working at all.

Also, another thing, the module used to DNS spoof someone to the Rick Rolling or Nyan Cat, even when I disabled the module, it would still redirect people to those pages. I ended up having to completely uninstall it, and reboot the pineapple for it to go away.

Link to comment
Share on other sites

Could you login to your pineapple through SSH, go to the MITM infusion folder and type the following command:

sh install.sh

and post the output of the command.

same here installing on a blank pineapple isn't working. From what is saw going over the output for a short time it is trying to do a softlink on "/usb/usr/lib/ImageMagick-6.7.8/" which doesn't exist even after removing and reinstalling "ImageMagick" by hand.

Created a folder with the name "ImageMagick-6.7.8" by hand and copied over all the files created by the opkg package "ImageMagick" in it. Then the script installs at least more or less fine but there are still some warnings from the pip install but i guess this is normal. After that the web interfaces shows but correctly but the addon won't work, i can start it but it will not work at all.

here is the output of the install.sh on a blank pineapple with usb drive and swap:

Downloading http://cloud.wifipineapple.com/packages/Packages.gz.
Updated list of available packages in /var/opkg-lists/pineapple_packages.
Installing python (2.7.3-1) to usb...
Downloading http://cloud.wifipineapple.com/packages/python_2.7.3-1_ar71xx.ipk.
Installing libffi (3.0.10-1) to usb...
Downloading http://cloud.wifipineapple.com/packages/libffi_3.0.10-1_ar71xx.ipk.
Installing python-mini (2.7.3-1) to usb...
Downloading http://cloud.wifipineapple.com/packages/python-mini_2.7.3-1_ar71xx.ipk.
Configuring libffi.
Configuring python-mini.
Configuring python.
Installing python-openssl (2.7.3-1) to usb...
Downloading http://cloud.wifipineapple.com/packages/python-openssl_2.7.3-1_ar71xx.ipk.
Configuring python-openssl.
Installing imagemagick-tools (6.7.8-1) to usb...
Downloading http://cloud.wifipineapple.com/packages/imagemagick-tools_6.7.8-1_ar71xx.ipk.
Installing imagemagick (6.7.8-1) to usb...
Downloading http://cloud.wifipineapple.com/packages/imagemagick_6.7.8-1_ar71xx.ipk.
Installing libjpeg (6b-1) to usb...
Downloading http://cloud.wifipineapple.com/packages/libjpeg_6b-1_ar71xx.ipk.
Installing libtiff (4.0.3-1) to usb...
Downloading http://cloud.wifipineapple.com/packages/libtiff_4.0.3-1_ar71xx.ipk.
Configuring libjpeg.
Configuring libtiff.
Configuring imagemagick.
Configuring imagemagick-tools.
mkdir: can't create directory '/usb/usr/lib/ImageMagick-6.7.8/config': No such file or directory
cp: can't create '/usb/usr/lib/ImageMagick-6.7.8/config/': No such file or directory
cp: can't create '/usb/usr/lib/ImageMagick-6.7.8/config/': No such file or directory
Installing distribute (0.6.21-1) to usb...
Downloading http://cloud.wifipineapple.com/packages/distribute_0.6.21-1_ar71xx.ipk.
Configuring distribute.
Downloading/unpacking pip
  Downloading pip-1.3.1.tar.gz (247Kb): 247Kb downloaded
  Running setup.py egg_info for package pip

    warning: no files found matching '*.html' under directory 'docs'
    warning: no previously-included files matching '*.txt' found under directory 'docs/_build'
    no previously-included directories found matching 'docs/_build/_sources'
Installing collected packages: pip
  Running setup.py install for pip

    warning: no files found matching '*.html' under directory 'docs'
    warning: no previously-included files matching '*.txt' found under directory 'docs/_build'
    no previously-included directories found matching 'docs/_build/_sources'
    Installing pip script to /usb/usr/bin
    Installing pip-2.7 script to /usb/usr/bin
Successfully installed pip
Cleaning up...
Downloading/unpacking mitmproxy
  Downloading mitmproxy-0.9.1.tar.gz (3.1MB): 3.1MB downloaded
  Running setup.py egg_info for package mitmproxy

Downloading/unpacking netlib>=0.9.1 (from mitmproxy)
  Downloading netlib-0.9.1.tar.gz (58kB): 58kB downloaded
  Running setup.py egg_info for package netlib

Downloading/unpacking urwid>=1.1 (from mitmproxy)
  Downloading urwid-1.1.1.tar.gz (482kB): 482kB downloaded
  Running setup.py egg_info for package urwid

Downloading/unpacking pyasn1>0.1.2 (from mitmproxy)
  Error <urlopen error [Errno 131] Connection reset by peer> while getting https://pypi.python.org/packages/source/p/pyasn1/pyasn1-0.1.7.tar.gz#md5=2cbd80fcd4c7b1c82180d3d76fee18c8 (from https://pypi.python.org/simple/pyasn1/)
Exception:
Traceback (most recent call last):
  File "/usb/usr/lib/python2.7/site-packages/pip/basecommand.py", line 139, in main
    status = self.run(options, args)
  File "/usb/usr/lib/python2.7/site-packages/pip/commands/install.py", line 266, in run
    requirement_set.prepare_files(finder, force_root_egg_info=self.bundle, bundle=self.bundle)
  File "/usb/usr/lib/python2.7/site-packages/pip/req.py", line 1033, in prepare_files
    self.unpack_url(url, location, self.is_download)
  File "/usb/usr/lib/python2.7/site-packages/pip/req.py", line 1161, in unpack_url
    retval = unpack_http_url(link, location, self.download_cache, self.download_dir)
  File "/usb/usr/lib/python2.7/site-packages/pip/download.py", line 534, in unpack_http_url
    resp = _get_response_from_url(target_url, link)
  File "/usb/usr/lib/python2.7/site-packages/pip/download.py", line 569, in _get_response_from_url
    resp = urlopen(target_url)
  File "/usb/usr/lib/python2.7/site-packages/pip/download.py", line 143, in __call__
    response = self.get_opener(scheme=scheme).open(url)
  File "/usb/usr/lib/python2.7/urllib2.py", line 400, in open
    response = self._open(req, data)
  File "/usb/usr/lib/python2.7/urllib2.py", line 418, in _open
    '_open', req)
  File "/usb/usr/lib/python2.7/urllib2.py", line 378, in _call_chain
    result = func(*args)
  File "/usb/usr/lib/python2.7/site-packages/pip/download.py", line 123, in https_open
    return self.do_open(self.specialized_conn_class, req)
  File "/usb/usr/lib/python2.7/urllib2.py", line 1177, in do_open
    raise URLError(err)
URLError: <urlopen error [Errno 131] Connection reset by peer>

Storing complete log in /root/.pip/pip.log
Downloading/unpacking pyasn1
  Downloading pyasn1-0.1.7.tar.gz (68kB): 68kB downloaded
  Running setup.py egg_info for package pyasn1

Installing collected packages: pyasn1
  Running setup.py install for pyasn1

Successfully installed pyasn1
Cleaning up...
Downloading/unpacking BeautifulSoup
  Downloading BeautifulSoup-3.2.1.tar.gz
  Running setup.py egg_info for package BeautifulSoup

Installing collected packages: BeautifulSoup
  Running setup.py install for BeautifulSoup

Successfully installed BeautifulSoup
Cleaning up...
Downloading/unpacking upsidedown
  Downloading upsidedown-0.3.tar.gz
  Running setup.py egg_info for package upsidedown

Installing collected packages: upsidedown
  Running setup.py install for upsidedown

    Installing upsidedown script to /usb/usr/bin
Successfully installed upsidedown
Cleaning up...
root@Pineapple:/usb/infusions/mitm#

Link to comment
Share on other sites

I cannot get this module to install. I have tried through the web gui and by running the install.sh script. The problem occurs during the pip install of mitmproxy, during the install of urwid. It tries to call "ccache_cc", but that program is not installed. I'm not sure how to get it installed, or how to resolve the problem a different way.

Link to comment
Share on other sites

  • 1 month later...

hello , nice work ( in the text ;) )...

a) i make the install with a swap 2GB (stop ICS that was the key for me) and i follow the steps of velocityserial ... THANX

but ...

b) when i run the MITM just block my internet connection in clients ... no upsidedown , no snow , just "oops not connect from chrome" ... any help ?

thank you again

Link to comment
Share on other sites

  • 1 month later...
  • 1 month later...

hello, this is my first post in this forum, I'm looking for my infusions pineapple and I liked this, but I see no link or way to download ...

I'm a little lost. can you help?

Thank you all!

EDIT:

When work fine for me :)

The problem is the avast firewall.

Thanks!

Edited by Hits_s
Link to comment
Share on other sites

  • 8 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...