Jump to content

Setting up BT5R3 with 2 interfaces


Rincewind
 Share

Recommended Posts

Hi Guys

I am having trouble setting up BT5 with both my wlan0 and eth0 being up and active at the same time.

WICD seems to disable the wireless when i enable eth0 an vice versa.

I think i need to disable wicd and do it all manually but this is where i am falling down being a noob.

i think i have worked out how to setup eth0 manually without too many problems but wlan0 is giving me trouble.

ifconfig wlan0 down

ifconfig wlan0 up

iwconfig wlan0 essid Kittens

iwconfig wlan0 key kittensarecute - this line suggests i have the syntax wrong somewhere

Can i just enter the psk in plain text (seems pretty insecure to have this in plain text) or can / should i be using some kind of hash or hex equivalent.

Any help you can give would be much appreciated as i cannot play with my new favourite fruit based toy until i sole this one ;)

Thanks

Rincewind

Link to comment
Share on other sites

WEP you use key.

Example:


iwconfig wlan0 essid Kittens
iwconfig wlan0 mode managed
iwconfig wlan0 channel 1 (where 1 is the routers channel you want to connect to, but not required in most cases)
iwconfig wlan0 key kittensarecute
dhclient wlan0
[/CODE]

For WPA/WPA2, you need to create the wpa supplicant file to connect if doing it manually.

http://forums.hak5.o...gip#entry201419

Edited by digip
Link to comment
Share on other sites

runnig

Hi Guys

I am having trouble setting up BT5 with both my wlan0 and eth0 being up and active at the same time.

WICD seems to disable the wireless when i enable eth0 an vice versa.

I think i need to disable wicd and do it all manually but this is where i am falling down being a noob.

i think i have worked out how to setup eth0 manually without too many problems but wlan0 is giving me trouble.

ifconfig wlan0 down

ifconfig wlan0 up

iwconfig wlan0 essid Kittens

iwconfig wlan0 key kittensarecute - this line suggests i have the syntax wrong somewhere

Can i just enter the psk in plain text (seems pretty insecure to have this in plain text) or can / should i be using some kind of hash or hex equivalent.

Any help you can give would be much appreciated as i cannot play with my new favourite fruit based toy until i sole this one ;)

Thanks

Rincewind

if you insist on not running xserver and doing everything from tty why dont you use wicd-cli or wicd-curses to manage your connection settings instead of dickin around with iw and wireless-tools.

Link to comment
Share on other sites

Thanks guys. I followed digip's instructions and that worked like a dream and i can now have both interfaces up properly.

I will have a look at wicd cli later today and see if i can get any joy with that too.

I am still had trouble using the internet when i set it all manually as opposed to dhclient. I think route add default gw 192.168.1.1 solved the problem of adding the default gateway

Thanks gigip for such a quick response - i managed to get it all sorted later that night.

RW

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...