Jump to content

changing txpower on external card?


Recommended Posts

Hi guys i was trying to change the txpower on an external alfa wireless card (to get a better transmittion) via ssh on the pineapple but was not able to do so, has anybody tried to change it?

the commands i run are

iw reg set BO < this command runs fine >

iwconfig wlan1 txpower 30 < here i get the following error >

Error for wireless request "Set Tx Power" (8B26) :

SET failed on device wlan1 ; invalid argument.

maybe i should have a look on the openwrt forum but figured id ask on here also..

Edited by saeed662
Link to post
Share on other sites

Small stupid question:

Did you use a poweruser to run it. like root ? otherwise use sudo in front.

Also do the region change when your wireless is down.

Thx for your response, appreciate your effort to help.

the wifi is down and after a region change it only allows me to set txpower to 0 i set the region to BO n it accepts that. it wont even allow me to set the txpower back to 20 dBm. also im logged in as root.

i think the problem is with the openwrt's firmware,iv searched their forum couldn't find much that helped..

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...