Jump to content

No Access Points Showing On Site Survey


Recommended Posts

I've got the WiFi Pineapple Mk.IV, and it's been a rather fun tool so far. Unfortunately I seem to have ran into a problem with Site Survey, which is currently refusing to display any APs. Instead, it just shows "No data...".

When I first ran it yesterday, I had the same problem, but after a reboot it seemed to work fine. This morning I've ran into the same issue, and I can't get it to work at all, despite my Windows machine reporting 14 APs nearby. I've checked the logs and ran dmsg over SSH, and can't find anything unusual.

Details:

  • Mk.IV running firmware 2.7.0
  • Karma switched off (only Wireless and Cron Jobs switched on)
  • Site Survey version 2.5, running off USB
  • wlan0 is in monitor mode
  • Monitor interface is selected as mon0
  • Tried clicking Refresh APs and Refresh Clients - "Loading" appears for a second, but returns no data.
  • Tried sending captures to internal memory and USB - no difference.
  • Tried restarting wireless - no difference.
  • No Javascript errors.
  • Wireless LED doesn't seem to flicker.

Any ideas?

Edited by gsuberland
Link to post
Share on other sites

Surprisingly, that worked, as long as I stopped the monitor, stopped the wifi from the front page, started the wifi from the survey page, then started the monitor from that page too.

Any ideas why it makes a difference?

Link to post
Share on other sites

I look at it this way... The pineapple starts up with WiFi enabled and is busy doing it's job, this happens regardless of the modules you have installed. Turning it to monitor mode and doing a site survey is a different function with a module so it makes sense to me to stop one before the other. I don't see why modules can't be more integrated but it's not the only one that behaves this way.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...