Jump to content

Recent Openwrt/pineapple Incompatibilities With Ruby


JayBlack
 Share

Recommended Posts

When I first got my pineapple I could opkg install ruby and other ruby packages just fine. Ruby "still" works... but irb and gem won't. I've looked into the fact that /usr/lib/ruby is at /usb/usr/lib/ruby ... I linked it. After that I seemed to have progress except I get a "/usb/usr/bin/ruby: can't resolve symbol 'getipnodebyname'" error. It seems that OpenWRT has a bad file in the package. One source suggests downgrading the zlib library... but the link given is bad. Another seems to indicate it's a makefile difference and a merge to an old version will fix it.

Are we able to build/fix packages on the box? I really would like to use the full power of the Ruby language here. Help would be greatly appreciated!

Link to comment
Share on other sites

When I first got my pineapple I could opkg install ruby and other ruby packages just fine. Ruby "still" works... but irb and gem won't. I've looked into the fact that /usr/lib/ruby is at /usb/usr/lib/ruby ... I linked it. After that I seemed to have progress except I get a "/usb/usr/bin/ruby: can't resolve symbol 'getipnodebyname'" error. It seems that OpenWRT has a bad file in the package. One source suggests downgrading the zlib library... but the link given is bad. Another seems to indicate it's a makefile difference and a merge to an old version will fix it.

Are we able to build/fix packages on the box? I really would like to use the full power of the Ruby language here. Help would be greatly appreciated!

Hey JayBlack,

I would be happy to help you out there. Please let me know exactly what packages you need and I will get them sorted for you.

Please keep in mind that I am quite busy at the moment so it will take a day or so.

Best Regards,

Sebkinne

Link to comment
Share on other sites

These are the relevant tickets. Creating a link /usr/lib/ruby -> /usb/usr/lib/ruby fixed this ticket https://dev.openwrt.org/ticket/7804 and the current issue I'm having they still haven't resolved has to do with socket.so in the ruby-core package https://dev.openwrt.org/ticket/9873 . They say it's "still a problem in the Backfire branch (at least when building with eglibc as libc library)."

For others trying to install ruby you will need to install a downgraded version of zlib as indicated here http://www.hackup.net/2012/01/openwrt-and-scripting-languages-part-1/ ... this guy never bothered to fix the problem I've listed here.

I can't find the page that mentioned merging with the old makefile to get things to work. But this is all the info I can find via Google.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...