Jump to content

[BugReport] Why Is My Alt Key Not Working.


Daan
 Share

Recommended Posts

Hi,

Today I recieved my Rubberducky. While I was waiting for it to arrive I thought up some nice pranks. One is a MS Word version of the Lock Your Computer Message. I started working on it immediately. But....

Everything in the script works accept the ALT key. When the ALT+n command is given it produces a Ñ in the Word document. It should be pressing ALT+N to get some options on the ribbonbar. I even tried creating a small scritp opening a notepad and closing it with ALT+F4 but there the ALT key also does not work.

I am running on Win 7 and tried it on XP and Ubuntu. In Ubuntu I ran the script in Gedit to see what the output was and it also produced a Ñ.

The encoding of the script I tried was done with

Everything gives me the same stupid Ñ :wacko: . And not the wanted options on the ribbon bar. I am trying to add an image with an url. It works perfect when I type it myself in Word.

My keyboard setting is US international and I even tried US. Same problem.

Does anyone know a solution to my problem. It would give me a lot of more fun for some scripts when the ALT key would work.

Thanks.

Here is the script I use.


DELAY 2000
GUI r
DELAY 500
STRING winword
ENTER
DELAY 2000
STRING Blablablablablablabla
ENTER
STRING Blablablablablablabla
ENTER
ENTER
DELAY 500
ALT n
DELAY 500
STRING p
DELAY 500
STRING http://4.bp.blogspot.com/-ofvP1DGFrbU/T9C6s6ZFECI/AAAAAAAAF2o/dGM3UIzR29w/s320/pie4.gif
ENTER
DELAY 2000
CTRL p
[/CODE]

Link to comment
Share on other sites

See if it works on another computer. This will tell you if its a script problem or a computer problem. I would test it myself but I let one of my friends borrow mine. I would go ahead and try encoding it on a different computer too.

Make sure none of this is enabled when encoding your script:

http://tlt.its.psu.e...l#international

Check for any num lock, fn lock (function key), scroll lock, etc.

Edited by aPices
Link to comment
Share on other sites

Too bad. That did not do the trick.

I tried some other computers. Same problem.

Checked the keyboard settings. They are as they should be.

The weird thing is that if I type the commands manually on my keyboard it runs perfect. If the Ducky does it, it gives me the strange Ñ in the Word document instead of executing the ALT+N that would give me the ribbon options.

Any more ideas on this issue.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...