Jump to content

Awus Not Picked Up By Bt 5


Pwnd2Pwnr
 Share

Recommended Posts

Here we go... showing off the noob tan...

I am not sure what kind of attention this will grab; for there is a lot of "tutorials" and "how to's" for BT... in fact... too much. I was looking for my answer for a few days now... and still not sure what I am doing wrong.

Problem: Ubuntu detects my awus036h; awus036h won't get detected through Oracle VB BT5. I added a so called "USB 2.0 extension" for the damned thing; nothing. VirtualBox won't even detect that my awus is up from the main screen. I've iwconfig'd, ifconfig'd, ifdmyself in the face. Every tutorial shows instantaneous connection with the thing... ay caramba...

I have done my homework and teacher sent it home to "try again"... keep in mind I am new to Linux and probably am just missing a huge step... probably.

UPDATE: Just downloaded VMware and it works right off rip. How do I uninstall VirtualBox VIA command line?

Edited by Pwnd2Pwnr
Link to comment
Share on other sites

Honestly, I would stick with Vmware and skip vbox for now. They make a free player that should get you up and running with BT and you can just download and plop in the premade VM from the BT site, but on the configuration for vbox side, go into the settings, and make sure its connecting all USB devices and passing them to the VM upon plugging any of them into a USB drive to show up or pass directly to the VM, or its basically only going to show up on the host system. Quick way to tell, see if when plugged in, do a dmesg in the VM before and after the card is plugged in. If nothing changes, then the host system actually has access to the card and is not releasing it. If so, then its not being passed over to the VM, or the VM is misconfigured. If you do a dmesg before and after its plugged in, and the results at the bottom are different in the bt terminal, you should see something, if anything, including an error upon plugging in a usb device.

Link to comment
Share on other sites

VirtualBox was a power hog, too. It lacked so much functionality; I couldn't press ctrl+c or anything... it was ridiculous... but the VMware... I love it... so many options that are on the fly... minus the overly heavy VB Settings GUI.

Digip: Spot on, as always :) . I can bring up my chipset without any affect on connectivity. When I lend the Alfa to BT, my WiiMax automatically takes over on Ubuntu = win win! Only one conflict with my network and that is my awus036h now bypasses my internal NIC... so every 5 minutes or so it requests for me to enter the WiiMax 6250 Centrino wireless key in Ubuntu... so I disabled the internal NIC (I think) from the network manager. No problems yet. Cheers!

Mr-Protocol: The VB has a "fix" for the issue. It is an extension that you download from their site. I did that, followed the yellow brick road, and led me back to the forum and ask you guys... What is the deal with patches or fixes that don't patch or fix anything? Entirely different topic...

But, alas, one more issue... how can I uninstall VirtualBox in command line without the initial downloaded file? I think the person whom writes Oracles' help items may be trolling his own work; it seems their directions are of no use. I want that POS out of my box. It is wasting semi-valuable space

Nevermind... I pulled up my big boy pants and did it

apt-get remove virtualbox* (the asterisk made all of the difference) --purge

Hold the applause... jk

Edited by Pwnd2Pwnr
Link to comment
Share on other sites

I have the exact opposite experience. VMWare being the power hog and lacking functionality. Virtualbox has never done me wrong except for this USB passthrough on the alfa N adapter. Which VMWare and Virtualbox both had issues with.

You need to install additions to copy/paste from machine to machine lol. Same goes with VM Tools.

BTW, mind sharing a link for the "Fix"?

If you are talking about the USB 2.0 extension, yes I have that installed.

See: https://www.virtualbox.org/ticket/9511?cversion=0&cnum_hist=2

http://forums.hak5.org/index.php?/topic/27374-vbox-issue-with-awus036nha/

Link to comment
Share on other sites

Well, I've got 16GB of Ram, and about 2TB of space spread over 4 drives, and never had any issues with VMware other than on slow systems with little resources(school computers, not my own). I can see it being an issue on Windows 7 if you have a dual core with only say 4BG ram and slow disk drives, but I've got Vmware Workstation 8.x something or other, with the GPU acceleration, Hexacore AMD CPU (Phenom II X6 1090T 3.2Ghz) and an ATI HD6800 GPU. I've run Windows 8, 7 and Vista in VM's all at the same time side by side, with no issues and they can all do Aero, while my host OS Is Windows 7 64bit Pro. Personally, I only run Linux in VM's since it tends to be too buggy and unreliable for every day use, but I do have Backtrack 5R1 installed on my laptop natively, and works pretty decent with my wireless card. I've yet to update to the latest version. The laptop is running KDE, and I might wipe it and switch over to the 32bit gnome, since there seem to be more software support on the 32 bit stuff than on the 64 bit side(at least in the past anyway, some stuff on the 64KDE seemed to not work right but I've not tried R3 yet).

Edited by digip
Link to comment
Share on other sites

I never had any problems with Vmware, with Virtualbox I occasionally have. Plus I own an Alfa adapter and never had any issues with Backtrack being unable to detect it. It always works. Make sure you you have the latest updates installed.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...