Jump to content

Startx Command In Backtrack Doesn't Work.


Infiltrator
 Share

Recommended Posts

Hey guys,

Not sure if anyone has experienced this problem with the latest version of Backtrack. But when I tried to upgrade Backtrack to the latest "Distribution Upgrade Available" and after restarting the system, this is what I am getting, when typing the Startx command at the console.

Backtrack.png

By the way, I am using Virtualbox and the version of Backtrack is R3 KDE x64 bit. I've spend a lot of hours, researching on this issue and still can't find a solution.

I've read a few how-tos from the Backtrack website, including the forums, but had no luck.

Any comment or suggestion will be very much appreciated.

Thank you in advance.

Edited by Infiltrator
Link to comment
Share on other sites

Maybe you can trying starting the X server using /etc/init.d/gdm start instead of startx?

I will give it a try and I will let you know afterwards. Thanks for the suggestion.

Link to comment
Share on other sites

Few releases back they had issues with some graphic cards and drivers in addition to corrupt resource files in the native install versions, and having to remove files in the KDE version to make the gui load properly. Might be similar issue where you have to delete the resource files and let the system recreate them, but that shouldn't still be an issue. I could however see it being a vbox issues, since vmware seems to have better GPU support, might be something such as updating your virtual box to fix the problem, or trying to change the boot to use vesa mode and then reconfiguring/dpkg the xorg configuration for your system to fix it.

This is what we used to do in BT5 KDE x64 - http://www.ticktockc...l-instructions/ but I don;t know that it would help you in your situation. By the way, thats for installing vmware tools, you can ignore that part for vbox obviously.

Edited by digip
Link to comment
Share on other sites

Few releases back they had issues with some graphic cards and drivers in addition to corrupt resource files in the native install versions, and having to remove files in the KDE version to make the gui load properly. Might be similar issue where you have to delete the resource files and let the system recreate them, but that shouldn't still be an issue. I could however see it being a vbox issues, since vmware seems to have better GPU support, might be something such as updating your virtual box to fix the problem, or trying to change the boot to use vesa mode and then reconfiguring/dpkg the xorg configuration for your system to fix it.

This is what we used to do in BT5 KDE x64 - http://www.ticktockc...l-instructions/ but I don;t know that it would help you in your situation. By the way, thats for installing vmware tools, you can ignore that part for vbox obviously.

I've tried all that and still didn't work. I'm also running the latest verison of Virtualbox and after sometime of playing around with it, I decided to create another Backtrack VM. But this time, I am using Vmware as I always do. The virtualbox thing was only experiemental, as I never used it before.

Anyway, thanks for your help I really appreciate.

Edited by Infiltrator
Link to comment
Share on other sites

Yeah, for what its worth, I've never had any luck with vbox. Vmware has never really let me down, and only time I ran into a problem was with windows 8 and I had to update workstation to the latest in order to do the uefi bios boot thing that windows 8 requires, or you can't boot it in a VM. Other than that, vmware has always been solid for me and I have no reason to switch. it does what I need, and its not that expensive for workstation, worth every penny.

Link to comment
Share on other sites

Like digi said it sounds like maybe it's a driver issue. What updates did you install?

Can you boot it to the cli? If you can maybe you can run

lshw[/CODE]

and see what video driver you're using. You can also try to download the driver from the manufacturer's page, chmod +x it, and run it from the console. Once it is installed you can try the /etc/init.d/gdm start. That's how I normally install video drivers on my Ubuntu machines. Could also be a resolution issue. BT should ask something about display/driver settings on bootup, anything of interest there?

Link to comment
Share on other sites

Like digi said it sounds like maybe it's a driver issue. What updates did you install?

Can you boot it to the cli? If you can maybe you can run

lshw[/CODE]

and see what video driver you're using. You can also try to download the driver from the manufacturer's page, chmod +x it, and run it from the console. Once it is installed you can try the /etc/init.d/gdm start. That's how I normally install video drivers on my Ubuntu machines. Could also be a resolution issue. BT should ask something about display/driver settings on bootup, anything of interest there?

I can certainly boot into the CLI and even login, but when I execute the command startx, my desktop looks like the screen shot I posted. I think it has something to do with the distribution I upgraded Backtrack with, it somehow must have stuffed up some vital configuration file. Now on my Vmware Backtrack machine, I just issued the following commands, followed by a reboot.

[CODE]
apt-get update
apt-get dist-upgrade
[/CODE]

And I didn't have any problems whatsoever. I can boot into my normal Backtrack desktop just fine.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...