Jump to content

Recommended Posts

  • Replies 157
  • Created
  • Last Reply

Top Posters In This Topic

I start to think that my MK4 is broken,reflashed many-many times different firmware versions and Rever still "Waiting for beacon" no matter how to start it through web UI or ssh.

This module hasn't been updated in a long time. I doubt it is your pineapple. Try the command line.

Link to comment
Share on other sites

I start to think that my MK4 is broken,reflashed many-many times different firmware versions and Rever still "Waiting for beacon" no matter how to start it through web UI or ssh.

I also forgot to ask are you sure you are choosing a router that has the wps feature?

Cause I know hackrylix is using airodump-ng to do the access point scan and not using wash to do the scan.

and airodump scans for all ap and wash only scans for wps featured ap

Edited by demonjester
Link to comment
Share on other sites

I just tested you have to bring down wlan0, if you ssh in and issue

airmon-ng start wlan0

ifconfig wlan0 down

and then run reaver from the gui it will work

reavergui.png

Edit: another option is go to the gui/reaver-module scan for and select the AP you want to attack, start mon0 and then disable wlan0 then click attack.

Edited by kevambert
Link to comment
Share on other sites

I just tested you have to bring down wlan0, if you ssh in and issue

airmon-ng start wlan0

ifconfig wlan0 down

and then run reaver from the gui it will work

reavergui.png

Edit: another option is go to the gui/reaver-module scan for and select the AP you want to attack, start mon0 and then disable wlan0 then click attack.

Yep, I mentioned this on page 5 or 6

Link to comment
Share on other sites

I also forgot to ask are you sure you are choosing a router that has the wps feature?

Cause I know hackrylix is using airodump-ng to do the access point scan and not using wash to do the scan.

and airodump scans for all ap and wash only scans for wps featured ap

I'm sure about wps because tried that AP with reaver on nokia N900.

Strange that airodump-ng catches Beacons(ssh),wash can detect wps enabled APs(ssh), but reaver(ssh and gui)....is cursed.

Edited by satana77
Link to comment
Share on other sites

"Warning:Failed to associate to ......"

1)Install reaver module on usb

2)install reaver on usb from the module page

3)Disable AP from status page

4)enable wlan0 on reaver page

5)start mon0 from page

6)scan APs,choose target

7)disable wlan0

8)Start attack

Three last steps were advised earlier.

And wash is working after disabling wlan0.

Link to comment
Share on other sites

  • 2 weeks later...

Am having the same problem! am forever on the waiting for beacon :(

tried just about everything... really want reaver too.

Has anyone found the cause?

Iv tried with the inbuilt AP and with a Alfa card, i either get constant channel hopping or if i use the non hop option i get waiting for beacon for a infinite time

Edited by deviney
Link to comment
Share on other sites

Am having the same problem! am forever on the waiting for beacon :(

tried just about everything... really want reaver too.

Has anyone found the cause?

Iv tried with the inbuilt AP and with a Alfa card, i either get constant channel hopping or if i use the non hop option i get waiting for beacon for a infinite time

are you doing it through the GUI or CLI

Link to comment
Share on other sites

are you doing it through the GUI or CLI

I am using the GUI, its even managed to associate with the AP but it wont try pins now :o

This would be such a good tool if it worked.

How do you use the CLI because if you go to advanced an used reaver -i mon0 -b (MAC) -vv it would not show output as screen :/

Also everyone who has posted a pic seems to have their logs going to USB??? how did they change it to that?

Edited by deviney
Link to comment
Share on other sites

  • 1 month later...

Has anyone else worked out the "failed to associate" issue with Reaver? I have tried the following:

Firmware at 2.8.1 stable

Installed the reaver 0.4 module

~In Module~

Stopped wlan0

started wlan0

started mon0

scanned for APs

selected my AP (WPS enabled, good signal)

Selected auto detect and set channel choices

Started attack

At this point I get the failed to associate message. So I switched to the CLI via SSH.

~CLI~

ifconfig wlan0 down

airmon-ng start wlan0

ifconfig wlan0 up

ifconfig mon0 down

ifconfig mon0 up

reaver -i mon0 -b XX:XX:XX:XX:XX:XX -a -c 11 -vv

and I get failed to associate. So I tried using aireplay-ng

~CLI~

aireplay -1 5 (or 120) -a XX:XX:XX:XX:XX:XX -e ESSID mon0

comes back with "could not determine channel". Tried setting channel by dropping wlan0 and changing it using "iw wlan0 set channel 11" and still nothing. Tried doing the same for mon0 but regardless of the interface being up or down the interface states that it is busy when I try to change the channel of mon0.

At this point I am completely out of ideas. Any ideas?

*edit* I have also tried using the exact same reaver command on my Kali build running side by side and the reaver attack through Kali works fine. So I know my AP is not immune to the attack

Edited by airman_dopey
Link to comment
Share on other sites

I prefer using reaver and wash from terminal. I have had better luck this way.

The commands I use are:

airmon-ng start wlan0

ifconfig wlan0 down

wash -i mon0

reaver -i mon0 -b XX:XX:XX:XX:XX:XX -a -c XX -vv

If you don't know what wash does, it displays only WPS enabled access points.

Hope this helps.

-SymPak

Link to comment
Share on other sites

I prefer using reaver and wash from terminal. I have had better luck this way.

The commands I use are:

airmon-ng start wlan0

ifconfig wlan0 down

wash -i mon0

reaver -i mon0 -b XX:XX:XX:XX:XX:XX -a -c XX -vv

If you don't know what wash does, it displays only WPS enabled access points.

Hope this helps.

-SymPak

Thank you for your response. I tried following your commands and get the same thing. When I leave wlan0 up the "failed to associate" messages appear approx. once every 10-12 seconds. With having wlan0 down and only mon0 up the failed messages spam every second. With that being said, wash displays the proper APs in my area properly.

I think I am going to attempt to reflash my pineapple and start over and see if that makes a difference.

*EDIT* Reflashed, did an opkg update, opkg install reaver, and then ran the commands listed above, same thing. Tried bringing wlan0 back up, no change (other than the time between error messages again).

*EDIT 2* Tried on a seperate AP and same result.

Edited by airman_dopey
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...