Jump to content

Ubertooth One Firmware Programming Issue. $20 Bounty!


Recommended Posts

First of all I'm working with a backtrack 5 VM through parallels.

Been working on this for 14 hours straight, so I'm desperate.

I built my own ubertooth, checks out fine. flashed the bootloader onto it just fine too.

Now i'm working on flashing the bluetooth_rxtx.bin file onto it using ubertooth_dfu but I keep getting the following error:

No module named core
Traceback (most recent call last):
File "ubertooth-dfu", line 318, in <module>
print dfu.get_status( )
NameError: name 'dfu' is not defined.

The command I use:

python ubertooth-dfu write bluetooth_rxtx.dfu

bluetooth_rxtx.dfu is in the same folder as ubertooth-dfu. I've also tried flashing .bin, .hex, and all the rest of the stuff I can find.

I have the device in DFU mode with the only method I can, bridging pins 1 and 3 with a paper clip. Seems to work just fine as everything lights up to show DFU mode.

If anyone has the SLIGHTEST idea how I might could fix this, I'd be ever so thankful. And to the person who helps most/gives me a fix is of course the $20 bounty, if allowed on the forums. I've tried everything i can on both mac and backtrack 5 linux, seems like I've got everything but one small detail.

Thanks in advance for any and all replies!


Edited by alphax
Link to comment
Share on other sites

  • 1 month later...

# -----------compile firmware ------------

Try to use this : https://sourcery.mentor.com/sgpp/lite/arm/portal/package7815/public/arm-none-eabi/arm-2010.09-51-arm-none-eabi.bin

That worked for me...

Here is my messy notes from when i compiled firmware for my ubertooth..


apt-get install python-pyside.qtgui

apt-get install python-usb

apt-get install libusb-dev python-pyside python-numpy subversion

git clone git://ubertooth.git.sourceforge.net/gitroot/ubertooth/ubertooth

mkdir temp

cd temp

wget http://sourceforge.net/projects/pyusb/files/PyUSB%201.0/1.0.0-alpha-1/pyusb-1.0.0-a1.zip

wget http://sourceforge.net/projects/pyusb/files/PyUSB%201.0/1.0.0-alpha-2/pyusb-1.0.0a2.zip

unzip pyusb-1.0.0a2.zip

cd pyusb-1.0.0a2/

python setup.py install

cd ~/source/UBERTOOTH/ubertooth/trunk/host/specan_ui

# insert ubertooth (2 green lights) wait for 1 red light (USB) and run the following as root:

apt-get install libicu48

python ./specan_ui.py

apt-get install libfuse-dev libdbus-1-3 libdbus-1-dev obexftp libobexftp* libdbus-glib-1-2 libdbus-glib-1-dev obexfs python-gobject python-dbus bluez-hcidump

FORGET THE REST BELOW.. just test stuff

svn co https://pyusb.svn.sourceforge.net/svnroot/pyusb pyusb

# cd pyusb/trunk/

# ./setup.py build

# ./setup.py install

# cd ../../

# python specan_ui.py

wget http://downloads.sourceforge.net/project/ubertooth/ubertooth-r434.tar.gz?r=http%3A%2F%2Fsourceforge.net%2Fprojects%2Fubertooth%2F&ts=1337345333&use_mirror=dfn

$ git clone git://git.code.sf.net/p/libbtbb/code libbtbb

$ cd libbtbb/

$ gmake

$ sudo make install

hciconfig -a # List the device

# -----------compile firmware ------------

installer: https://sourcery.mentor.com/sgpp/lite/arm/portal/package7815/public/arm-none-eabi/arm-2010.09-51-arm-none-eabi.bin

SOME TEST FILES... SKIP.. https://sourcery.mentor.com/sgpp/lite/arm/portal/package8734/public/arm-none-eabi/arm-2011.03-42-arm-none-eabi-i686-pc-linux-gnu.tar.bz2

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...