Jump to content

Sandisk Cruzer Fit Write Protection On?


Recommended Posts

First of all, I love Hak 5 and u guys have done amazing work with the pineapple. I recieved my Mark IV a few days ago. I got the elite package with the 4gb USB. Set it up with he swap and for a couple days it worked great. All of a sudden, the pineapple can't write to the USB. Turns out the USB is now write protected. I have only used it with the pineapple. I can't seem to get the write protection off, can't format or remove the partitions. Tried with Fdisk, Gparted, disk utility (which says the system is NOT clean, but doesnt fix), LL-format tools in windows and pretty much every other solution I could find online. I did just recently update to the 2.6.1 with the cruzer plugged in. Then it works no more. I would just get another one, but I hate having an issue I can't figure out. Any help would be so much appreciated. Thanks again guys. I Love my Pineapple!!!

Link to comment
Share on other sites

I have 2 of those drives but 16 gig and have not had the misfortune yet. cross my fingers.

it is a known issue with the cruzer fit and a few other sandisk models, I don't think anyone got it fixed and there are post that sugest others have not either. It just plain sucks.

telot likes a thumb drive called Pico, says it's got great read/write speeds and no BS.

Link to comment
Share on other sites

I'm having this problem with my Cruzer Fit 16GB. I was testing the aircrack suite by capturing packets to the USB drive. I think the Pineappple became unresponsive at some point, and I'm guessing it may have rebooted. It's possible there was an open file stream to the USB when it rebooted. When I looked at the drive in Ubuntu, the first partition was still created but the 2nd partition (swap) seemed to have been deleted. The whole drive was read-only and I could not format the swap partition. I stopped there as I didn't want to format the drive just yet. Not sure what to do... Pico drives huh?

Link to comment
Share on other sites

I do had the same problem but i knew this from another Stick wich locked me out before.

This happens if the Stick is not properly ejected from the os.

Did send an email to scandisk they offered me to replace the stick.

Anyway that´s it your stick is locked and there is no way (at least i didn´t found a way and scandisk says the same) to unlocked it again, either buy a new one or contact scandisk about your problem.

If you want to i can post the email answer from scandisk with their solution (have to translate it from german into english tough).

Link to comment
Share on other sites

Having the same problem here! While creating the swap partition my Pineapple crashed and made my 16GB cruzer fit read only! Not even a low level format can fix it. Gone mail SanDisk to, want a new one. DealXtreme is charging me full shipment costs for there RMA service :-(

B.T.W I also have a 8GB version and that thing works fine a my MK4.

Edited by R04DRUNN3R
Link to comment
Share on other sites

Thanks guys for all the info and quick replies.

Odd that noone seems to have a working solution. Was looking through BT5 for any tools that'd force it open, but doesn't seem to be any, at least not that I've found.

Anywho, I'm using a different brand for now. Just nervous for it to happen again, and it'll keep nagging in my mind to figure out a solution.

Thanks again all!

Link to comment
Share on other sites

My SanDisk Cruzer Fit 4GB from Hak5 shop is completely hosed.

I formatted it with Disk Utility (on Lubuntu) exactly as described in the Pineapple instructions. All appeared OK. After inserting it into the Pineapple and trying to make swap, the Pineapple seemed to go nutz with several "No CGI" warnings, multiple disconnects/reconnects, botched reboots, no media in device and other error messages.

I tried examining the Cruzer with Gparted, but it can't even find the Cruzer. Nor will the Cruzer mount on the Mac. I tried using MacOS Disk Utility, which can usually fix anything including FAT32 drives, but it hard froze the Mac and that goofed up the Mac's boot drive.

I was able to repair the Mac with Disc Warrior, but can't fix the Cruzer. Nor can anything I've tried on Windoze repair the Cruzer.

Yes the Pineapple was powered from USB. It is only at the bottom of this thread:


that warns the Pineapple should be powered from the wall power supply. That should be at the *top* of the thread by Darren.

Edited by farfel
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...