Jump to content

Mk4 Firmware 2.6.4 Release


Sebkinne
 Share

Recommended Posts

  • Replies 90
  • Created
  • Last Reply

Top Posters In This Topic

Seb. I can't thank you enough. I just downloaded 2.6.3 and the feeling of relief that I got when I plugged in my AWUS036NH and finally saw it listed under iw list. I was set up and ready to just go buy an AWUS036H so that I could get this thing completely wireless.

You sir, have made my day.

Edited by mondrianaire
Link to comment
Share on other sites

Thanx, great work! See you already fixed phishlog, thats amazingly fast fixed! :) Not the biggest one, but still.. :)

Just wanted to make a little note for the stable release; -The language packs are not downloading, when trying to update language packs. The only language files in the languages folder is english 2.6.2 and 2.6.3.

Edit: Guess I should mention that this is with 2.6.3 flash :)

Edited by loozr
Link to comment
Share on other sites

Thanx, great work! See you already fixed phishlog, thats amazingly fast fixed! :) Not the biggest one, but still.. :)

Just wanted to make a little note for the stable release; -The language packs are not downloading, when trying to update language packs. The only language files in the languages folder is english 2.6.2 and 2.6.3.

Edit: Guess I should mention that this is with 2.6.3 flash :)

Yeah, that was done on purpose, I am working on a bit of an improvement on how to handle the language changes. Right now, if there are no changes I have to manually make a copy and rename the files. That gets old after a short while ;)

But yeah, I will do that for 2.6.3. There will be one last 2.6.4 release IF 2.6.3 is stable. the .4 will just fix a language thing and will then be marked as stable.

Best Regards,

Sebkinne

Link to comment
Share on other sites

Seb great work:-D my nha now comes up every boot just like last time. but now set to default as an ap with open-wrt for ssid so I changed /etc/config/wireless

from


config wifi-iface
option device radio1
option network lan
option mode ap
option ssid OpenWrt
option encryption none
[/CODE]

to

[CODE]
config wifi-iface
option device radio1
option network lan
option mode sta
option ssid OpenWrt
option encryption none
[/CODE]

making radio1/wlan1 managed mode instead of master.

one thing I did notice different is if wlan1 is up and when i deauth using mdk3 it does not deauth but with ifconfig wlan1 down it does?

BUT If I run this script to manually connect to my home wifi

[CODE]
#!/bin/sh
#Change the Mac address of the usb wifi to something random.
ifconfig wlan1 down
macchanger -A wlan1
ifconfig wlan1 up

#WPA2 - Let's assume we're going to connect to a WPA2 network
wpa_supplicant -B -D nl80211 -i wlan1 -c /usb/wpa_supplicant.conf
#WEP - Uncomment if you want to conect to a WEP network
#iwconfig wlan1 mode managed key your_key_here
#iwconfig wlan1 essid "your access point name here"
#OPEN - Uncomment if you want to conect to a WEP network
#iwconfig wlan1 essid "your access point name here"

#Setup ipforwarding via iptables.
echo 1 > /proc/sys/net/ipv4/ip_forward
#Reset iptables
iptables -F
iptables -X
iptables -A FORWARD -o wlan1 -i br-lan -s 172.16.0.0/24 -m conntrack --ctstate NEW -jACCEPT
iptables -A FORWARD -m conntrack --ctstate ESTABLISHED,RELATED -j ACCEPT
iptables -A POSTROUTING -t nat -j MASQUERADE
#Wait for 7 seconds to give enough time for association.
sleep 7
#Grab an ip via DHCP
udhcpc -i wlan1
[/CODE]

and then on top of that run mdk3 it deauths???

Link to comment
Share on other sites

  • 2 weeks later...

New firmware version 2.6.4 has been released.

Features have now been frozen and are being moved into the stable branch.

Once that step is complete, languages will be added for the next stable version.

Please note: The webUI is now ONLY accessible through http://172.16.42.1:1471.

While you can change this port, be aware that after the upgrade you will only find it there.

Best Regards,

Sebkinne

Link to comment
Share on other sites

Great! B)

Will test it as soon as I've taken backup of my configs..

Awesome. Persistent upgrades, something that is in the works. I actually have an itch to push that feature out asap but there are things that have a higher priority. This version to become stable for one.

Best Regards,

Sebkinne

Link to comment
Share on other sites

I upgraded to the new fw version, verified by all my settings being reset and not being able to access the UI from 172.16.42.1/pineapple/ however on the upgrade page, it still is showing current fw as 2.6.3. Just a bug?

I remember there being a way to check fw version from cli but I forgot. Sorry I could not be more useful.

Link to comment
Share on other sites

I upgraded to the new fw version, verified by all my settings being reset and not being able to access the UI from 172.16.42.1/pineapple/ however on the upgrade page, it still is showing current fw as 2.6.3. Just a bug?

I remember there being a way to check fw version from cli but I forgot. Sorry I could not be more useful.

Clear browser cache ;)

When you ssh into pineapple you can see the fw version in the welcome banner :)

Link to comment
Share on other sites

Clear browser cache ;)

When you ssh into pineapple you can see the fw version in the welcome banner :)

-Its accessed by a new url, so the browser would not cache the page load page from cache

-the welcome banner only shows minor release version (2.6), not revision numbers.

EDIT:*load page from cache

Edited by mondrianaire
Link to comment
Share on other sites

What is wrong with that link?

Sorry if I don't see what is wrong, had a long day.

If you could supply a bit more information that would be great!

Best regards,

Sebkinne

it's suppose to be 172.16.42.1:1471/index.php. the advance tab's url is correct just not status and config, note this is only an issue when viewing a module

EDIT:

I see the issue in navbar.php the first two links are missing a forward slash

also I went to use your bartender module after updating blacklister and I guess it also needs to be updated, should I wait for it to be fixed instead of the old way of packaging a module?

Edited by petertfm
Link to comment
Share on other sites

it's suppose to be 172.16.42.1:1471/index.php. the advance tab's url is correct just not status and config, note this is only an issue when viewing a module

EDIT:

I see the issue in navbar.php the first two links are missing a forward slash

also I went to use your bartender module after updating blacklister and I guess it also needs to be updated, should I wait for it to be fixed instead of the old way of packaging a module?

Awesome, thanks.

Change has been committed - will be in the stable branch.

I have updated Bartender to work properly.

Best Regards,

Sebkinne

Link to comment
Share on other sites

I finally updated the flash, blame the delay on Black Mesa :rolleyes:

Anyways, anyone else having trouble with modules with 2.6.4? I guess it's because of the port-change. I guess this is up to the module-writers to fix, but I thought I should mention it here, rather than posting in all the module thread's..

Link to comment
Share on other sites

I finally updated the flash, blame the delay on Black Mesa :rolleyes:

Anyways, anyone else having trouble with modules with 2.6.4? I guess it's because of the port-change. I guess this is up to the module-writers to fix, but I thought I should mention it here, rather than posting in all the module thread's..

A bit OT but Black Mesa is awesome.

Anyway, on topic, module developers need to fix this issue. The change was announced and is now permanent.

In version 2.7.0, the next stable release, all modules which are not updated will cease to be available.

Remember, this is a development version, so not all features may be available.

Best Regards,

Sebkinne

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...