Jump to content

Piggyback The Pineapple With Another Openwrt Device


FunkyMrMagic
 Share

Recommended Posts

I'm having a bit of a nightmare here, and I'm hoping that someone can help me out. What I'm *trying* to do is configure a TP Link WR703N to act as a wireless bridge for my pineapple thus:

Internet <====> Wireless AP <====> WR703N <====> Pineapple

I'm configuring the 703N as a minipwner, only I'm not completing the build, just building it up to the point that I have connectivity through to my wireless AP. At this point I have something along these lines:

Laptop eth0 on 192.168.1.111, connected to:

WR703N eth0/br-lan on 192.168.1.1, bridging to:

WR703N wlan0 on 192.168.2.21, connected to

Wireless AP on 192.168.2.1

With it setup like that, bridging works fine, and I can connect to the internet from my laptop, via the WR703N (and wireless is disabled, so it definitely IS going that way!), with no issues.

If I change the IP address on the WR703N to 172.16.42.42, and the IP on my laptop to mimic the pineapple as 172.16.42.1, then I can no longer bridge through the device. The only thing that has changed is the IP. If I try and ping from the laptop, it can't resolve DNS names, and times out trying to reach IP addresses. I've cleared ARP caches, and compared /etc/config/network ../system and ../wireless files a dozen times over, but nothing is different save the IP addresses.

Has anyone done something similar and experienced/resolved the issue?

Thanks

Link to comment
Share on other sites

...look into you iptables for nat forwarding and make sure that you are clear on which ip address you are changing as your wlan should still be 192.... and your lan/eth0 is the 172... also the gateway on the lan should be pointed to 192.... and then double check that you have the dhcp server turned off on the bridge but turned on via pineapple .... or i am just wrong and someone else can help you, failure is always an option, bu ti do hav ea similar setup and i spent a lot of time wrestling around with it only to find out my iptables weren't setup right.

Link to comment
Share on other sites

I am using a similar setup.

To make windows mimic a pineapple, remember to set your dns server and default gateway to 172.16.42.42 on the PC as well as setting the ip to 172.168.42.1, 255.255.255.0

As far as using the wifi pineapple as the ap, with an ethernet connection to a ddwrt router, operating as guest on a wireless network...

First check you are plugged into the PoE LAN port on your pineapple.(I'm using MKIV, but you havent specified)

Then check that you only have two entries in your routing table. I had plugged into the WAN/LAN port at one point, and acquired some other routes that were screwing my setup up.

You dont need DHCP on the WifiGuest router then, as the PoE LAN interface on the pineapple is a static ip, with the routing configured by default.

This makes for a fairly elegant solution as you can use the built in pineapple wifi for karma, use the ethernet port for internet, and use the usb for storage or an alfa. I'm using a DLink DIR-300 with DDWRT as my secondary router. Its nice cause it'll run off 5v.

Oh, and one last note, ADD YOUR WIFI GUEST ROUTERS MAC ADDRESS TO KARMA'S BLACKLIST!!!

this threw me off, as I was giving myself bad karma. This will stop you connecting to yourself accidentally.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...