Jump to content

Updated Aircrack Suite


SystemCrash86
 Share

Recommended Posts

I use backtrack 5r2 and i did apt-get upgrade and recieved a new aircrack upgrade. However this new upgrade doesnt work. When i use airmon-ng to place my card into monitor mode i get a response saying that my device is busy and when i try and use airdrop-ng and try and use my monitor interface it tells me that that interface does not exist. Everything worked fine before the update. Has anyone had similar issues with the latest version of aircrack. Does anyone have a solution?

Link to comment
Share on other sites

Try Airmon-zc instead, see what happens. I have issues with airmon-ng, which tends to make my card hang, as where airmon-zc, doesn't seem to have the same problem. Airmon-zc is like, whats supposed to replaced -ng at some point from what I recall.

Link to comment
Share on other sites

Yeah i tried airmon-zc and i still get the same result. I always use airmon-zc because of my wireless chipset anyway and everything was working until i apt-get upgrade in backtrack 5r2 and it updated aircrack suite and now it wont work, especially putting my card into moniror mode and using airdrop-ng.

Link to comment
Share on other sites

Try removing aircrack and then downloading it form their site directly, see what happens if you manually install it.

I do know the aircrack site was hacked into months ago, but as far as I know, source and binaries were not effected, only his forums I beleive. I had thought he stopped development for a while too, since the attack, so curious to know what kind of updates we're made to aircrack. Might be a new bug and a fix out soon if thats the case, try reporting it on the BackTrack bug tracker.

http://redmine.backt...arch?q=aircrack

Might already be addressed and a fix, or could be corrupted install, which removing and reinstalling might fix, but everything BackTrack related is kind of touchy, so when in doubt, revert to the latest distro download. In general, most people either use it live, or in a VM. if you had a VM, you could snapshot before every update, but would require a USB wifi card to work with it.

edit:

By the way, R3, will be out in a few days, so unless you have a native install, you can download the latest when it comes out, or try a dist upgrade when it does for native installs.

http://www.backtrack-linux.org/backtrack/backtrack-5-r3-release-aug-13th-2012/

Edited by digip
Link to comment
Share on other sites

  • 3 weeks later...

I am experiencing the same problem with both BT5R2 & R3.

I am so confused and have spent 5 to 6 hours today trying to get Airdrop to work, to no avail.

The problem seems to be with the dependencies, as lorcon2 and pylocon are tough buggers. On the online man page for airdrop, it mentions that it doesnt support newer versions of lorcon, and gives instructions to download old lorcon, however when I go to run airdrop, I get a dependency error requiring a liborcon2.so file to be in a /usr/lib directory. The file in question is available when lorcon2 is compiled, however it is named liborcon2-2.0.0.so, so the dependency error is still up. Copying//renaming the liborcon file to match what airdrop is looking for no longer gives me lorcon errors, however I do get the aforementioned error "Interface mon0 does not exist".

I wouldn't be chasing this so much except that airdrop is said to support client deauth management as well as station.

a simple rule of


a/[an ap]|[my mac or usb adapter]
a/[pineapple]|any
d/any|any
[/CODE]

Would make the pineapple into a wifi nuke, and would not permit anyone to use any internetz except my pineapple, while still allowing my pineapple to connect to an access point to route internet to.

Any ideas would help.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...