Jump to content

Bt5 R2 32Bit Gnome - Asus 1025C Netbook


Batman
 Share

Recommended Posts

Hi guys,

So I'm trying to install BT5 to the HD of my new netbook, and I'm having trouble with it.

When I go to install off of my USB drive, I get this screen [http://i.imgur.com/KlLU1.jpg]. I press "enter" to view the modes. [http://i.imgur.com/ArTwu.jpg]. I select mode 9 - 800x600x32 VESA and everything boots up completely fine. I installed BT5 to the HD with no errors. Then once restarting the computer to boot from the HD it starts loading up, and before getting to the term to login, I get this screen [http://i.imgur.com/Ecz22.jpg]. It lasts about 4 seconds and then the screen goes black with nothing on it. Nothing happens any further.

I'm assuming this is an issue with my default video resolution settings. They need to be changed to 800x600 from the 1024x720 or whatever the default is for BT. I've tried googling this with no solutions that have been helpful.

Does anyone have any suggestions?

Thanks.

Link to comment
Share on other sites

In the bootloader, which I assume to be Grub, you can provide the startup parameter "text" which will start things up in text-mode, allowing you to fiddle with the settings.

Alternatively, put the thing on a network, figure out its IP and SSH in to it (assuming you installed it and made it auto-start). From there you can easily "telinit 3" and take it from there.

Link to comment
Share on other sites

here's what happens.

here's what happens when i boot off live USB.

I chose mode 9 which is 800x600x32 VESA. It owrks perfectly fine.

Bootloader is grub.

Link to comment
Share on other sites

I figured it out. Here's what I had to do just incase anyone else has this issue ever:

In /etc/default/grub find the lines:

Code:

GRUB_CMDLINE_LINUX_DEFAULT="text splash nomodeset vga=791"

and change it to:

Code:

GRUB_CMDLINE_LINUX_DEFAULT="text splash"

&

Code:

GRUB_GFXMODE=800x600x32

underneath that line insert:

Code:

GRUB_GFXPAYLOAD=keep

GRUB_GFXPAYLOAD_LINUX=800x600x32

then in /etc/grub.d/00_header find the line:

Code:

if [ "x${GRUB_GFXMODE}" = "x" ] ; then GRUB_GFXMODE=800x600x32 ; fi

then insert below it

Code:

if [ "x${GRUB_GFXPAYLOAD}" = "x" ] ; then GRUB_GFXPAYLOAD=800x600x32 ; fi

In the same file, but farther down the page, find the line:

Code:

set gfxmode=${GRUB_GFXMODE}

insert below that line:

Code:

set gfxpayload=${GRUB_GFXPAYLOAD}

Save file and close.

Now run in terminal

Code:

# update-grub2

Edited by Batman
Link to comment
Share on other sites

I think you could run like noacpi and nomodeset to get it to initially boot until you can install third party drivers. Not sure, I only run it in VMs.

I just booted off of a USB and edited my File System files mentioned above in order to change the settings. I tried doing nomodeset with no help, but maybe that was because I didn't do noacpi as well. I am glad that I finally was able to figure it out.. It's so nice having a portable PC with BT5 on it! :D

Now I need to save up for a wifi pineapple!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...