Jump to content

Mk4 2.4.1 Firmware Release


Recommended Posts

Hey everyone,

After a while of not getting out any new firmwares, we are proud to present version 2.4.0.

Amongst a few nice changes and additions you will find that the pineapple UI is now available in multiple languages! Translating the UI has been made very simple and we are expecting to have it available in many more languages shortly.

Changelog:

2.4.1

  • Fixed some CSS that messes up when other languages than English are selected.
  • Fixed 3g support (kmod-usb-serial made a mess).
  • Fixed a string in upgrade.php

2.4.0:

  • Added more modems:
    • E173
    • More (will add later)

    [*]Added rt73 drivers

    [*]Added usb driver for gps

    [*]Fixed ping and traceroute interface

    [*]Appended last part of wireless MAC to SSID to tell pineapples appart

    [*]Infusion Changes:

    • Added Support link. Infusion devs can now add a support link to their infusions. This will allow the infusion users to quickly find help if they need it.
    • Removed launch link. Added link on Infusion name.

    [*]Bartender

    • Added Support link. Infusion devs can now add a support link to their infusions. This will allow the infusion users to quickly find help if they need it.
    • Removed launch link. Added link on Infusion name.

    [*]Multi-language support. We already support:

    • English
    • Spanish
    • Dutch
    • Arabic
    • Portuguese

    [*]Bartender feature (released as a module). Makes your infusion development easier!

Download: http://cloud.wifipin...nloads

MD5: 636e2dfacfc9860a1ccb3f43e9c35b6e

This release made proper use of our Beta testing system in an open beta and the results were amazing.

Our thanks go out to all the beta testers and translators who helped bring you this new 2.4.0 version!

As usual, leave any feedback here!

We hope you enjoy this!

-The Jasager Team

Link to post
Share on other sites

Minor cosmetic detail on stats page ;)

Line 126 of stats.php is:


echo "   Stealth <font color=lime><b>".$strings["status-enabled"]."</font>. | <a href=\"index.php?stealth=off\"><b>".$strings["status-disable"]."</b></a><br />";
[/CODE]

but should be:

[CODE]
echo "  Stealth <font color=lime><b>".$strings["status-enabled"]."</font>.  | <a href=\"index.php?stealth=off\"><b>".$strings["status-disable"]."</b></a><br />";
[/CODE]

To fix the stealth toggle alignment issue.

Also when switching to any other language the text will go out of bounds on 3G and SSH page, except for default english language.

Edited by WatskeBart
Link to post
Share on other sites

Minor cosmetic detail on stats page ;)

Line 126 of stats.php is:


echo "   Stealth <font color=lime><b>".$strings["status-enabled"]."</font>. | <a href=\"index.php?stealth=off\"><b>".$strings["status-disable"]."</b></a><br />";
[/CODE]

but should be:

[CODE]
echo "  Stealth <font color=lime><b>".$strings["status-enabled"]."</font>.  | <a href=\"index.php?stealth=off\"><b>".$strings["status-disable"]."</b></a><br />";
[/CODE]

To fix the stealth toggle alignment issue.

Also when switching to any other language the text will go out of bounds on 3G and SSH page, except for default english language.

We are aware of this issue, but we decided that we wanted to push out the main features first before doing some cosmetic bug-fixing.

Thanks for sharing that info WatskeBart

Hm - There should be a "BUG" section for Jasager here..

A bug section will be added. Not necessarily to the forum but it will be added ASAP.

Link to post
Share on other sites

Ace job but ive had to roll back to last version.

Im using a Huawai E367 3g dongle and rmmod usbserial no longer works on new 2.4.0 version.

I went back to old version and it worked, retried new version and it doesnt work.

root@Pineapple:~# ls /dev/ttyUSB*

ls: /dev/ttyUSB*: No such file or directory

root@Pineapple:~# insmod usbserial vendor=0x12d1 product=0x1506

insmod: can't insert 'usbserial': File exists

root@Pineapple:~# rmmod usbserial

rmmod: can't unload 'usbserial': Resource temporarily unavailable

root@Pineapple:~#

Link to post
Share on other sites

Ace job but ive had to roll back to last version.

Im using a Huawai E367 3g dongle and rmmod usbserial no longer works on new 2.4.0 version.

I went back to old version and it worked, retried new version and it doesnt work.

root@Pineapple:~# ls /dev/ttyUSB*

ls: /dev/ttyUSB*: No such file or directory

root@Pineapple:~# insmod usbserial vendor=0x12d1 product=0x1506

insmod: can't insert 'usbserial': File exists

root@Pineapple:~# rmmod usbserial

rmmod: can't unload 'usbserial': Resource temporarily unavailable

root@Pineapple:~#

Can you try re-flashing 2.4.0?

Best,

Sebkinne

Link to post
Share on other sites

brand new flash, no changes made, just plugged in usb 3g:

root@Pineapple:~# lsusb

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Bus 001 Device 003: ID 12d1:1506 Huawei Technologies Co., Ltd. E398 LTE/UMTS/GSM Modem/Networkcard

root@Pineapple:~# ls /dev/ttyUSB*

ls: /dev/ttyUSB*: No such file or directory

root@Pineapple:~# insmod usbserial vendor=0x12d1 product=0x1506

insmod: can't insert 'usbserial': File exists

root@Pineapple:~# rmmod usbserial

rmmod: can't unload 'usbserial': Resource temporarily unavailable

root@Pineapple:~#

rolled back, worked perfectly.

2.3.1:

root@Pineapple:~# lsusb

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Bus 001 Device 003: ID 12d1:1506 Huawei Technologies Co., Ltd. E398 LTE/UMTS/GSM Modem/Networkcard

root@Pineapple:~# ls /dev/ttyUSB*

ls: /dev/ttyUSB*: No such file or directory

root@Pineapple:~# insmod usbserial vendor=0x12d1 product=0x1506

insmod: can't insert 'usbserial': File exists

root@Pineapple:~# rmmod usbserial

root@Pineapple:~# insmod usbserial vendor=0x12d1 product=0x1506

root@Pineapple:~# ls /dev/ttyUSB*

/dev/ttyUSB0 /dev/ttyUSB1 /dev/ttyUSB2 /dev/ttyUSB3

root@Pineapple:~#

all working, just for fun i reflashed 2.4.0 and again it didnt work.

So it seems rmmod works on 2.3.1 but not on 2.4.0 L:(

Edited by sawks
Link to post
Share on other sites

brand new flash, no changes made, just plugged in usb 3g:

root@Pineapple:~# lsusb

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Bus 001 Device 003: ID 12d1:1506 Huawei Technologies Co., Ltd. E398 LTE/UMTS/GSM Modem/Networkcard

root@Pineapple:~# ls /dev/ttyUSB*

ls: /dev/ttyUSB*: No such file or directory

root@Pineapple:~# insmod usbserial vendor=0x12d1 product=0x1506

insmod: can't insert 'usbserial': File exists

root@Pineapple:~# rmmod usbserial

rmmod: can't unload 'usbserial': Resource temporarily unavailable

root@Pineapple:~#

rolled back, worked perfectly.

2.3.1:

root@Pineapple:~# lsusb

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Bus 001 Device 003: ID 12d1:1506 Huawei Technologies Co., Ltd. E398 LTE/UMTS/GSM Modem/Networkcard

root@Pineapple:~# ls /dev/ttyUSB*

ls: /dev/ttyUSB*: No such file or directory

root@Pineapple:~# insmod usbserial vendor=0x12d1 product=0x1506

insmod: can't insert 'usbserial': File exists

root@Pineapple:~# rmmod usbserial

root@Pineapple:~# insmod usbserial vendor=0x12d1 product=0x1506

root@Pineapple:~# ls /dev/ttyUSB*

/dev/ttyUSB0 /dev/ttyUSB1 /dev/ttyUSB2 /dev/ttyUSB3

root@Pineapple:~#

all working, just for fun i reflashed 2.4.0 and again it didnt work.

So it seems rmmod works on 2.3.1 but not on 2.4.0 L:(

The problem seems to lie with the new kmod-usb-serial-pl2303 drivers.

To fix this issue for now, remove them by issuing this command:


opkg remove kmod-usb-serial-pl2303 && reboot
[/CODE]

Then wait for the device to start again.

A bugfix version will be out soon.

Best,

Sebkinne

Link to post
Share on other sites

When Booting the mk4 with an rt73 in a usb hub, the rt73 takes over as wlan1 and the internal wifi wlan0 is down, im on 2.4.0 at the moment.

Tried to bring up wlan0 and i get no device found.

Link to post
Share on other sites

Could we make a firmware thread and have it stickied at the top of the forum? That way it is the first thing you see on the page, instead of having to sift through several threads to find the latest one.

As always, thank you all for your hard work. It is VERY much appreciated.

Link to post
Share on other sites

well, I have 2 pineapples and one is firmware 2.4.1 while the other is 2.3.1

I just updated (5 min ago) the one pineapple to 2.4.1 and am having problems with 3g. What is most interesting is that the device (zte mf591) is now mounted? at /usb. This solves some challenges I've had as far as installing modules, bla.bla, however it opened other challenges;

I can't get the 3g to dial!

And while I'm here reporting 'bugs' (perhaps this is not a bug, but instead it's me being retarded) I noticed today @ work while doing a live implamentation that once I enabled karma, I lost 3g connectivity. I am just too inexperienced to understand that one. How does the answering of probe requests affect routing? I am soooo lost on that one. I really want to understand it, but I 'spose as long as it works, I'll be happy, and perhaps one day I will understand it. Also; during said implamentation karma did not do it's 'thing'. I had not one ssid in the list of available networks that did not belong there. As a matter of fact, there were 3 ssid's. When I got home, I used the other pineapple and enabled karma. This was successful as I saw many 'available' networks to join. Some even had different signal strengths than others (which I thought was right on for it looked much more legit).

Link to post
Share on other sites

Been features for a while. If not in the GUI then via SSH.

you can change mac address for the external wifi adapters but to change the internal mac is going to mess with karma and wifi, I have played with figuring out a way to make it work together but still can't find a soulution? if someone has one? remember it may change the mac but then karma does not function.

Link to post
Share on other sites

you can change mac address for the external wifi adapters but to change the internal mac is going to mess with karma and wifi, I have played with figuring out a way to make it work together but still can't find a soulution? if someone has one? remember it may change the mac but then karma does not function.

Getting this to work won't be much of an issue, requires some changes on our side. It will be in a future release.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...