Jump to content

New To Wifipineapple, What To Do With Alpha Wifi Dongle


Recommended Posts

i just got the pineapple mark 3 pro bundle and it came with a alpha wifi dongle. i was just wondering why i would need this if my computer already had a wifi chip. i know this is most likely a stupid question but i am brand new to this stuff. thanks for the help.

Link to post
Share on other sites

That wifi adaptor has a chipset that will allow you to change the mode, such as managed, moniter mode etc. This allows attacks such as deauth which means disconnecting a specific client from a specific access point, or even all clients from all access points, this will improve the number of clients on your pineapple as they get kicked from their access points. You should look at the aircrack-ng packages, and their website- it provides good documentation on the tools and how to use them. The alfa wireless cards are high powered and high range, they support wireless injection and are almost the 'industry standard' for any kind of wireless based attacks.

Link to post
Share on other sites

i am trying to do a deauth attack just for fun and when i plug in the adapter and run the aircrack command (sudo airmon-ng) to find the chipset it doesnt find any. what do i have to do to get the computer to recognize it?

do a iwconfig to see what adapters are available wlan0 should be the internal command

so "ifconfig wlan1 up" should bring it up.

Link to post
Share on other sites
Posted · Hidden by lufthansa747, July 6, 2012 - No reason given
Hidden by lufthansa747, July 6, 2012 - No reason given

do a iwconfig to see what adapters are available wlan0 should be the internal command

so "ifconfig wlan1 up" should bring it up.

when i type iwconfig i get 2 lines. one is l0 and eth0 both say no wireless extension? i should be pluged into the poe lan port on the pineapple right?

Link to post

do a iwconfig to see what adapters are available wlan0 should be the internal command

so "ifconfig wlan1 up" should bring it up.

the adapter i am using is Alfa AWUS036NHA. when i type iwconfig i get 2 lines. one line is lo and the other is eth0. both say no wireless extension. what does that mean?

Link to post
Share on other sites

the adapter i am using is Alfa AWUS036NHA. when i type iwconfig i get 2 lines. one line is lo and the other is eth0. both say no wireless extension. what does that mean?

hmm not sure what is happening, if not already using the ac adapter power the pineapple with it, only have the nha plugged into the usb and you could always try a diff cable as some people have had duds

and make sure the firmware version is 2.3.1, I believe they added in support for the alfas in 2.3.0

Link to post
Share on other sites

hmm not sure what is happening, if not already using the ac adapter power the pineapple with it, only have the nha plugged into the usb and you could always try a diff cable as some people have had duds

and make sure the firmware version is 2.3.1, I believe they added in support for the alfas in 2.3.0

oh i think i might have set it up wrong. how should i set i up. should i have the pineapple powered up and then plug the alfa card into the usb port of the pineapple? and the pineaple is connect through ethernet to the computer?

Link to post
Share on other sites

oh i think i might have set it up wrong. how should i set i up. should i have the pineapple powered up and then plug the alfa card into the usb port of the pineapple? and the pineaple is connect through ethernet to the computer?

no you can have the ethernet and usb device connected from the start or after, It doesn't make much of a diff, I just wanted to make sure the issue wasn't power or usb cable related.

Link to post
Share on other sites

the adapter i am using is Alfa AWUS036NHA. when i type iwconfig i get 2 lines. one line is lo and the other is eth0. both say no wireless extension. what does that mean?

I'm Guessing since you only have lo and eth0 that you are issuing this command in the backtrack VM you mentioned in another post, if this it the case then you need to have the wireless adaptor plugged into the computer and set up a USB passthrough to the VM.

If you want to use this adaptor connected to the pineapple you need to log in via SSH to the pineapple, and you should end up with a prompt that looks like this:

root@pineapple#

you can then issue the aircrack-ng package commands and the wireless card will show up.

Link to post
Share on other sites

I'm Guessing since you only have lo and eth0 that you are issuing this command in the backtrack VM you mentioned in another post, if this it the case then you need to have the wireless adaptor plugged into the computer and set up a USB passthrough to the VM.

If you want to use this adaptor connected to the pineapple you need to log in via SSH to the pineapple, and you should end up with a prompt that looks like this:

root@pineapple#

you can then issue the aircrack-ng package commands and the wireless card will show up.

i am pretty sure i have setup the usb passthrough but still it doesnt work. what i did was downloaded the usb 2.0 extension pack and then clicked add fillter and selected the atheros device. do i need to downlaod the driver for the wifi card?

Link to post
Share on other sites

i am pretty sure i have setup the usb passthrough but still it doesnt work. what i did was downloaded the usb 2.0 extension pack and then clicked add fillter and selected the atheros device. do i need to downlaod the driver for the wifi card?

Not sure if this applys for mac, but with ubuntu you must have the oracle version, not the ubuntu repositery version.

The wireless card should show up as 'wlan0', whats does lsusb display? (from terminal in backtrack vm)

Link to post
Share on other sites

Not sure if this applys for mac, but with ubuntu you must have the oracle version, not the ubuntu repositery version.

The wireless card should show up as 'wlan0', whats does lsusb display? (from terminal in backtrack vm)

it does show atheros communications device listed. but still the sudo airmon-ng command doesnt show any devices.

Edited by lufthansa747
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...