Jump to content

Flash Drive With Elite Pkg Will Not Mount

Recommended Posts

I can't get the sandisk usb 4gb fit drive that came with the elite package to mount. I followed the gparted formatting instructions here: http://forums.hak5.org/index.php?showtopic=25706 and changed the fstab to match Darrens via the thread he made on how to do it. Everytime I type "mkswap /dev/sda1" I get the message "no such file or directory", the flash drive is blinking and the LED light is on constant on the mark IV. I've tried to reboot, and followed other tips I found through out the forum as well. Please help. Thanks.



Now when I type: "mkswap /dev/sda1" I get this message: "/dev/sda1: Device or resource busy"

Edited by BigFanOHak5
Link to comment
Share on other sites

I had the same problem. My mount points ended up being sda5 and sda6 some how. To find what yours are ssh into the pineapple, plug in the usb drive, wait one minute, then run "dmesg". It will be near the end. You can also check to see if it found the swap when you plugged in the USB by running "free".

P.S. After i got my working, if i boot with the USB plugged in it wont give DHCP over ethernet. If i boot without USB then plug USB in after boot it will give DHCP.

Edited by sUbZeRo
Link to comment
Share on other sites

the renumbering is from unplugging it and plugging it back in while the pineapple is still running, on fresh boot it will start at sda1

This is one first plug. I think it is because i used a partitioning tool i downloaded for windows since I didn't have a linux computer on hand at the time. Still doesn't explain the DHCP issue though. I get an error like:

DHCP packet received on eth0 which has no address

Link to comment
Share on other sites

I had something happen with minitools for windoze, gparted works nicely in BT5 VM

when i run the set up script on my VM eth1 is my pineapple and eth0 is my internet being shared

(script would like it reverse with default settings)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...