Jump to content

Can't Boot Virtualbox Vm With Thumb Drive


Sartori
 Share

Recommended Posts

I followed the instructions in this video; that part worked out just fine. The problem comes when I try to partition the disk (Virtual OS: Gentoo). Whenever I try to write (w) the new partition table with fdisk, the virtual OS freezes and this error message pops up:

error.png

I thought this might have to do with the thumb drive (Corsair Flash Voyager 16GB) being "Write Protected", so I tried the following suggestions:

Remove USB Memory Stick Write Protected:

How to remove a write protection from your USB memory Stick

1. Shutdown your computer or laptop

2. Insert USB Memory Stick into your laptop or Computer

3. Turn on laptop and then immediately start pressing (F8) key then Advanced Boot Options screen will come up

4. Select Safe Mode with Command Prompt

5. After loading files if your USB Memory Stick drive letter is (G) for example then write as

6. C:\windows\system32>G: and press enter

7. G:\>format G: and press enter

8. If ask you (Y/N) then press (Y) and press enter

9. Now a full format will start which remove write protection from USB Memory Stick.

Access was denied, so option 1 was dead in the water

1. Go to run, type regedit and press enter.

2. Navigate to the path:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies

If the registry key StorageDevicePolicies does not exist, you will need to create it manually.

3. Highlight StorageDevicePolicies, and then create a New DWORD (32-bit) Value named as WriteProtect.

4. Double click the key WriteProtect in the right window and set the value to 0 in the Value Data Box and press OK button

5. Restart your computer and see if this help

or

1. Start > search bar -> CMD and press enter

2. type< diskpart

3. type< list disk

4. type< select disk # (# is the number of the USB key)

5. type< attributes disk clear readonly

I did as options 2 and 3 instructed, no dice.

I'm at a loss here. I don't believe this has ever been addressed on Hak5, though it should be because it's a big enough pain in the ass to warrant a segment. Hope someone out there can help me out.

My Host OS is Windows 7 64-bit. The Corsair thumb drive is formatted NTFS.

Link to comment
Share on other sites

I'm using Virtualbox on Ubuntu and can confirm that it's crap software. Their USB functionality and shared folder functionality doesn't work.

Depends on how you configure it :)

Okay booting from USB in Vbox is pretty easy..

I did it in windows.

1- start -> run -> diskmgmt.msc check wchich Disk Number your Stick has ( remember that you have to reuse the file we will be creating you probably have to use the same port everytime.)

then cmd -> VBoxManage internalcommands createrawvmdk -filename “%USERPROFILE%”.VirtualBoxusb.vmdk -rawdisk \.PhysicalDrive#

my personal example is-> VBoxManage internalcommands createrawvmdk -filename D:\Images\Virtualbox\usb.vmdk -rawdisk \\.\PhysicalDrive1

-> USB.vmdk sucessfully created.

Now create ur virtual machine as usual and point the image to this VMDK file.

And ur Vbox will boot directly from your USB.

hmmm lol--here is an english version _> http://www.pendrivelinux.com/boot-a-usb-flash-drive-in-virtualbox/

Edited by Yamada Taro
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...