Jump to content

Metasploit And Armitage


psydT0ne
 Share

Recommended Posts

fresh install of windows 7 x64

downloaded metasploit community edition (armitage is bundled)

installed

went to Framework Update

updated all ok

Created an account using their web browser GUI and activated using a community license.

Closed browser.

started armitage and was asked to connect to the database....

changed the details in armitage to the port that metasploit install said it was on 3790

entered the logon details for the account i created in the webgui.

armitage attempted to connect and then.......nothing....box closed... no errors...nothing.

i really haven't got a clue beyond this....

any ideas?

Link to comment
Share on other sites

You have Java installed? Armitage is Java based.

Link to comment
Share on other sites

BackTrack 5r2 in virtual box VM...

ran msfupdate

ran msfconsole

tried to run armitage

now i get :

org.postgresql.util.PSQLException ERROR: relation "workspaces"

the fix for this?

run msfconsole.......WHICH I ALREADY FUCKING DID!

ran it again.......SAME FUCKING ERROR>

RAAWRARRWRASRARRRRRRRRRRR!!!!

Link to comment
Share on other sites

armitage, if you mistakenly updated it to latest, will require metasploit 4 branch. Everything in BT5R2 works out of the box, but if it gets hosed, install the metasplut run file manually, which will give you the latest metasploit and latest armitage. Once that is done, everything will work as it should, but if you start metapsloit without doing the updates, you would be ok there too, just running version 3 by default. In the R2 build I think both are installed side by side, wcih causes some of the issues. For me, I instlaled MSF4 manually, and always chang edirectory to the /opt/metasplit folder to start everything form there. Also, when instlaling, let it instlal metasploit as a service to start on boot, so when starting armitage, it will start everything for you if it isn't already.

Notes. Besfore doing the metasploit install, in bt5r2(32 bit, 64 still bit wonky) do apt-get update, apt-get upgrade, and apt-get dist-upgrade, then manually install metasploits latest fromt he run file off their website and all should be good. If you don't update anything, then it will work out fo the box, but with out dated msf modules. Also, change to the directory where the new installation is and do an svn update from there, I skip msfupdate, always seems to hose things for me for some reason.

Edited by digip
Link to comment
Share on other sites

thank you very much mate, i appreciate the time you took to explain it to me.

i shitcanned the vm and i'll start again, (cool thing about vms:) )

you're defintely correct about things working from the box, as armitage and msf all work as they should when using the "live" backtrack...

i'll let you know how i went.

Link to comment
Share on other sites

By the way, I think msf3 and 4 are installed together in bt5, which might be part of the confusion on why shit gets borked. For instance, I have a native install of BT5R1 on my laptop. Doing the svn update updated metasploit, but then armitage would fail due to the newer branch of metasploit 4 and later. This required me to manually install metasploit 4.xxx whatever the latest is. Once that was done, Armitage worked again. You can use it without armitage, but I like to see the machines al in a gui and when they light up once compromised. I'm a noob from the console with metasploit, so I use Armitage as a cruch, but it also helps me learn the commands since you can see in the console what to type. Kind of teaches you at the same time.

http://www.fastandeasyhacking.com/faq

Edited by digip
Link to comment
Share on other sites

Well i successfully got metasplut and armitage to work on the vm install of backtrack5 r2.

Now i'll work on actually using it on my home network and then updating everything.

Never majorally into linux, let alone backtrack...but i thought fuck it, its about time.

thanks again for your help :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...