Jump to content

Poor Wifi Signal Range

Recommended Posts

I just started to experience VERY poor signal range after I re-flashed the 2.7.0 firmware via web interface. Originally, I had an issue when trying to power the Pineapple via the wall outlet, and had an unpowered hub supporting an Alpha AWUS036H and 16gb sd card. I realized my issue then was one of power, or the lack there of, but had to re-flash the firmware OTA due to some issues with the wireless interface going completely down after that. At the time I wasn't able to enable wireless at all, so hence, the re-flash of 2.7.0.

Since my re-flash, I've had absolutely zero range with my pineapple (everything else works fine though, just no range). I have the standard antenna attached and cannot get any of the three PC's (all different OSs) or my Android phone to connect. I was able, later, to get my phone to connect by physically holding it ON the antenna, but as soon as I move 3-5+ feet away, the connection completely drops. My range use to be AMAZING. The only way I can connect flawlessly is via ethernet. Anything wireless isn't connecting, or if by chance it does, it have to [literally] be on top of the Pineapple.

I've tried three different antennas, all 5dBi (which again, have worked great up until now). There was no range difference noted. The pineapple is transmitting at 18dBm. I've tried two different methods of supplying power, the wall plug and the usb, both have the same result. I then cracked the pineapple open and checked the antenna cable, as the thread suggested, and it appears that it is fine. It wasn't twisted, even thought the nut had come loose. I checked the connection to the board and it was fine. Guess my next step is to order some replacement RP-SMA to U.FL cables and see how that goes.

Not sure why this problem started shortly after I re-flashed, but this clearly is an antenna cable issue. Have those who replaced the RP-SMA to U.FL cable had their issues resolved, or has it been a mixed bag? Also, does anyone know what could cause this issue with the antenna cable, or are they just fragile?

Anyway, I just wanted to "chime in" since there seems to be an issue with these cables. Maybe they'll resolve the issue with the company or stock replacement cables in the HakShop in the future :) . Any updates / suggestions from those who have also experienced this problem?

EDIT: I actually just ordered this U.FL to RP-SMA cable and I hope it works out. The description said its "high quality" and looks a lot more sturdy than the one installed now. Its a little more expensive than the other ones, but if it stands up than it will be worth it. Just incase anyone else was looking for a better cable than the standard one.

Edited by Scout32
Link to comment
Share on other sites

  • Replies 54
  • Created
  • Last Reply

Top Posters In This Topic

UPDATE: I just received two new U.FL to RP-SMA cables in the mail. The oen I linked above isn't 6" as advertised, its 8" and doesn't fit that well. Anyway, I was hoping the new connector would fix my WiFi range, but sadly, it didn't. I still can't connect via WiFi from more than 3-5 feet away from the unit, line of sight. I used to be able to connect to the pineapple while it was in my office (2nd floor) and I was in my living room (1st floor) with zero problem. Also, I use Site Survey to find local APs... my laptop picks up approximately 20... my pineapple doesn't pick up a single one now. The only way I was able to get my laptop to connect to the pineapple was to have the pineapple sitting [literally] on the keyboard. Odd, however, when 'connected' via WiFi my laptop is showing full signal strength, but I have one hell of a time getting into the WUI. Most times it times out, along with pings to the pineapple.

This is really frustrating now, as it worked great for the first few days I had it, then it all of a sudden stopped. I'm not sure what else to do other than exchange it at the HakShop.

Does anyone have any suggestions or ideas as to how I can fix this? Also, what range are other people seeing in line of sight or obstructed/walled environments? I'm literally getting 1-2 feet maximum with a 5dBi antenna (where before it was much greater).

Hardware: Mk IV

Software: 2.7.0

Things I've done to try and fix this:

  • I've tried two different U.FL to RP-SMA cables, both brand new
  • I've tried 5 different antennas, four 5dBi and one 9 dBi (very slight improvement with 9dBi... one whole foot LoS).
  • I've run the Pineapple on three different forms of power: Laptop USB, wall plug, and my newly acquired Anker Astro3 fully charged... same results on all three
  • I've changed channels from 11 to 6 to 1... everything except 12 & 13.
  • I've reflashed OTA twice now (pineapple plugged into the wall, ethernet cable to pc > go to web ui and click upgrade > Check for Upgrades > then "Re-Flash 2.7.0?"... I've never entered anything into the Perform Upgrade section where you can add an upgrade.bin and md5... I've only clicked the "Re-Flash 2.7.0" link under "Check for Upgrades".
  • I have NOT reflashed since replacing the antenna cable... I'm going to give that a shot in a few.

Am I re-flashing wrong? Missing a step? Or does it sound like my pineapple's wireless is just FUBAR?

My iwconfig looks like this:

Execute: iwconfig wlan0
wlan0 IEEE 802.11bgn Mode:Master Tx-Power=18 dBm
RTS thr:off Fragment thr:off
Power Management:on

My wireless configuration file (/etc/config/wireless) looks like this

config wifi-device radio0
     option type     mac80211
     option channel  11
     option macaddr       00:c0:xx:xx:xx:xx
     option hwmode 11gn
     option htmode HT20
     list ht_capab SHORT-GI-20
     list ht_capab SHORT-GI-40
     list ht_capab RX-STBC1
     list ht_capab DSSS_CCK-40

config wifi-iface
     option device   radio0
     option network  lan
     option mode     ap
option ssid "noInternet"
     option encryption none

Is there another file / location I need to be looking at to solve this or find the potential problem, or does this sound like a hardware issue?

Any help / suggestions would be greatly appreciated! Thanks!

Link to comment
Share on other sites

  • 4 months later...

I had the same problem; I received my MKIV int he mail, opened it and proceeded to assemble. Little did I know that the nut on the inside was not tight. I assumed I should turn the antenna until it was semi-tight. The only problem with that line of thought was it didn't stop turning, it started to get tight at one point then just snapped the cable off inside. When I realized what I had likely just done to the unit I got out the screw driver set to open this bad boy only to quickly learn that the transparent piece of plastic on the front is a bit thin =P and snapped it in half. In the end I ordered another cable, figured the appearance wasn't as important as function and wrote the face plate up as a learning experience. The unit is now working as expected.

Link to comment
Share on other sites

  • 2 months later...


I too am having this issue after purchasing a wifi-pineapple. I have tried the various solutions posted here. I purchased a batch of 5 cables because others here have posted that they had to purchase a couple before the got a working one. I have seen no improvement. I had a few antenna/s sitting around and none of those less the 9db unit have improved the signal strength and then that only took it from maybe 10 feet max range to 20-25 and did not oddly enough seem to improve the range to which the unit could see other wifi signals, only the range in which other devices could see (but not connect reliably) to the pineapple.

I have also upgraded from the 2.8.1 firmware to the 3.0.0 firmware. Although the pineapple gui seems to respond better (faster) the weak signal issue has not been resolved. I have also played with changing channels, and checked the broadcast strength (18db).

Reading the many threads that have been posted on this site there seems to be this assumption that this issue only comes in one form, bad cable. I can promise you I have spend hours dicking with replacement cables and seen no improvement to date.

What other options do we have? Can it be returned?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...