Jump to content

Backtrack 5r2 And Pineapple Mkiv


Recommended Posts

I've recently switched my main OS from Ubuntu 11.10 to Backtrack 5 R2 and I can't seem to use both my ethernet port and my wifi card at the same time. This was not an issue however using Ubuntu and I'm not quite sure why it is using Backtrack when they are very similar. This is part of the output I get using lspci to find my network adapters:

02:00.0 Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)

If anyone has any suggestion to fix this it would be great so that I can use my pineapple again.

Link to post
Share on other sites

I've recently switched my main OS from Ubuntu 11.10 to Backtrack 5 R2 and I can't seem to use both my ethernet port and my wifi card at the same time. This was not an issue however using Ubuntu and I'm not quite sure why it is using Backtrack when they are very similar. This is part of the output I get using lspci to find my network adapters:

02:00.0 Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)

If anyone has any suggestion to fix this it would be great so that I can use my pineapple again.

You have to disable the networking manager. Right click the icon and disable networking or kill it in terminal.

Link to post
Share on other sites

I killed the process but was unable to use iwconfig to connect to the network. This is the command I used to try to connect to my home network.

iwconfig wlan0 essid Network_Name key s:Network_Pass
Error for wireless request "Set Encode" (8B2A) :
    SET failed on device wlan0 ; Invalid argument.

But as you can see it failed to set the key and every time I've tried to find another way to do it it's always the same result.

Link to post
Share on other sites

I killed the process but was unable to use iwconfig to connect to the network. This is the command I used to try to connect to my home network.

iwconfig wlan0 essid Network_Name key s:Network_Pass
Error for wireless request "Set Encode" (8B2A) :
    SET failed on device wlan0 ; Invalid argument.

But as you can see it failed to set the key and every time I've tried to find another way to do it it's always the same result.

you might want to look into wpa supplicant.

I have my bt comp use it to connect to any wpa wifi networks, it's a bit tricky to set up

Link to post
Share on other sites

That get it working for you?

No unfortunately it's not working for me. I removed wicd and wicd-gtk to make sure those weren't an issue anymore and now I just use wpa_supplicant to connect to my network. The issue is when I plug in the ethernet cable from my pineapple to my laptop it's not even recognized. I can connect fine over WiFi to the pineapple and manage it like that bt i don't have a second wifi card to tether it to.

Edited by E1337Recon
Link to post
Share on other sites

:) I logged in to ask this same question and have tried all the above.

I start up wifi. Turn off manager. Plug in mark4 and run the script.

It kicks my wifi every time.

How do I kill manager in terminal?

'service network-manager stop'

Network-manager: unrecognizable service

Edited by sneakyaussie
Link to post
Share on other sites

/etc/init.d/wicd stop

This shuts off wlan0 or eth0.

Bt5 r2.

Mk4 1.1.1?

Alfa awus036h

I can connect no problems to mk4/eth0.

I can connect to interwebs with Alfa wlan0

I cant tether as it boots me off wireless to connect to eth0... Aaaaagh lol

Can I replicate this- 245 times

Also tried dhclient wlan0 as suggested.

I have cat6 wired through my house. I can't understand why I can't plug mk4 into one of these points and bypass the Alfa altogether to tether the mk4.

Edited by sneakyaussie
Link to post
Share on other sites
  • 2 weeks later...

Hey guys, been a forum crawler for a while. Just got my mk IV today, but have been running a v2 for about a year. I had to share this, because I used to have the same problems. I discovered this a few months ago.

The simplest way is to just change the wired interface in wicd preferences. You will be able to run pineapple.sh and still use network manager.

HTH :)

K.

Link to post
Share on other sites
  • 8 months later...

Hey guys, been a forum crawler for a while. Just got my mk IV today, but have been running a v2 for about a year. I had to share this, because I used to have the same problems. I discovered this a few months ago.

The simplest way is to just change the wired interface in wicd preferences. You will be able to run pineapple.sh and still use network manager.

HTH smile.gif

K.

Do you use this steps:

Start BT

Start WICD and change the wired interface (ex. etho to eth5)

Connect to wireless network

Run ./wp4.sh

Ready to go?

Sometimes doesnt works for me.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...