Jump to content

I Need Some Help.. I Am In Search Of A Wifi Pineapple


Recommended Posts

I need some help.. i am in search of a wifi pineapple mentor how can helps me setup, aim willing to pay for the help. Here is my situation.

-I have a macbook pro (osx lion) vmware and parralles installed

-newest pineapple mk4 with newest firmware.

Could you or do you know some one how can teach me the usage of the mk4(i have decent knowledge of tcp/ip,etc. The best would be with teamvieuwer and Skype video. Hope to hear from you.

Greetings,

redboxtein

Edited by redboxtein
Link to comment
Share on other sites

We have the pinned thread on this forums about OSX and the pineapple...but its kind of all over the place with its instruction. I've got my macbook at home, I'll hook you up later tonight with some real instructions on how I got it to work.

telot

Link to comment
Share on other sites

@Darren, i understand it, iknow that its good to sort things out your self. And to it yourself the trail and error way, " the hacker mentality" But i put so many hours in it and have been reading so much... That i lost track.... and that i just need a mentor you can help me.... And iam willing to pay for her or his help... thats not wrong right?

@telot that would be awesome thanx!

Edited by redboxtein
Link to comment
Share on other sites

@Darren, i understand it, iknow that its good to sort things out your self. And to it yourself the trail and error way, " the hacker mentality" But i put so many hours in it and have been reading so much... That i lost track.... and that i just need a mentor you can help me.... And iam willing to pay for her or his help... thats not wrong right?

@telot that would be awesome thanx!

Sorry I wasn't able to get to this last night as promised, I ended up working very late and didn't have time for pineappling (so sad). Ok lets get started!

First connect to wifi on your Macbook. Second plug in your power to the mark4 and ethernet from POE port on mark4 to ethernet port on macbook. Then open Network Settings in System Preferences on Macbooky and click on Ethernet on the left. Configure IPv4: Manually. IP address will first be 172.16.42.42 Subnet is 255.255.255.0 Router left blank. Click Advanced and then the DNS tab and Add 8.8.8.8 and click OK. You should then be able to ping your mark4 from the terminal and access 172.16.42.1/pineapple in your browser to get to the pineapple config page. After verifying this, open a terminal and ssh root@172.16.42.1 user is root, password is pineapplesareyummy then nano /etc/config/network to look like this:

config interface lan

option ifname eth0

option type bridge

option proto static

option ipaddr 192.168.2.254

option netmask 255.255.255.0

option gateway 192.168.2.1

option dns 8.8.8.8

DONT MESS THIS UP!!! If you screw this up, in all likelihood you WILL NOT be able to access your pineapple without a soft/hard reset - avoid it by making sure you type correctly. Then Ctrl+x to escape and save. Unplug your pineapple from your laptop and once again go to Network settings. This time change the Ethernet Manually assigned IP address to 192.168.2.1 - leave everything else the same. Then go into System Preferences -> Sharing and check the box "Internet Sharing" share your connect from Wifi to Ethernet (make sure its checked). and then close that. Plug in your pineapple and give it a go!

Hope this helps

telot

Edited by telot
Link to comment
Share on other sites

@telot wow thanks! one questions: what should i do here: (what are the exact steps?)

nano /etc/config/network to look like this:

config interface lan

option ifname eth0

option type bridge

option proto static

option ipaddr 192.168.2.254

option netmask 255.255.255.0

option gateway 192.168.2.1

option dns 8.8.8.8

Link to comment
Share on other sites

@telot wow thanks! one questions: what should i do here: (what are the exact steps?)

nano /etc/config/network to look like this:

config interface lan

option ifname eth0

option type bridge

option proto static

option ipaddr 192.168.2.254

option netmask 255.255.255.0

option gateway 192.168.2.1

option dns 8.8.8.8

Type nano /etc/config/network

Scroll down to the "config interface lan" section and make it look like the above.

hit Ctrl x then y then enter

Nano is a text editor like vi. Kinda like using notepad instead of Word. They both do basically the same thing, but notepad is a shit ton easier to use. ;)

Edited by barry99705
Link to comment
Share on other sites

then i reciev this error message:

BusyBox v1.19.3 (2012-02-21 19:25:47 GMT) built-in shell (ash)

Enter 'help' for a list of built-in commands.

_______ ________ __ \

| |.-----.-----.-----.| | | |.----.| |_ \ \

| - || _ | -__| || | | || _|| _| \ \ \

|_______|| __|_____|__|__||________||__| |____| <, .v , // ) ) ) ) )

|__| W I R E L E S S F R E E D O M \\; \// // / / /

ATTITUDE ADJUSTMENT (bleeding edge, r29839) ---------- ;\\|||//; / /

* 1/4 oz Vodka Pour all ingredients into mixing ,'<\/><\/` /

* 1/4 oz Gin tin with ice, strain into glass.,.`X/\><\\>`

* 1/4 oz Amaretto ;>/>><\\><\/`

* 1/4 oz Triple sec |<\\>>X/<>/\|

* 1/4 oz Peach schnapps `<\/><\/><\\;

* 1/4 oz Sour mix '/\<>/\<>/'

* 1 splash Cranberry juice `<\/><;`

-----------------------------------------------------WiFi_Pineapple MKIV

root@Pineapple:~# Type nano /etc/config/network

-ash: Type: not found

root@Pineapple:~# nano /etc/config/network

Error opening terminal: xterm-256color.

root@Pineapple:~# nano /etc/config/network

Error opening terminal: xterm-256color.

root@Pineapple:~#

Link to comment
Share on other sites

then i reciev this error message:

BusyBox v1.19.3 (2012-02-21 19:25:47 GMT) built-in shell (ash)

Enter 'help' for a list of built-in commands.

_______ ________ __ \

| |.-----.-----.-----.| | | |.----.| |_ \ \

| - || _ | -__| || | | || _|| _| \ \ \

|_______|| __|_____|__|__||________||__| |____| <, .v , // ) ) ) ) )

|__| W I R E L E S S F R E E D O M \\; \// // / / /

ATTITUDE ADJUSTMENT (bleeding edge, r29839) ---------- ;\\|||//; / /

* 1/4 oz Vodka Pour all ingredients into mixing ,'<\/><\/` /

* 1/4 oz Gin tin with ice, strain into glass.,.`X/\><\\>`

* 1/4 oz Amaretto ;>/>><\\><\/`

* 1/4 oz Triple sec |<\\>>X/<>/\|

* 1/4 oz Peach schnapps `<\/><\/><\\;

* 1/4 oz Sour mix '/\<>/\<>/'

* 1 splash Cranberry juice `<\/><;`

-----------------------------------------------------WiFi_Pineapple MKIV

root@Pineapple:~# Type nano /etc/config/network

-ash: Type: not found

root@Pineapple:~# nano /etc/config/network

Error opening terminal: xterm-256color.

root@Pineapple:~# nano /etc/config/network

Error opening terminal: xterm-256color.

root@Pineapple:~#

http://lmgtfy.com/?q=Error+opening+terminal%3A+xterm-256color.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...