Jump to content



Recommended Posts

Just wondered if anybody can help me out with this one,i got the evil twin method to work on my network perfectly,i have been doing it from ia live cd,everything worked great with a few tweeks. So i decided to install backtrack 5 r2 to my hdd, But when i came to install the dhcp3 server i got this message.

root@bt:~# apt-get install dhcp3-server -y

Reading package lists... Done

Building dependency tree

Reading state information... Done

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies:

dhcp3-server: Depends: dhcp3-common (= 3.1.3-2ubuntu3.2) but 3.1.3-2ubuntu3.3 is to be installed

E: Broken packages


im doing somthing wrong???????????


Link to comment
Share on other sites

Updated by muts 2 months ago

Priority changed from High to Low

Actually, the problem is different here.

Looks like you didn't update your sources list to include the updates repo:


deb http://updates.repository.backtrack-linux.org main microverse non-free testing

to your sources.list, then apt-get update and you should be good.

According to muts, that's the fix. So I got nothing else to offer lol. Reboot?

Link to comment
Share on other sites

I had te same problem and got it fixed. First, get Synaptic an then find dhcp-common and force version. Downgrade it one version. After this you'll need to reinstall Wicd. After downgrading, you should be able to install dhcp-server.

I'm using my phone now so if you need me to go into more detail, let me know and I'll reply when I get home.

Link to comment
Share on other sites

Thanks Mr-Protocol for you help but i still come up a blank with it,but if you have some more info on this tyler then im willing to give anything a try.


Did you try what I wrote? I just reinstalled Backtrack 5, used my method, and it works fine.

Link to comment
Share on other sites

How did you get your internet back after rolling back the dhcp3-server, i couldnt get back on the internet to download the programs i needed.

I had the same problem if I rebooted before I reinstalled Wicd but it worked fine if I was using an ethernet cable rather than the wireless card. Did you try that? You might have to look up how to manually start networking and I suppose it would work. Check the basic usage page on Backtrack's website. Here's the link.

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...