Jump to content

Recommended Posts

  • Replies 142
  • Created
  • Last Reply

Top Posters In This Topic

just having problem with site. Guess they're updating it maybe? Just sucks. I go to the module list and it tries connecting but says "failed, check your internet connection" my internet is fine and pineapple works.. anything that has to fetch from the site just fails. And the pineapple wiki has said "coming soon" for two days now.

Link to post
Share on other sites

just having problem with site. Guess they're updating it maybe? Just sucks. I go to the module list and it tries connecting but says "failed, check your internet connection" my internet is fine and pineapple works.. anything that has to fetch from the site just fails. And the pineapple wiki has said "coming soon" for two days now.

Sorry about that, we did indeed go down for updates. Sorry for any inconvenience that caused!

It should work fine now though on our end, so if you are still having issues we will need to debug that :)

Wiki wise, we are moving to a new platform. Won't take too long I hope.

Best Regards,

Sebkinne

Link to post
Share on other sites
  • 3 weeks later...

Well I was wondering, with the new protection (HSTS) which website is still working with sslstrip?

Facebook
Gmail
Twitter

Are not working because of HSTS. Is there a list of non-working website with SSLstrip?

Link to post
Share on other sites
  • 2 months later...

Why wouldn't my SSL strip infusion allow me to store my logs on my configured usb storage stick. i can store infusions on the usb, but it isn't accessible with in the ssl infusion. i am working off a mac!!!

This is what my pineapple looks like:

sslstrip
sslstrip installed
sslstrip disabled | Start Verbose

Autostart disabled | Enable
[Refresh] Filter Piped commands
:o :o This is what i want it to look like: :o :o
SS_8.png
used to filter output (e.g. grep, awk)
Link to post
Share on other sites

Well, if I understand the question correctly, you would like to store the sslstrip log on usb ?

I removed the feature as now, infusion can be stored on usb directly, which was not the case at the begining of infusions concept. Your screenshot comes from an older version of the infusion.

Simply install your infusion on usb and the logs will be as well, by default.

Edit: I moved the topic into the infusions section.

Edited by Whistle Master
Link to post
Share on other sites

thanks for helping me understand the infusion a little better.... If that is the case, then why can't i view the logs as the ssl is running and how can i view the information capture on the usb. i'm using a mac, and i cant seem to get the pineapple to capture any traffic. my pineapple is sharing great, it is working as a bridge, i set the dsn spoof configuration to 172.16.42.1*, i have downloaded wireshark and x11(which i don't understand how to use them correctly as yet!!LOL)


i would be thankful for help in this matter. I just want to use this in a demo at work if i can.


Link to post
Share on other sites
  • 2 weeks later...

WM, Might I ask what your exact install process is? I'm trying to write a script for the pineapple and, as listed above, simply installing sslstrip causes problems. I tried digging through your code but I am not familiar enough with PHP and was unable to find it

Link to post
Share on other sites

Sorry if I missed the thread, but I did some searching and didnt find the solution to the following error.

I am trying to install sslstrip. I had it installed before I re-flashed. Previously I used the gui to install, but since that had a install error, I went to the cli.

running firmware 2.8.1

root@Pineapple:~# opkg update
Downloading http://cloud.wifipineapple.com/packages/Packages.gz.
Updated list of available packages in /var/opkg-lists/pineapple_packages.
root@Pineapple:~# opkg install --dest usb sslstrip
Installing sslstrip (0.7-1) to usb...
Downloading http://cloud.wifipineapple.com/packages/sslstrip_0.7-1_ar71xx.ipk.'>http://cloud.wifipineapple.com/packages/sslstrip_0.7-1_ar71xx.ipk.
wget: server returned error: HTTP/1.0 403 Forbidden
Collected errors:
 * opkg_download: Failed to download http://cloud.wifipineapple.com/packages/sslstrip_0.7-1_ar71xx.ipk,'>http://cloud.wifipineapple.com/packages/sslstrip_0.7-1_ar71xx.ipk, wget returned 1.
 * opkg_install_pkg: Failed to download sslstrip. Perhaps you need to run 'opkg update'?
 * opkg_install_cmd: Cannot install package sslstrip.
Does the same with internal mem... i assume the url is the hint?
I was able to download from my server...
wget http://cloud.wifipineapple.com/packages/sslstrip_0.7-1_ar71xx.ipk
--2013-07-31 11:52:40--  http://cloud.wifipineapple.com/packages/sslstrip_0.7-1_ar71xx.ipk
Resolving cloud.wifipineapple.com (cloud.wifipineapple.com)... 206.72.192.42
Connecting to cloud.wifipineapple.com (cloud.wifipineapple.com)|206.72.192.42|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/sslstrip_0.7-1_ar71xx.ipk [following]
--2013-07-31 11:52:40--  http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/sslstrip_0.7-1_ar71xx.ipk
Resolving downloads.openwrt.org (downloads.openwrt.org)... 78.24.191.177
Connecting to downloads.openwrt.org (downloads.openwrt.org)|78.24.191.177|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 21841 (21K) [application/octet-stream]
Saving to: `sslstrip_0.7-1_ar71xx.ipk'


100%[==========================================================================================>] 21,841      --.-K/s   in 0.1s    


2013-07-31 11:52:42 (148 KB/s) - `sslstrip_0.7-1_ar71xx.ipk' saved [21841/21841]
Wondering if I should just scp file over and opkg install?
If there is a thread on this, can you please point me there. I can read the steps from there.
Thank you !
Edited by BGPv5
Link to post
Share on other sites

update - I just scp .ipk to the pineapple and installed.

Looks like opkg installed a few deps (python)

root@Pineapple:/# opkg install --dest usb /etc/sslstrip_0.7-1_ar71xx.ipk 
Installing sslstrip (0.7-1) to usb...
Installing python (2.7.3-2) to usb...
Downloading http://cloud.wifipineapple.com/packages/python_2.7.3-2_ar71xx.ipk.
Installing libffi (3.0.11-1) to usb...
Downloading http://cloud.wifipineapple.com/packages/libffi_3.0.11-1_ar71xx.ipk.
Installing python-mini (2.7.3-2) to usb...
Downloading http://cloud.wifipineapple.com/packages/python-mini_2.7.3-2_ar71xx.ipk.
Installing twisted (2.5.0-1) to usb...
Downloading http://cloud.wifipineapple.com/packages/twisted_2.5.0-1_ar71xx.ipk.
Installing zope-interface (2.5.0-1) to usb...
Downloading http://cloud.wifipineapple.com/packages/zope-interface_2.5.0-1_ar71xx.ipk.
Installing twisted-web (2.5.0-1) to usb...
Downloading http://cloud.wifipineapple.com/packages/twisted-web_2.5.0-1_ar71xx.ipk.
Installing pyopenssl (0.10-1) to usb...
Downloading http://cloud.wifipineapple.com/packages/pyopenssl_0.10-1_ar71xx.ipk.
Configuring python-mini.
Configuring zope-interface.
Configuring twisted.
Configuring twisted-web.
Configuring libffi.
Configuring python.
Configuring pyopenssl.
Configuring sslstrip.
I will see if this worked and report back.
Link to post
Share on other sites

Still having trouble with sslstrip in the terminal and the infusion. If I try to just run sslstrip I get the error " env: can't execute 'python': No such file or directory" so I did cd /usb/usr/bin then ran python2.7 sslstrip and I new error

Traceback (most recent call last):
File "sslstrip", line 27, in
from twisted.web import http
ValueError: could not convert string to float: ffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffff

If I try to run the infusion when I click start it says sslstrip is running but as soon as I try to refresh it says sslstrip is not running. It won't long anything and sometimes DoS anything that isn't https on the network. I've tried uninstalling and reinstalling and I'm running out of ideas.

Link to post
Share on other sites

sorry if this has already been answered but when I open the sslstrip module I run the module and it says it is not running even though it is, and sometimes my pineapple will reboot. have any ideas why and a possible fix or is it just me?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...