Jump to content

Mark 4 Setup Script

Recommended Posts

  • Replies 64
  • Created
  • Last Reply

Top Posters In This Topic

Velkrosmaak, sounds like you've got some serious issues. Maybe you've modified something on your shell and it's causing errors.

Try changing the shebang line at the beginning of the script to use bash instead. Maybe it'll solve your issue. Just a shot in the dark because I've never seen a shell throw errors on empty lines.

#!/bin/sh to #!/bin/bash

Link to comment
Share on other sites

  • 2 weeks later...
  • 5 weeks later...

Nop, that wont work work. If i try "test test test" the result is "test".

Hmm if it worked before I don't know what to say?

Could try and remove the variable and quotes then type in the ssid within the command.

Maybe something in your ssid is a sed command?

Edited by petertfm
Link to comment
Share on other sites

  • 1 month later...

Hi, does this script work with Firmware 2.8.0?

I copied it and saved it on my pineapple but somehow it wont run.

When I run :

root@Pineapple:~# run: chmod +x pineapple-mk4-setup-script.sh; ./pineapple-mk4-setup-

Nothing happens..

And when I Try

root@Pineapple:~# chmod +x pineapple-mk4-setup-script.sh; /pineapple-mk4-setup-s

I get:
-ash: /pineapple-mk4-setup-script.sh: Permission denied

What am I doing wrong ?

Link to comment
Share on other sites

  • 4 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...