Jump to content

Any Fix For Theses


ZaraByte
 Share

Recommended Posts

Alright finally got my WiFi Pineapple Mark VI setup was wanting to check the Modules but im getting this:

bJqDW.png

Also i notice the upgrade page gives an error aswell.

Tried changing my eth0 to eth1 but still get the same error any idea?

Edited by ZaraByte
Link to comment
Share on other sites

Do you have internet connection sharing configured? looks like the pineapple doesnt have an internet connection

Yup it has a internet connection cause i can go to google and whatismyip.com and see the IP of the Wireless network im connected to. Surf any website just fine so not really sure whats going on.

i also tryed to ssh into the pineapple from backtrack using ssh root@pineapple but not able to not sure what the information is to ssh into the pineapple or if i need to turn ssh on in the pineapple some where.

Link to comment
Share on other sites

Yup it has a internet connection cause i can go to google and whatismyip.com and see the IP of the Wireless network im connected to. Surf any website just fine so not really sure whats going on.

i also tryed to ssh into the pineapple from backtrack using ssh root@pineapple but not able to not sure what the information is to ssh into the pineapple or if i need to turn ssh on in the pineapple some where.

there is a place in the ui where you can ping a ip try 8.8.8.8 if it is successful then the server for the modules is down again.

Link to comment
Share on other sites

I have the same error as the OP after removing Opkg Manager ... hesitant to flash it, any other option besides waiting for 1.1.2?

EDIT: fixed the issue rather easily with the ultra quick start command;

wget wifipineapple.com/wp4.sh; chmod +x wp4.sh; ./wp4.sh; firefox http://172.16.42.1/pineapple &

BTW, thank you Darren, Snubs, Paul and everyone else from Hak5 your shows bring me much joy!

Happy days, happy days :D

Edited by Synsafe
Link to comment
Share on other sites

Having no problems whatsoever :mellow:

Make sure you have internet on your pineapple.

When you think ICS is causing troubles, plug a cable in the WAN port of your pineapple and connect it to your router/switch which provides internet and with a second cable connect the PoE/LAN port to your computer.

You can control your pineapple with your computer and your pineapple will have internet. Then check the module list again.

If you also want internet to be routed to your computer copy/paste these lines in "Execute commands" box on the Advanced page on your pineapple and click the execute button. This will enable NAT, see wiki.

iptables -A FORWARD -i eth1 -o wlan0 -s 172.16.42.0 -m state --state NEW -j ACCEPT
iptables -A FORWARD -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE

I added these lines to the WPS button script ;)

Link to comment
Share on other sites

Having no problems whatsoever :mellow:

Make sure you have internet on your pineapple.

When you think ICS is causing troubles, plug a cable in the WAN port of your pineapple and connect it to your router/switch which provides internet and with a second cable connect the PoE/LAN port to your computer.

You can control your pineapple with your computer and your pineapple will have internet. Then check the module list again.

If you also want internet to be routed to your computer copy/paste these lines in "Execute commands" box on the Advanced page on your pineapple and click the execute button. This will enable NAT, see wiki.

iptables -A FORWARD -i eth1 -o wlan0 -s 172.16.42.0 -m state --state NEW -j ACCEPT
iptables -A FORWARD -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE

I added these lines to the WPS button script ;)

Cool, thanks. I'll try that out later tonight.

I'm sure that the pineapple can access the internet because I tested it by connecting to the pineapple with my phone and got online just fine. It's really strange because I can go to the URL from the error in my browser but the pineapple just can't seem to get to it. Anyways, thanks again. I'll see if I can fix it by physically connecting it to my router.

Link to comment
Share on other sites

Having no problems whatsoever :mellow:

Make sure you have internet on your pineapple.

When you think ICS is causing troubles, plug a cable in the WAN port of your pineapple and connect it to your router/switch which provides internet and with a second cable connect the PoE/LAN port to your computer.

You can control your pineapple with your computer and your pineapple will have internet. Then check the module list again.

If you also want internet to be routed to your computer copy/paste these lines in "Execute commands" box on the Advanced page on your pineapple and click the execute button. This will enable NAT, see wiki.

iptables -A FORWARD -i eth1 -o wlan0 -s 172.16.42.0 -m state --state NEW -j ACCEPT
iptables -A FORWARD -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE

I added these lines to the WPS button script ;)

Okay, I have a question. I have the pineapple connected physically between my router with Internet access and my computer but how exactly do I get to the pineapple from my computer this way? I'm not exactly sure how to use the wp4.sh script because when it asks for the interface between my PC and the Internet, I don't know what to put. I guess it should be eth0 since my PC is connected to the pineapple that way and then pineapple is then connected to a router with Internet access but it won't let me choose eth0 since that's the same interface used to connect my PC and the pineapple. So, how exactly do I set this up when I've got the pineapple physically connected like you wrote?

Link to comment
Share on other sites

If you have your setup like i described in my post then you don't need the wp4.sh script ;)

The pineapple will have internet from your router.

Your computer will get a ip from your pineapple via DHCP.

The iptables lines will tell the pineapple to route the internet traffic from the WAN port to the PoE/LAN port and the wlan.

The wp4.sh script is for a ICS setup: Internet > Router/Switch > Computer > Pineapple

The WAN port NAT setup is: Internet > Router/Switch > Pineapple > Computer

Link to comment
Share on other sites

Ah, I got it! I haven't had much sleep and misunderstood what you meant. I was thinking that setting up NAT was to allow devices wirelessly connecting to the pineapple to be able to access the Internet. I'll try what you said now that I understand it more. Thanks again!

Link to comment
Share on other sites

This is so weird. I've connected everything just like your instructions say but still no luck. I can access the Internet and can even go to the URL in the error I get from the pineapple. When I click on "show" to see available modules, it just says waiting for a few minutes and eventually times out. I'm stumped. Maybe, I'm just out of luck for now?

Link to comment
Share on other sites

Error re-occured for me after tinkering with the modules again via thumbdrive (formated to ext4 with miniTool Partition for windoze)

root@Pineapple:/www/pineapple# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         172.16.42.42    0.0.0.0         UG    0      0        0 br-lan
172.16.42.0     *               255.255.255.0   U     0      0        0 br-lan

I have not used the commands above provided by WatskeBart,

current setup is Pineapple - Backtrack(VBox) - Internet

I have an AWUS036H I am dying to tether to it, but want to play with it a bit more before I let it go solo.

Link to comment
Share on other sites

Could you ssh into your pineapple and post the output of the following command:

route

Here's what I get:

Kernel IP Routing table
Destination		Gateway		Genmask		Flags		Metric		Ref		Use		Iface
default		172.16.42.42		0.0.0.0		UG		0		0		0		br-lan
default		192.168.1.1		0.0.0.0		UG		0		0		0		eth1
172.16.42.0		*		255.255.255.0		U		0		0		0		br-lan
192.168.1.0		*		255.255.255.0		U		0		0		0		eth1

But now, I've run into another problem. At first I could connect to the Internet by setting up iptables but now I can't get it to work... I tried rebooting and also resetting with the reset button but it still doesn't work. I think there's a problem with iptables because when I set it up using ICS it works just fine.

Edited by tylerscoldrevenge
Link to comment
Share on other sites

It seams that you have two gateways defined:

default         172.16.42.42            0.0.0.0         UG              0               0               0               br-lan
default         192.168.1.1             0.0.0.0         UG              0               0               0               eth1

Do you connect your pineapple to your home router through the WAN/LAN port and also to your computer through PoE LAN port ?

If you only use ICS through a computer with PoE LAN port, try the following:

route del default gw 192.168.1.1 eth1

Edited by Whistle Master
Link to comment
Share on other sites

It seams that you have two gateways defined:

default 		172.16.42.42            0.0.0.0 		UG              0       		0       		0       		br-lan
default 		192.168.1.1     		0.0.0.0 		UG              0       		0       		0       		eth1

Do you connect your pineapple to your home router through the WAN/LAN port and also to your computer through PoE LAN port ?

If you only use ICS through a computer with PoE LAN port, try the following:

route del default gw 192.168.1.1 eth1

Okay, I've got it working again and can connect to the Internet once again. I'm not sure what fixed it but I tried to reset everything with the reset button and that didn't seem to work and then I noticed that it was giving my PC the wrong IP address so I set 172.16.42.42 as a static IP and it works again. However, I'm still having the same problem and can't see the module list. When I ssh and do route, I get the same as before but the only gateway listed is 192.168.1.1.

Oh, by the way, I'm connected to my router through the WAN/LAN port rather than doing ICS because I wanted to see if a problem with ICS was keeping me from seeing the module list.

Edited by tylerscoldrevenge
Link to comment
Share on other sites

  • 3 weeks later...

Well, I would say that the problem is nothing to do with connectivity of the device, per se. Though I understand why that is the first assumption.

Go to a non-related computer that gets internet.

The php module page on line 92 is pointing to: http://wifipineapple.com/downloads.php?moduleList'>http://wifipineapple.com/downloads.php?moduleList

Go to this in your browser: http://wifipineapple.com/downloads.php (or try the one above).

Looks like behind the scenes dropbox is being used and it's not quite right anymore.

Warning: file_get_contents(http://dl.dropbox.com/u/411404/wifipineapple/mk4/files) [function.file-get-contents]: failed to open stream: HTTP request failed! HTTP/1.1 404 NOT FOUND

in /home/aardwolf/wifipineapple.com/downloads.php on line 62

Bottom line the link the modules page is pointing to by default is barfing.

Any alternate locations to pull modules?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...