Jump to content

Mark Iv Home Network Setup Help


Recommended Posts


I've seen in other posts people are able to connect their Pineapple MKIV to their home network instead of having it tethered to a laptop or a 3G dongle because I simply cannot get the tethering to work on my laptop. My only problem is I'm not quite sure how to go about doing this. Here is what I currently have to work with:

  • Wifi Pineapple MKIV
  • Laptop with Atheros chipset (not sure which)
  • Netgear WNDR3400 running DD-WRT
  • Home Network is
  • Pineapple Network is
  • KARMA SSID set to NETGEAR (So I pickup NETGEAR and pineapple from my laptop)
  • Firmware version 1.1.1

This is what I tried putting into the terminal from wp4.sh but I'm not sure if I have it configured correctly:

Input Pineapple Netmask [or ENTER for]:

Input Pineapple Network [or ENTER for]:

Input Interface between PC and Pineapple [or ENTER for eth0]: eth1

Input Interface between PC and Internet [or ENTER for wlan0]:

Input Internet Gateway [or ENTER for]:

Input IP Address of Host PC [or ENTER for]:

Input IP Address of Pineapple [or ENTER for]:

Pineapple connected to: eth1

Internet connection from: wlan0

Internet connection gateway:

Host Computer IP:

Pineapple IP:



SIOCSIFADDR: No such device

eth1: ERROR while getting interface flags: No such device

SIOCSIFNETMASK: No such device

eth1: ERROR while getting interface flags: No such device

IP Forwarding enabled. /proc/sys/net/ipv4/ip_forward set to 1

iptables chains and rules cleared

IP Forwarding Enabled

Default route removed

SIOCADDRT: No such process

Pineapple Default Gateway Configured

PING ( 56(84) bytes of data.

64 bytes from icmp_req=1 ttl=64 time=0.272 ms

64 bytes from icmp_req=2 ttl=64 time=0.284 ms

64 bytes from icmp_req=3 ttl=64 time=0.264 ms

--- ping statistics ---

3 packets transmitted, 3 received, 0% packet loss, time 1999ms

rtt min/avg/max/mdev = 0.264/0.273/0.284/0.015 ms

ICS configuration successful.

Now connecting to -- Happy Hacking!

I currently have the Pineapple plugged into the router into LAN3 on my router via the WAN/LAN port(eth1 I think it is). This is how it looks on the back of the router(Yay ASCII art):

[WAN] [LAN1][LAN2][LAN3][LAN4]

I'm not sure whether or not to use the PoE/LAN or the WAN/LAN on the Pineapple to connect to the router or if the other should be plugged into anything at all. If anyone has anything helpful that would be great and until then I'm going to be messing around trying to make this work. Thank you in advance for your help.

Edited by E1337Recon
Link to comment
Share on other sites

well what you need to do is connect the POE from the pineapple to any Lan port of the router. But your main problem is the IP setup you are having. this will not work.

You could put your home router on IP or you will need to adjust the pineapple to the IP of your home network.

after that you should be good to go


Link to comment
Share on other sites

Thanks for the help guys, I finally managed to get the tethering to work. My problem was I misconfigured the Internet Gateway to the default instead of (my router) but after I did that it worked like a charm. This is an amazing tool and I can't wait to fool with it some more.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...