Jump to content

Upingable Mk Iii


velkrosmaak
 Share

Recommended Posts

Hi there!

I'm only able to connect to the pineapple's UI by connecting to the 'pineapple' AP then viewing the WebUI from the /pineapple URL. If connected to eth0 I am unable to ping, or otherwise connect to it.

This happened to be once before, and after a factory reset (via WebUI) the box was completely unusable. does not show on LAN, is unpingable, and pineapple SSID doesn't show - even after waiting 30mins+.

Have I 'bricked' my pineapple by not being patient enough after a factory reset? how long should one expect to wait? anything I can try short of reflashing it again?

This is on an AP51 btw, flashed DIY style from Windows.

Thanks!

Link to comment
Share on other sites

I would suggest flashing with the newest Mark III firmware and then we can troubleshoot from there. If you set your card to 192.168.1.1 to flash, you will need to set it to 172.16.42.42 subnet:255.255.255.0 and a *blank* gateway in order to talk to it over a wired connection. You could also double check those settings before flashing. After the flash the wired port is 172.16.42.42 and not the 192.168.1.1 that was used to flash it.

Link to comment
Share on other sites

If I force the wired connection to have the ip 172.16.42.42 on my box (BT5r2) and connect to the pineapple, I get an error and it times out. If I leave it to auto-discover IP it also times out. Maybe a reflash is in order. Do I need to reflash every time I do a factory reset? Or was it, as suspected, due to my lack of patience when doing factory reset?

I will try reflashing it when I get home this evening. Was hoping my MKiv would turn up today (see my other thread from today...)

Thanks!

Link to comment
Share on other sites

After much tinkering, I finally managed to get it to reflash (seemingly I had to reinstall Winpcap and the machine, every time I restarted attempts at flashing)

Now I'm back to the same problem as before. can see the pineapple AP. can't connect to it via ethernet, but can when connected via the pineapple SSID.

any thoughts?

hoping MK IV arrives soon and I can turn MK III into a dedicated deauthing box or something. Or a paperweight.

Link to comment
Share on other sites

Re-downloaded wp3.sh just in case it was corrupt or something somehow - but still the same problem. here's the output:

Input Pineapple Netmask [or ENTER for 255.255.255.0]: 
Input Pineapple Network [or ENTER for 172.16.42.0/24]: 
Input Interface between PC and Pineapple [or ENTER for eth0]: 
Input Interface between PC and Internet [or ENTER for wlan0]: wlan1
Input Internet Gateway [or ENTER for 192.168.1.1]: 
Input IP Address of Host PC [or ENTER for 172.16.42.42]: 
Input IP Address of Pineapple [or ENTER for 172.16.42.1]: 
Pineapple connected to: eth0
Internet connection from: wlan1
Internet connection gateway: 192.168.1.1
Host Computer IP: 172.16.42.42
Pineapple IP: 172.16.42.1
Network: 172.16.42.0/24
Netmask: 255.255.255.0
IP Forwarding enabled. /proc/sys/net/ipv4/ip_forward set to 1
iptables chains and rules cleared
IP Forwarding Enabled
Default route removed
Pineapple Default Gateway Configured
PING 172.16.42.1 (172.16.42.1) 56(84) bytes of data.
From 172.16.42.42 icmp_seq=1 Destination Host Unreachable
From 172.16.42.42 icmp_seq=2 Destination Host Unreachable
From 172.16.42.42 icmp_seq=3 Destination Host Unreachable

--- 172.16.42.1 ping statistics ---
3 packets transmitted, 0 received, +3 errors, 100% packet loss, time 1999ms
, pipe 3

Browse to http://172.16.42.1/pineapple  --  Happy Hacking!

Double checked via ifconfig that my ethernet interface is definitely eth0 and am out of ideas as to what else might be wrong. this is on a freshly flashed AP51 with the latest MK III firmware.

Has worked previously, so not sure what's going on.

As said before, the pineapple SSID shows up when I scan and when I connect via that I can access the pineapple web UI.

Thanks in advance dudes!

Edit: Tidied up

Edited by velkrosmaak
Link to comment
Share on other sites

Static IP you need to set on your computers ethernet adapter is 172.16.42.42

Static IP of the router is and will always be: 172.16.42.1

IPs of your clients should always be: 172.16.42.XXX

Are all of these things true? If in linux run ./wp3.sh multiple times - I don't know why but on my mark3 I have to run it 4-5 times before I get pings back (mystery to me...). If on windows - please walk through the steps you took to setup the static IP and ICS.

When you connect to said pineapple and can reach the pineapple control console, can you also access the internet?

telot

Link to comment
Share on other sites

telot I had the same problem with having to run wp3.sh many times for the mark3

I found if I turned on the mark3 and waited 3 or 4 minutes then plugged in the ethernet and ran the script soon after, I would always connect.

Edited by petertfm
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...