Jump to content

Recommended Posts

So I was trying to play with Reaver on the Mk4 and haven't gotten it to work.

I SSHd in to the Mk4 and issued the command:

reaver -i mon.wlan0 -b xx:xx:xx:xx:xx:xx -v

and i get "[+] Waiting for beacon from xx:xx:xx:xx:xx:xx" and it just sits and nothing happens.

So then I tried:

reaver -i wlan0 -b xx:xx:xx:xx:xx:xx -v

and i get "[+] Waiting for beacon from xx:xx:xx:xx:xx:xx" and it just sits and nothing happens again.

I definitely have the correct MAC address, as it works perfectly in BT5r2 with:

reaver -i mon0 -b xx:xx:xx:xx:xx:xx -v

So, is mon.wlan0 the correct interface, or do I need to run airmon-ng first? Has anyone had success with Reaver on the Mk4 thus far?

Thanks in advance.

Link to post
Share on other sites

Yes, it would need to be in monitor mode and obviously must be on the same channel, if all else fails, try

airreplay-ng -1 999 -a APBSSID mon0

and add a "-A" arguement to reaver, basically this just tells airreplay to do the associations, it might happen on some routers.

Link to post
Share on other sites

So I was trying to play with Reaver on the Mk4 and haven't gotten it to work.

I SSHd in to the Mk4 and issued the command:

reaver -i mon.wlan0 -b xx:xx:xx:xx:xx:xx -v

and i get "[+] Waiting for beacon from xx:xx:xx:xx:xx:xx" and it just sits and nothing happens.

So then I tried:

reaver -i wlan0 -b xx:xx:xx:xx:xx:xx -v

and i get "[+] Waiting for beacon from xx:xx:xx:xx:xx:xx" and it just sits and nothing happens again.

I definitely have the correct MAC address, as it works perfectly in BT5r2 with:

reaver -i mon0 -b xx:xx:xx:xx:xx:xx -v

So, is mon.wlan0 the correct interface, or do I need to run airmon-ng first? Has anyone had success with Reaver on the Mk4 thus far?

Thanks in advance.

I'm planning on giving it a try today. Can we get a straight answer from the devs: What does mon.wlan0 do? Whats its function? Why is it always on Channel 11? Can I change it to whatever channel I want without breaking things? iwconfig mon.wlan0 channel 1? What are the implications to mon.wlan0 if I do an airmon-ng wlan0? Will karma still work?

The reason I dont just try this stuff, is I'm paranoid about bricking the little guy until I get my serial cable...I've got all weekend with this thing (wifes being nice and swtor has her soul mwahahaha) and I don't want to break it first thing saturday morning lol...

telot

Link to post
Share on other sites

The reason I dont just try this stuff, is I'm paranoid about bricking the little guy until I get my serial cable...I've got all weekend with this thing (wifes being nice and swtor has her soul mwahahaha) and I don't want to break it first thing saturday morning lol...

telot

I know how you feel. Mine is still on the truck for delivery. I'm working today though, so that helps.

Link to post
Share on other sites

So I was trying to play with Reaver on the Mk4 and haven't gotten it to work.

I SSHd in to the Mk4 and issued the command:

reaver -i mon.wlan0 -b xx:xx:xx:xx:xx:xx -v

and i get "[+] Waiting for beacon from xx:xx:xx:xx:xx:xx" and it just sits and nothing happens.

So then I tried:

reaver -i wlan0 -b xx:xx:xx:xx:xx:xx -v

and i get "[+] Waiting for beacon from xx:xx:xx:xx:xx:xx" and it just sits and nothing happens again.

I definitely have the correct MAC address, as it works perfectly in BT5r2 with:

reaver -i mon0 -b xx:xx:xx:xx:xx:xx -v

So, is mon.wlan0 the correct interface, or do I need to run airmon-ng first? Has anyone had success with Reaver on the Mk4 thus far?

Thanks in advance.

maybe a "-c XX" the channel of the access point would work?

if not also try this before running reaver:

iwconfig mon.wlan0 channel XX

Link to post
Share on other sites

I started another topic for your question bobtheman. This thread is about Reaver on the Mk4.

Thanks! :)

Also, has anyone gotten it to work on the mon.wlan0 interface? I'm assuming that this is the monitor interface on the pineapple, but I could be wrong. We all know what assuming does! :P

I thought, and ofc I could be incorrect, that airmon-ng start wlan0 was run on boot.

Link to post
Share on other sites

I started another topic for your question bobtheman. This thread is about Reaver on the Mk4.

Thanks! :)

Also, has anyone gotten it to work on the mon.wlan0 interface? I'm assuming that this is the monitor interface on the pineapple, but I could be wrong. We all know what assuming does! :P

I thought, and ofc I could be incorrect, that airmon-ng start wlan0 was run on boot.

First test - no screwing around with mon.wlan0 or channels - I just set my router to be on channel 11 to match the interface:

reaver -i mon.wlan0 -b XX:XX:XX:XX:XX:XX -vv

Waiting for Beacon from XX:XX:XX:XX:XX:XX

Switching mon.wlan0 to channel 2

Switching mon.wlan0 to channel 3

Switching mon.wlan0 to channel 4

Switching mon.wlan0 to channel 5

Switching mon.wlan0 to channel 6

Switching mon.wlan0 to channel 7

Switching mon.wlan0 to channel 8

Switching mon.wlan0 to channel 9

Switching mon.wlan0 to channel 10

Switching mon.wlan0 to channel 11

Switching mon.wlan0 to channel 12

Switching mon.wlan0 to channel 13

Switching mon.wlan0 to channel 14

Switching mon.wlan0 to channel 1

Switching mon.wlan0 to channel 2

And so on...

Adding -c 11 to the mix for a: reaver -i mon.wlan0 -b XX:XX:XX:XX:XX:XX -c 11 -vv gets me:

Waiting for beacon from XX:XX:XX:XX:XX:XX

And it stalls after that just like it does for iamk3.

Ok now I tried the following:

airmon-ng stop mon.wlan0

ifconfig wlan0 down

airmon-ng start wlan0

iwconfig mon0 channel 3 (the channel my target AP is now set to)

reaver -i mon0 -b XX:XX:XX:XX:XX:XX -vv

Still nothing :(

I'm fearing that it has to do with wlan0 being in master mode? When I try and change wlan0 to Managed or even change the channel to 3, it gives me an error.

Whats odd is that I can get an association using aireplay-ng -1 999 like Andrei suggested. Still reaver keeps switching channels...

Edited by telot
Link to post
Share on other sites

Have you tried the association plus setting a static channel using "-c 11" ? If that still doesnt work I dont really know what to suggest.. maybe make sure no external tools are using the wlan interface because they maybe causing the channel change

Link to post
Share on other sites

Have you tried the association plus setting a static channel using "-c 11" ? If that still doesnt work I dont really know what to suggest.. maybe make sure no external tools are using the wlan interface because they maybe causing the channel change

I havevn't had a chance to yet - got distracted. But I believe you're on the right track with external tools utilizing the interface (pineapple AP...) and thereby denying any changes to the channels or preventing association to the target AP. Any ideas (Seb?) on how we'd stop the AP and put the card into Managed mode? Everytime I try it says resources busy...and I'm afraid of doing any serious change for fear of bricking it. I'll give the -c 11 a try asap - thanks again Andrei!

telot

Link to post
Share on other sites

I'm in the same boat... I can't get it to work at all. In fact, I've gotten nothing to work. Using what telot suggested with shutting down wlan0 and starting over does get it so I can hop channels, deauth seems to work but reaver still does not... and of course karma no longer functions, I can't seem to get wlan0 back into master mode either.

Link to post
Share on other sites

There will be a small upgrade out shortly which will have reaver 1.4 which is said to be more reliable and have a few bugs ironed out.

Best,

Sebkinne

BackTrack mentality. Keep older versions that work well together vs bleeding edge and bugs. All about keeping those trouble tickets down :P.

Link to post
Share on other sites
  • 1 year later...

My n900 can crack this AP so i'm in range.I even tried to set channel manually before brute.(airodump-ng scanning on all channels perfect).


Wash scanning works only after this commands:

ifconfig wlan0 down

airmon-ng stop mon0

airmon-ng stop wlan0

iwconfig wlan0 mode Monitor

ifconfig wlan0 up

airmon-ng start wlan0

wash -i mon0 -C

What else can i try to make reaver working?APs signal power is about 80.

_______

I found strange output when tried to launch reaver and aireplay-ng -1 999 -a.....

aireplay is waiting for beacon on channel "-1".iw config shows normall frequency of the 4-th channel.Maybe need to install some kernel patch

Edited by satana77
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...