Jump to content

Mk4 - No Internet For Pwnt Targets


hfam
 Share

Recommended Posts

Got my MK4s!!

However, I can NOT get my pwnt clients to connect to the Internet.

(I know it looks lengthy, but it's just defining the steps I took clearly)

Everything is setup just as it was with my MK3s, same laptop, same cables:

- Laptop/W7 - Tethered correctly.

- 42.42 is the local eth0

- 42.1 is the MK4 POE/LAN

- WiFi on Laptop is providing Internet, Sharing is enabled

- Internet is accessible on the laptop

- I can ping (.42), (.1), as well as the IP my "pwnt" client gets from the pineapple (.161)..all from the laptop

- Android Tbolt is the pwnt client in this case

- The MK4 fires up and I get the interface via browser on the MITM laptop, and log into it.

- I fire up Karma, and I can see the logs showing it's working, and can see it associating with a few local APs.

- I add an AP called "PWNT" on my Android

- Android connects to "PWNT", Karma does it's thing, associates with PWNT, and the MK4 provides my Android with an IP (.161)

On the Android, I can see I've got full WiFi bars, but I open a browser and cannot get anywhere. Instant "page not found"

On the Android, I reconnect to my real AP (the one providing Internet to the laptop), and can get to anywhere on the Internet.

On the Android, I reconnect to "PWNT", and again, the Android dutifully connects to the Karma'd MK4.

On the Laptop, I ping the IP that I see the Android's been given (.161) by the MK4, and sure enough, it responds.

The MK4 will not let my pwnt client onto the internet.

I then pulled out my MK3, powered/decabled the MK4, powered/cabled the MK3, let it boot up, and accessed the GUI on the MK3.

In the meantime, my Android had reconnected to my local AP, and again, internet on the Android is working fine.

On the Android, with the MK3 now powered up on the same laptop, I now connect to "PWNT", Karma does it's thing, and I can see my Android has re-leased the same IP (.161), I can ping it from my Laptop.

The Android connects to the Internet just fine, as it should, through the MK3.

So, you can see that the laptop is setup fine, the MK3 pwns my Android perfectly, but the MK4 in the identical situation will not allow the pwnt clients to access the Internet.

What am I missing here? Is there something else I need to do on the MK4?? I've turned on Karma, and turned on URLSnarf. Client gets pwnt, but cannot get to the Internet.

ETA: On the pwnt Android, when connected to "PWNT" (karma), I *CAN* get to http://172.16.42.1/pineapple, but I cannot get through the AP to the Internet

ETA2: I've tried removing the ICS and resetting up the ICS to no avail. Still no Internet for the pwnd clients, still can connect to the MK4 GUI from the clients. Also tried my 2nd MK4 just to be sure and got the same results. I also again re-confirmed that removing the MK4 and putting in the MK3, everything works perfectly.

ETA3: I tried running it off of straight power (was using USB power) and got the same results.

I'm really stumped here gang, any help would be really appreciated!

Edited by hfam
Link to comment
Share on other sites

  • Replies 74
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

Can you ping 8.8.8.8? Use overlook fling on android.

if you can i think it would be an DNS issue in the DHCP settings on the MK4.

Link to comment
Share on other sites

Thanks for the reply (and the tip on Fing!!)! This is driving me absolutely crazy.

I installed Fing on the Androis, got Karma'd up on the MK4, and pinging 8.8.8.8 on the Android comes up 100% packet loss.

I'm completely out of ideas...just out of gas on and really bummed out. I've spent hours eliminating anything in my equation and proving out the issue exists on the MK4. What it is I haven't the faintest idea...

I can take my MK3, swap it out for the MK4 right now, and it works flawlessly.

It's GOT to be something on the MK4 not allowing packets through, everything else works perfectly, including the MK3. I can see the 172 network, I can grab the GUI page, but I can't get Internet. Just comes up empty.

I even tried my 2nd MK4 to be certain, and got the same results. MK3 works perfectly though.

:(

Link to comment
Share on other sites

Sitting here, I just tried it with my Kindle Fire, and achieved the same results.

So I fired up PuTTY, logged into the MK4, and I *am* able to ping 8.8.8.8 from the MK4.

Any ideas? It's got to be at the MK4. The Internet Connection Sharing is working as it should, and the MK3 functioning proves that out.

It's got to be on the MK4.

Anyone?

ETA: I am unable to ping the Laptop's eth0 (172.16.42.42). I am able to ping 172.16.42.1.

Fing shows the following on the Android:

Net: 172.16.42.0/24

IP: 172.16.42.161

Gate: 172.16.42.1

DNS: 172.16.42.1

- Can ping my gate. Cannot ping the next hop (.42)

- From the MK4 (PuTTY) I can ping (.42) and out to the Internet

Still no love. Anyone?

Edited by hfam
Link to comment
Share on other sites

Have you tried the other eth port on the MK4? If not, give it a shot.

If it is indeed a firmware bug then we will find it asap.

I will look at it once I get back.

Best,

Sebkinne

Hi all,

Thanks for.the replies!.

iamk3: thanks, I'm anxious to see if you can.replicate the issue, holding tight for your follow up!

seb: I am using the PoE port which has 42.1 assigned to it. I did unplug from.that port and tried the.other.one (LAN/WAN) , and just tried to pong it from the laptop (42.42) and received no reply, so I figured that was a no-go.

Thanks for looking into.this fellas. I.provided a lot of details in as orderly a fashion as I could to try to get.to the bottom of this. I confirmed all the ICS stuff is working on the MITM laptop by plugging in my MK3 and it works like a dream. Even removed/re-setup ICS and tried it again on both MK3 and MK4 with the same results: MK3 works flawlessly, MK4 fails to route clients past the gateway.

Everything appears to work, interfaces responding as expected, except the MK4 refuses to let clients past the 42.1 gate, cant even ping 42.42 from a pwnd client. The MK4 itself can get past it (PuTTY, run a ping and it can ping all the way through 42.1, 42.42, 42.161(a client IP), 8.8.8.8, etc

If I can provide more info, or test some other ideas I would be more than happy to try anything at this point.

Thanks for all your help!

Edited by hfam
Link to comment
Share on other sites

hfam: I have tried all the same steps that you have with no luck either. I have tried connecting my android phone via karma and through the SSID and still no luck. I also tried changing the DNS server on my LAN connection from 8.8.8.8 to 4.2.2.2 (Verizon iirc) with no luck either.

Somewhere there is a problem getting connected clients to from the mk4 to the internet. I didn't make any changes and plugged up my mk3 and had no problem whatsoever.

FYI: running Win7 with ICS. I haven't tried 3G yet because that won't be in until tomorrow.

Link to comment
Share on other sites

hfam: I have tried all the same steps that you have with no luck either. I have tried connecting my android phone via karma and through the SSID and still no luck. I also tried changing the DNS server on my LAN connection from 8.8.8.8 to 4.2.2.2 (Verizon iirc) with no luck either.

Somewhere there is a problem getting connected clients to from the mk4 to the internet. I didn't make any changes and plugged up my mk3 and had no problem whatsoever.

FYI: running Win7 with ICS. I haven't tried 3G yet because that won't be in until tomorrow.

Dude, I can't thank you enough for confirming that I'm not nuts (ok, well maybe I am, but not on this particular issue!! :) )

So, there is definitely an issue going on with the MK4 and routing clients through the gateway.

Given that this issue has been confirmed, I'm confident that Seb/Robin/Darren/MrP can weigh in and get this issue resolved.

Eternal thanks for checking back in with your results my friend, the confirmation that there's an issue gives me some relief!! :)

Standing by for seb and crew to weigh in!

Thanks everyone, and again, anything I can do to test, provide more info, etc, I'm happy and ready to do so!

Link to comment
Share on other sites

I use my MK IV on a linux machine without any issue. I am using the WP3.sh script to set everything up. I even added a line of code to launch sslstrip in an xterm window on my laptop. I wonder if ti is OS related and not the MK IV itself??

Link to comment
Share on other sites

I use my MK IV on a linux machine without any issue. I am using the WP3.sh script to set everything up. I even added a line of code to launch sslstrip in an xterm window on my laptop. I wonder if ti is OS related and not the MK IV itself??

Its got.to be on the MK4:

- The MitM laptop and connected.clients works flawlessly with an MK3

- The client cannot get past the gateway (172.16.42.1), but the MK4 itself can (via a PuTTY session)

Edited by hfam
Link to comment
Share on other sites

Its got.to be on the MK4:

- The MitM laptop and connected.clients works flawlessly with an MK3

- The client cannot get past the gateway (172.16.42.1), but the MK4 itself can (via a PuTTY session)

I have the original Beta Version from Schmoocon, so my firmware may be different. Just saw the screenshots and realized I am a version behind....

Link to comment
Share on other sites

If you are using internet connection sharing, make sure the NIC the pineapple is connected to is set to 172.16.42.42.

You can then edit your dhcp file on the pineapple and point the DFG to 172.16.42.42. This should send all client traffic to your shared interface and out to the internet.

Link to comment
Share on other sites

Just read the OP. Reserving this spot. Pulling a pineapple off the factory line and testing. Standby.

Edit: Just read the rest of the comments. This is weird. In all of my tests I've been using the mk3.sh (now renamed to mk4.sh) on linux and tethering has always worked. First thought: Go to the advanced page in the web UI and in the text area at the bottom type "/etc/init.d/firewall stop" then click Execute Commands. Ok, grabbing a pineapple and looking for a Windows 7 machine now...

Edit 2: Issue /etc/init.d/firewall disable; /etc/init.d/firewall stop from the Execute Commands text area a the bottom of the advanced page.

Ok I grabbed a pineapple off the shelf, powered it, connected the spiffy little retractable ethernet cable between the pineapple's PoE LAN port and my laptop, booted Ubuntu (My Windows install is on a HDD collecting dust), connected to the WiFi on wlan0 and ran mk4.sh. It pinged 172.16.42.1 no problem. I browsed to http://172.16.42.1/pineapple, logged in, enabled karma. Went to the advanced page and verified that 172.16.42.42 is the default gateway. Entered 8.8.8.8 in the ping box and got replies, so it's online. Entered example.com in the ping box and also got replies, so DNS is working. Entered cat /etc/config/network; cat /etc/conf/dhcp in the execute commands box and everything looked great.

Then I put my phone in airplane mode (so it's off the 3G network), enabled wifi, added an SSID called "is_ics_working" and instantly it connected. Tried to pull up example.com in my browser, no dice.

Remembered this happening with 3G tethering and how the 3G tether scripts disable the firewall. Of course my testing didn't reveal this bug because I tested 3G first, then tethering...

Went to the Advanced page, issued /etc/init.d/firewall disable; /etc/init.d/firewall off using the "Execute Commands" box and refreshed example.com on my phone. It worked.

We'll squash this for good in the update coming out shortly. In the mean time run that command, or better yet add it to rc.local -- that's the startup script and you can edit it directly from the Jobs page.

Man, I can't believe I missed that one. Ugh. Reminds me of trying to host a Quake 3 server at a LAN party on a Windows XP box with the firewall up. *sigh*

Link to comment
Share on other sites

Just read the OP. Reserving this spot. Pulling a pineapple off the factory line and testing. Standby.

Edit: Just read the rest of the comments. This is weird. In all of my tests I've been using the mk3.sh (now renamed to mk4.sh) on linux and tethering has always worked. First thought: Go to the advanced page in the web UI and in the text area at the bottom type "/etc/init.d/firewall stop" then click Execute Commands. Ok, grabbing a pineapple and looking for a Windows 7 machine now...

Edit 2: Issue /etc/init.d/firewall disable; /etc/init.d/firewall off from the Execute Commands text area a the bottom of the advanced page.

Ok I grabbed a pineapple off the shelf, powered it, connected the spiffy little retractable ethernet cable between the pineapple's PoE LAN port and my laptop, booted Ubuntu (My Windows install is on a HDD collecting dust), connected to the WiFi on wlan0 and ran mk4.sh. It pinged 172.16.42.1 no problem. I browsed to http://172.16.42.1/pineapple, logged in, enabled karma. Went to the advanced page and verified that 172.16.42.42 is the default gateway. Entered 8.8.8.8 in the ping box and got replies, so it's online. Entered example.com in the ping box and also got replies, so DNS is working. Entered cat /etc/config/network; cat /etc/conf/dhcp in the execute commands box and everything looked great.

Then I put my phone in airplane mode (so it's off the 3G network), enabled wifi, added an SSID called "is_ics_working" and instantly it connected. Tried to pull up example.com in my browser, no dice.

Remembered this happening with 3G tethering and how the 3G tether scripts disable the firewall. Of course my testing didn't reveal this bug because I tested 3G first, then tethering...

Went to the Advanced page, issued /etc/init.d/firewall disable; /etc/init.d/firewall off using the "Execute Commands" box and refreshed example.com on my phone. It worked.

We'll squash this for good in the update coming out shortly. In the mean time run that command, or better yet add it to rc.local -- that's the startup script and you can edit it directly from the Jobs page.

Man, I can't believe I missed that one. Ugh. Reminds me of trying to host a Quake 3 server at a LAN party on a Windows XP box with the firewall up. *sigh*

Good work Darren! Thanks!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...