Jump to content

Captive Portal On The Mark Iii


Recommended Posts

Flashed my Mark III with the newest firmware (2.1.2) and noticed the redirect page for DNS spoofing said that:

One, it supported PHP.

and

Two, may be configured as a
.

Looking around and got a good idea what to use it for from Eviltechie's Post back in 2008.

I would like the captive portal to display something similar to x942's post ( or some other page )

have a button for them to agree to the TOS

then allow them to get to the internet for a set period of time, lets say 120 minutes.

I've tried wifidog. can only get the Gateway installed and haven't been able to configure it to do anything like a captive portal.

everything else out there needs a RADIUS server for authentication.

all i want it to do is display the page to someone who has just connected, hasn't clicked the agree button, or their session time has expired.

Any thoughts?

Edited by pewpew
Link to post
Share on other sites

I did not try it myself but maybe have a look at NoCatSplash

NoCatSplash is a Open Public Network Gateway Daemon. It performs as a [captive/open/active] portal.

When run on a gateway/router on a network, all web requests are redirected until the client either logs in or clicks "I Accept" to an AUP.

The gateway daemon then changes the firewall rules on the gateway to pass traffic for that client (based on IP address and MAC address).

Link to post
Share on other sites

was able to install Nodogsplash finally on 2.1.2 ( wont install on v1.9)

having a bit of an issue with this distro of Open-WRT

Looks like we're using ATTITUDE ADJUSTMENT (bleeding edge, r29839).

Nodogsplash seems to run best on Backfire or Kamikaze 8.09 (w/fixes), as IMQ isn't in Attitude Adjustment anymore, at least not that i could find

Plus

opkg install iptables-mod-imq

opkg install kmod-ipt-imq

opkg install kmod-sched

were not installing

Don't know if they are only for Backfire or not.

Did the copy paste thing for the interface config

ended up needing to reflash the firmware as it wasn't ping on 172.16.42.x or 10.0.15.x or 10.0.10.x anymore.

kind lost with adding sudo ports like eth0.1 and bridging them on an interface.

Thanks for the tips!

Will look for a better guide on nodogsplash later.

Tired after a long shift.

Edited by pewpew
Link to post
Share on other sites
  • 1 month later...

OK round two

gave up on wifidog and nocatsplash

trying out nodogsplash again ( which is a mesh between the nocat and wifidog ) using this tutorial

was able to install it ( and didn't brick it this time )

started with

a freshly flashed MK3 w/2.1.2

ran

opkg update

then

opkg install nodogsplash

it installed ok

set up

/etc/nodogsplash/nodogsplash.conf

added in the traffic control

added in the interface to use [br-lan]

added in the splash/error page

then ran

/etc/init.d/nodogsplash start

and got

[3][Thu Jan 1 00:21:06 1970][1730](gateway.c:249) Could not create web server: Address already in use

EDIT:

also getting this

[3][Thu Jan 1 00:26:23 1970][1449](tc.c:164) Could not set imq0 up. Download limiting will not work

/bin/sh: ip: not found

[3][Thu Jan 1 00:26:23 1970][1449](tc.c:178) Could not set imq1 up. Upload limiting will not work

is this because the pineapple is already using the web service for its own pages? ( i.e. phishing facebook.html )

EDIT 2:

here is the status of nodog

Starting nodogsplash ... 
==================
NoDogSplash Status
====
Version: 0.9_beta9.9.6
Uptime: 0d 0h 1m 15s
Gateway Name: "MK3 Pineapple"
Managed interface: br-lan
Managed IP range: 0.0.0.0/0
Server listening: 172.16.42.1:2050
Splashpage: /etc/nodogsplash/htdocs/splash.html
Traffic control: yes
Download rate limit: 200 kbit/s
Upload rate limit: 30 kbit/s
Total download: 0 kByte; avg: 0 kbit/s
Total upload: 0 kByte; avg: 0 kbit/s
====
Client authentications since start: 0
Httpd request threads created/current: 0/0
Current clients: 0
====
Blocked MAC addresses: none
Allowed MAC addresses: N/A
Trusted MAC addresses: none
========

Edited by pewpew
Link to post
Share on other sites

The error about the webserver simply says that the default (uhttpd) webserver is running.

Stop it / disable it like this:

/etc/init.d/uhttpd stop

/etc/init.d/uhttpd disable

The other two errors you are getting I am unsure about.

I will research and report back.

Best,

Sebkinne

Link to post
Share on other sites
  • 9 months later...
  • 4 months later...

Just picked this up after seeing the episode with it as a demo. Looks like it's not quite kosher with 2.8.1 yet (these are the other packages that Darren suggests installing with nodogsplash):

Collected errors:
* opkg_install_cmd: Cannot install package iptables-mod-imq.
* opkg_install_cmd: Cannot install package kmod-ipt-imq.
* satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-sched:
* kernel (= 3.3.8-1-d6597ebf6203328d3519ea3c3371a493) * kernel (= 3.3.8-1-d6597ebf6203328d3519ea3c3371a493) *

I might be missing a few other options, but it does manage to start up successfully. However, it's not intercepting any HTTP requests. Again, I've only had a few minutes to play with it today, but I figured I'd get the ball rolling again since it looks like there's a way to make it work out there.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...