Jump to content

Mk4: Shmoocon Edition Hotfix


Darren Kitchen
 Share

Recommended Posts

If you picked up a MK4 from Shmoocon please do not use the factory reset function on the Advanced page. I discovered a flaw in the firmware that will make the pineapple very unhappy.

The factory reset button executes the commands rm /etc/config/* and cp /etc/config/backup/* /etc/config/

Problem is, the MK4 from Shmoocon doesn't contain a /etc/config/backup directory filled with original configs.

Here's a quick hotfix for the problem.

From the advanced page paste the following into the bottom text field and click "Execute Commands"

mkdir /etc/config/backup/
cp /etc/config/* /etc/config/backup/

As always, MK3 or 4, if you're having problems with your Pineapple that you can't fix yourself please contact shop@hak5.org and we'll take care of you.

And if you're not up to speed on the mk4 details please see http://forums.hak5.org/index.php?showtopic=25448

Link to comment
Share on other sites

We'll have a firmware update for the MK4's that launched at Shmoocon this week. Good to hear you're up and running MF_berry. We're not ready for 3G out-of-the-box yet, but we're on our way. I'll post my findings as I have working configs. Right now I'm focusing on the Novatel MC760 as it's widely supported in Linux. That's the Virgin Mobile dongle I had at the booth. About a hundred bucks at a Best Buy and the unlimited 3G refill cards at $50. Both can be bought with cash ;)

Link to comment
Share on other sites

I purchased a WifiPineapple Mk4 at shmoocon, and I have challenges the whole time, at this point I did a factory reset and now neither interface on the device lights up. I tried to use the wp3.sh on an Ububtu and

received errors, I also tried on a windows machine still no luck. So what do I need to do to unbrick my new wifiPineApple Mk4? Can I use the USB port?

Please help!!

Link to comment
Share on other sites

eeffaabb, please contact shop@hak5.org. If you used the factory reset button before applying the above hot fix we're going to have to reflash your pineapple (unless you have a serial console cable)

I have a serial cable with a usb to serial adapter (TRENDnet TU-S9) connected to a WindowsXP machine. I tried to set connection through hyper terminal with the following port settings:

Bit Per Second: 9600

Data Bits: 8

Parity: None

Stop Bits: 1

Flow Control: None LAN Port

I also used the rj45 connector to the PoE port on the pineapple.

And then tried to use the ymodem to send "openwrt-atheros-vmlinux.lzma". Was not able to transfer, and I never got into the bootstrap in the pineapple.

Nothing is working for me.

What am doing wrong, are there a specific instructions on how to do this?

What version of the firmware do I use? Can you send me a link to were it is?

Sorry I need to be spoon fed this, I really want to get this to work and I do not want to send this to the west coast to get flashed, since I am on the east coast. I NEED HELP

Link to comment
Share on other sites

Here's a quick flashing guide for the MK4 via serial:

Connect a USB TTL Serial console cable to the pin headers next to the USB port. Set your com program (hyperterminal, minicom, screen, gcom) to use these settings:

115200, 8, N, 1, no hardware flow control, no software flow control

minicom -s

Connect ethernet between the PC and the Pineapple's WAN/LAN port. Set a static IP on the PC of 192.168.2.11 / 255.255.255.0

ifconfig eth0 192.168.2.11 netmask 255.255.255.0 up

Configure a TFTP server (Windows: http://tftpd32.jounin.net/ Linux: http://code.google.com/p/tftpgui/)

Download the factory firmware from http://wifipineapple.com/mk4/factory/kernel.bin and http://wifipineapple.com/mk4/factory/rootfs.bin

wget http://wifipineapple.com/mk4/factory/kernel.bin; wget http://wifipineapple.com/mk4/factory/rootfs.bin

Move the two bin files in your tftproot directory

Power on the pineapple. In your com program you will see:


U-Boot 1.1.4 (Sep 29 2011 - 16:39:41)

AP121-8MB (ar9331) U-boot
DRAM:  32 MB
Top of RAM usable for U-Boot at: 82000000
Reserving 248k for U-Boot at: 81fc0000
Reserving 192k for malloc() at: 81f90000
Reserving 44 Bytes for Board Info at: 81f8ffd4
Reserving 36 Bytes for Global Data at: 81f8ffb0
Reserving 128k for boot params() at: 81f6ffb0
Stack Pointer at: 81f6ff98
Now running in RAM - U-Boot at: 81fc0000
id read 0x100000ff
flash size 8388608, sector count = 128
Flash:  8 MB
In:    serial
Out:   serial
Err:   serial
Net:   ag7240_enet_initialize...
Fetching MAC Address from 0x81feb688
Fetching MAC Address from 0x81feb688
: cfg1 0x5 cfg2 0x7114
eth0: 00:c0:ca:5f:6b:5d
eth0 up
: cfg1 0xf cfg2 0x7214
eth1: 00:c0:ca:5f:6b:5e
athrs26_reg_init_lan
ATHRS26: resetting s26
ATHRS26: s26 reset done
eth1 up
eth0, eth1

Please choose the operation: 
   1: Entr boot command line interface. 
   2: Load system code then write to Flash via TFTP. 
   3: Boot system code via Flash (default).

Press 1 to enter the U-Boot CLI

At the ar7240> prompt issue these commands:

setenv bootargs "board=ALFA console=ttyATH0,115200 rootfstype=squashfs,jffs2 noinitrd"
saveenv
tftp 0x80600000 kernel.bin
erase 0x9f650000 +0x190000
cp.b 0x80600000 0x9f650000 d695a
tftp 0x80600000 rootfs.bin
erase 0x9f050000 +0x600000
cp.b 0x80600000 0x9f050000 23d004
bootm 0x9f650000

Once OpenWRT finishes booting press ENTER to active the console. Issue passwd and set a root password. Next start the ssh service /etc/init.d/dropbear start

Move the Ethernet cable from the WAN/LAN port to the PoE LAN port.

From the PC ping 192.168.2.1 to verify a connection. From here you'll need to SCP over the latest MK4 update from http://wifipineapple.com/mk4/firmware

SCP the latest firmware .bin file to the Pineapple's /tmp/ directory (windows: http://winscp.net/eng/index.php linux: you already have scp)

scp firmware.bin root@192.168.2.1:/tmp/

Once the firmware has been copied to the pineapple's /tmp/ directory you're ready to update the factory firmware to the latest version of the Jasager suite. On the pineapple issue:

sysupgrade -n -v /tmp/firmware.bin

The upgrade process takes 2-3 minutes. When complete the Pineapple will reboot and all will be happy again in the land of the pineapple. Continue with normal usage (ie: change your PC's ethernet interface back to DHCP or static it to 172.16.42.42)

Link to comment
Share on other sites

Here's a quick flashing guide for the MK4 via serial:

<snip>

From the PC ping 192.168.2.1 to verify a connection. From here you'll need to SCP over the latest MK4 update from http://wifipineapple.com/mk4/firmware

Nice!! LOTS of great info there, thanks Darren!

Unfortunately, the link to the MK4 Firmware comes up empty though. Any thoughts?

Thanks again for all you do, brother!! :)

Edited by hfam
Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...