Jump to content

Bt5r1 Locks Up On Airmon-ng Command


Madd Maxx
 Share

Recommended Posts

I'm trying to run BackTrack 5 R1 on my HP laptop (DV7 series), but it won't get beyond searching for wireless adapters. I have an RTL8187 USB adapter plugged in and it identfies and displays it correctly, but when it attempts to identify the laptop's built-in adapter (Intel Centrino Wireless-N 1030), it freezes. No error message - just a blinking cursor. I have used the same 8187 adapter and BT5 DVD on other systems and both work correctly. It just doesn't work on the one I need it to work on. I haven't tried removing the built-in adapter yet. I'd rather not open up the system if I don't have to. The tiny plastic tabs on the rear cover are easily brioken, as I discovered when I installed a second hard drive. Any suggestions on how to fix this this? Thanks.

Link to comment
Share on other sites

I had this issue before with a blinking cursor. Eventually it would boot (4 minutes or so of blinking cursor), and I found it was related to me having a USB Mouse plugged in. I think the usb ports on the side are a hub and it confuses the boot or something. Try plugging in your USB device afterwards.

Also try and disable your internal card (if there is a switch). Chances are that no driver currently exists for that internal card.

Link to comment
Share on other sites

Just to clarify, there is no boot issue. It boots fully into BT5 and I can open windows and issue commands. I also tried turning off the wireless function with the appropriate function key and nothing changed. It found the 8187 USB adapter and then hung with the blinking curser. However, when I hit ctrl-c to end the process, I was then able to put the 8187 in monitor mode and continue with other mon0 commands. So I have a workaround until I figure out what's wrong.

Thanks for your input Mr-P.

Link to comment
Share on other sites

Thanks digip, that worked fine, and the Centrino Wireless-N 1030 Rev 34 card is supported in BT5R1.

As a side note - while I was playing with the ctrl-c routine to get my laptop to work with the 8187 USB card, I went back and retried airmon-ng and this time it saw the Centrino card and worked with it. But that only happened once, so I guess the current drivers are not quite ready for prime time with the Intel card.

Thanks again for your help.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...