Jump to content

Problem Internally Connecting To Extra Website Functions Such As Forums And Blogs


astromech_kuhns
 Share

Recommended Posts

Okay, i have what seems to be an awkward problem that doesnt seem to show up much in google. people with something similar but not quite the same....

i have a static IP from my ISP and a website i built, basic one, never put time into adding much styling as i started working on other things...

site is wwww.kkuhns.com

the server is at my house on a second desktop i have. so its located internally on my network.

i tried to put a blog on my site using wordpress and textpattern. both of which were a success. except one problem. from withing my network, i can navigate to my site by entering my servers static IP of 192.168.1.100. but not the FQDN. i can NOT however access my blog which use to be located at www.kkuhns.com/blog from inside my network by using either the FQDN or the servers ip. if i go to 192.168.1.100, it works. if i go to 192.168.1.100/blog it would time out. i have since scrapped the blog because of this and again kinda stopped working on it and pushed it aside due to this problem of not being able to access it. i cant blog or work on it from the backend if i cant access it from my computer.

just tonight, i decided to try setting up a forum for fun. kinda bored and wanted to try myBB for a while so i figured id give it a go. copied the files over, breezed through the install, and once i tried to access it, same problem.

the forum currently resides at www.kkuhns.com/forum and i can access it from outside my network but not from within by using either FQDN or server IP. although the site itself works fine. it just seems to be these extras of a blog or forum that are giving me problems. this time, its bugging me and i really want it fixed.

anybody have any ideas into this? any reason i would timeout while trying to access these from my internal network? here was the thread i started on wordpress.org and didnt get much help with: http://wordpress.org/support/topic/site-loading-time-and-site-address?replies=10

it has more detail on the blog one. like i said though, blog service is no more, although, if i can get this issue fixed, i may be putting a lot more time into my site!

server is ubuntu 10.10 server edition at 192.168.1.100

FQDN www.kkuhns.com

my modem is a qwest pk5000 incase its a setting problem.

and my connection problem comes from any computer in my internal network.

Thanks guys, i appreciate any advice or help on this!

Link to comment
Share on other sites

So people from the internet can reach your box, and you can reach it at the domain name, but locally, you can't reach the machine from LAN side IP addresses? This is a box on your home network with something like DynDNS, right? You could add to your hosts file an entry for your site, as its IP at 192.168.1.100. ex:

127.0.0.1 localhost
192.168.1.100 www.kkuhns.com

If that doesn't work, something on the box, is blocking your local IP, like in the htaccess file or hosts.deny, or the web server is somehow configured, to only speak on the external address. Have you tried ftp or ssh into the box?

If this box is hosted at some hosting company, but its internal IP is 192.168.1.100, you won't be able to reach it, since that address would be local to THEIR lan and behind NAT, and not yours, but I assume this is a box in your home and is on YOUR lan...

Link to comment
Share on other sites

Yeah sorry if that was a bit hard to follow ill try to explain it better.

On my personal home network im running a server and a website. i have a static IP from my ISP.and im using a FQDN from domain.com to point kkuhns.com to my web server.

anyone outside my network can reach my server by going to kkuhns.com but from inside my network, i cannot reach my server by going to kkuhns.com as it times out.

i can reach my website on my server by pointing to its internal IP address of 192.168.1.100 and i can navigate to any of the other directories, download links or pages by using 192.168.1.100 rather than kkuhns.com

however, anytime i add either a blog or a forum to my website, im able to run the install script from my laptop which is also on the network. i would navigate to 192.168.1.100/xxx/install and i was able to set the forum up. after running the install script, i seem to be blocked from accessing it with the IP address. note im not blocked from my site, just the forum or blog or something i set up is the only thing that times out. and it does that on all the computers on my network. i know it can be connected to from outside my network as i was able to go to it via my smartphone.

so to sum it up kkuhns.com has always timed out within my network but navigating to the servers IP of 192.168.1.100 brings the site up, however if i have a blog or a forum, i cannot access those from either kkuhns.com/forum or 192.168.1.100/forum as they time out.

one thing i can think of is that in the beginning when running the set up scripts for both the blog and the forum is they ask for my forums web address and i enter www.kkuhns.com/forum maybe thats a setting that could be causing it?

EDIT: i had retried connecting to it while making this post and it brought up only an html text version with nothing aligned.

post-21044-0-28920700-1326740343_thumb.p

Edited by astromech_kuhns
Link to comment
Share on other sites

I havent changed anything yet. sometimes it will only load html sometimes it times out. either way though i never get the actual site to load. it did this same thing with my blog i tried.

also can you elaborate on dropping my FQDN into my host's file? i have added server name and server alias to my sites available file under /etc/apache2/sites-available if thats what you are referring to.

Link to comment
Share on other sites

Actually, that seemed to resolve it completely! i just went to my site with www.kkuhns.com after editing the file and it came up, as well as went to www.kkuhns.com/forum and it worked flawlessly!

one more question i guess then, how do i fix this on a windows machine as i have a W7 desktop for gaming and internet browsing as well as my laptop. my family's computers all run windows as well. is there maybe a way to set this standard for all clients on my network through my modem/router?

Link to comment
Share on other sites

On the other machines if they are windows 7, add it to their hosts file as well. Locations:

xp, vista, win7 - c:\windows\system32\drivers\etc\hosts

win95, 98, 2000 (prior to windows XP basically) - c:\windows\hosts

Make sure they don't save with .txt on the end, or it won't work.

Reason you need to do this, is because the machine in question is local to your network, so you are timing out trying to resolve the domain name, and the router probably sends the query to the internet(yoru ISP's dns server) and comes back as its own IP address, and the router probably then drops it on the outer interface. Using a hosts file, means you don't send the query to your gateway and DNS servers for resolution, but instead, use whatever you put in the hosts file. This also works when you want to block websites, like ad networks, for example pointing ads.doubleclick.net to localhost. ex:

127.0.0.1 localhost
127.0.0.1 ads.doubleclick.net
192.168.1.100 www.kkuhns.com

so then whenever an ad from "ads.doubleclick.net" tries to load, it should timeout and you wont see them or any code, iframes, sites you want to block.

Edited by digip
Link to comment
Share on other sites

I said in wordpress post i thought it had something to do with the loopback! Awesome thank you guys so much! really helpful and good to know, i had edited it once before when searching the problem but i wasnt adding the correct line to the file which is why it never worked a couple months back! i really appreciate all the help on here!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...