Jump to content

Mk3: Atheros Based Files To Flash


Recommended Posts

OK , I am try to get this clear.

I launch the ap51-flash-fonera-gui-1.0-42. There are 2 input boxes, the first one I browse to the squash file and the second I browse to the lzma file. Do I also check the boxes for 'Create Nvram Partition' and 'Uncompressed Load' as well?

Link to comment
Share on other sites

  • Replies 164
  • Created
  • Last Reply

Top Posters In This Topic

Ok, so I dont check any boxes and I have the pineapple connected with a crossover cable. I hit 'Go' in the EasyFlash and then plug in the power on the pineapple. I get ..

stderr:Non arp received. Make sure the device is connected directly!

stderr:Expect arp with lenght 60, receive 42.

Perr MAC: 00:c0:ca:32:b1:a8

Peer IP: 192.168.0.1

Your Mac: xx:xx:xx:xx:xx:xx

Your IP: 192.168.0.0

If I keep the pineapple plugged in I at least get the correct 172.16.42.1 IP..

Am I doing it right?

Link to comment
Share on other sites

Great to hear that you like it!

I had several sleepless nights to get this out of the way ;)

What logs are retained through the clearing of the cache? Arp and DHCP will be retained, but the others should be cleared?

@Mother,

How about you try booting the router? The first boot can take about 5 minutes. Just run a "ping -t 172.16.42.1" (in windows) and wait for it to reply. Then after around 5 minutes you should be able to ssh into the pineapple.

Make sure though that your NICs IP is on the same subnet (and if it is used for ics, it needs the ip 172.16.42.42).

Best,

Sebkinne

im looking at the url snarf and ngrep status on the front page

edit: ok, it's clearing everything out now. i had it up for a while, went to reboot the router and all the data was still there. i unplugged it then plugged it back in and it seemed to clear out all the logs. still it seems like a bit of an inconvenience how i have to go through and clear my iptables and unplug the thing before it'll clear my old ngrep and url snarf logs

Edited by allisonmagic
Link to comment
Share on other sites

on my OM1P i turned on all services except airmon-ng, after a few hours i went to check on it and it looks like it rebooted itself, now just running karma and urlsnarf, will post as i test, urlsnarf still will reboot the Fon2100 since it runs out of RAM. going to vegas for the weekend and i plan to bring my OM1P, 3201A and 2201 for testing, maybe the 2100 too, cant wait to see the airport results tonight

Update: after turning karmer and urlsnarf on i can no longer access the web interface, its still on, per the code the wifi light is on so karma must be on, will try a power cycle and see what happens

Update: currently trying a 3201A, going to start the services karma and urlsnarf and let it run for a few hours.

Update: i to only see data in the ARP and DHCP logging section, nothing else, this happens on all my devices i test, 2100 A/B/C, 2100 D/F, OP3201A, OM1P, 2201, and my 2202.

Update: have an Open Mesh 3201A fired up, one weird thing is that this out of all my devices responds the quickest and seems to work the best even though my OM1P has better HW, have the following services up Karma, URLSnarf and NGrep, no data showing in both but i did just fire them up and connect the pineapple to internet, will check the data in about 30min or so and also to see if i ran into the same issues as last night, as far as the different range of IP on the internet SSID, i thought that was intended and a good idea so no one could access the interface at all, but i do understand how it could be useful, with the non karma SSID, pineapple, i can access the interface and get my services started

Update: had my 3201A MK3 crash and had to power cycle, same happened to my OM1P, services running were karma, ngrep and urlsnarf, after reboot ran just karma and ngrep and after a few clients connecting it started to lag and almost crash if i didnt stop ngrep, now its running as normal with just karma, per the data and logs it looks like ngrep running is causing the router to crash and freeze up, but resources are not running out since it doesnt reboot itself, now trying karma and urlsnarf

Update: nope, karma just died, it looks like urlsnarf is causing the problem, retrying karma and ngrep again, even though no data shows for ngrep, this crash took only a few minutes.

Update: narrowed down the reboot cause, if i plug any of the MK3 routers directly into a switch/router to give it internet it causes the reboot, if i leave it unplugged it stays up and catches clients, have been watching it since the last update. I have not tried the normal way to give it internet via connection sharing, will try that tonight in the airport and post the results...

Update: added a GPIO script i created so i can see if wifi is on regardless if Karma is started to see what happens after it crashes, so far it works on boot

Update: while at my hotel i put up a 3201A Open Mesh MK3, just started Karma and URLSnarf, when i got back All services where off, but the interface was still enabled.

Note: usually when i start karma and when it switches to the karma SSID and i connect it issues a IP other then the non Karma SSID 172.16.42.XXX, now with Karma running when i connect to SSID internet i still get the 172.16.42.XXX IP and can connect to the pineapple web interface, i am using my linux laptop vs the Winblows 7 laptop i used before to admin the pineapple. Can anyone confirm this IP issued?

Update From Weekend: i used one specific pineapple all weekend while at the airport twice and while at my hotel, the weirdest thing that happened was that while leaving it running for two days if i didnt stay connected via cable it would i believe reboot, i didnt get to check uptime, if i didnt stay connected or connect via wirless when i came back at the least 2 hours later it would show all services off including karma. so i now have a router with great logs and other info to possibly identify any issues during a 2-3 day runtime. other then the possible reboot all services ran, but i never saw any data in the Ngrep, URLSnarf log areas, NGrep is a known issue and URLSnarf i didnt run/try prior to 1.9 so it could have worked previously.

Edited by Ghostshell
Link to comment
Share on other sites

Deauth Host: 00:11:22:33:44:55

Deauth Target: 38:ca:da:9c:52:c7

Deauth Times: 5

Executing: aireplay-ng -0 5 -a 00:11:22:33:44:55 -c 28:cf:da:9c:58:c0 --ignore-negative-one mon0

00:06:33 Waiting for beacon frame (BSSID: 00:11:22:33:44:55) on channel 1

00:06:43 No such BSSID available.

Please specify an ESSID (-e).

huh ? this is my first time running deauth from the pineapple ui... giving me issues .. do i need to reconfigure the script for it ?

Link to comment
Share on other sites

Hi All. my 1st post. Ive flashed a 2100 abc with MKIII and while it loads and works (ish) its apparent that its under powered soooo sloooow. Nothing I do will get URLSnarf to work, simply reboots the device. So i guess Ill have to fork out after the holidays and buy a shop one (any ideas when they'll be in?)

I did have fun with your php Darren and loaded bootstrap CSS coz i like my gui's to be pretty and my terminals green :)

Link to comment
Share on other sites

Just flashed my Fon 2100, I can access it via SSH no problem but when I try to access it via web I get this:

Warning: main(error.html) [function.main]: failed to open stream: No such file or directory in /www/redirect.php on line 8

Fatal error: main() [function.require]: Failed opening required 'error.html' (include_path='.:') in /www/redirect.php on line 8

Link to comment
Share on other sites

You will find the older fons and MR3201a have 16mb of RAM, the newer Open Mesh and AP51's are 32mb, makes a world of difference. For fun I also flashed my older fon, very little free memory with the mark3 firmware running, even less when Karma is enabled, very sluggish.

Have fun.

Link to comment
Share on other sites

You will find the older fons and MR3201a have 16mb of RAM, the newer Open Mesh and AP51's are 32mb, makes a world of difference. For fun I also flashed my older fon, very little free memory with the mark3 firmware running, even less when Karma is enabled, very sluggish.

Have fun.

Hi. Has anyone used the OM2P? It's nice looking :)

For the record the older Fons (2100) just arent Working. Too slow and constant reboots if you start ng, karma and DNS its up and down like a yoyo. And it's slow to reboot so a field test gets me 3 attempts on my dells battery.

Edited by Tezzal
Link to comment
Share on other sites

Hi. Has anyone used the OM2P? It's nice looking :)

For the record the older Fons (2100) just arent Working. Too slow and constant reboots if you start ng, karma and DNS its up and down like a yoyo. And it's slow to reboot so a field test gets me 3 attempts on my dells battery.

The OM2P does look nice, and I have one coming to me soon, but at some point not too far away I will release a firmware for that too.

Just stay put a little longer ;)

About the older Fons, you are right, most of them cannot handle it well. I however have an old fon (same type as the MKI was originally) which somehow manages not to crash. It is a little modified firmware wise I have to admit, but I will look into releasing a lighter version soon.

Best,

Sebkinne

Link to comment
Share on other sites

  • 2 weeks later...

The OM2P does look nice, and I have one coming to me soon, but at some point not too far away I will release a firmware for that too.

Just stay put a little longer ;)

I took a chance and ordered an OM2P, I am familiar with Redboot from the Fons/AP51/OM1P however can anyone point me to info on flashing it or other routers using U-Boot?

+2 on awaiting a U-boot image for MK3, or info on how to compile one, if possible from the MK3 .squashfs and .lzma?

Thanks, Seb for all the work you do.

Link to comment
Share on other sites

I took a chance and ordered an OM2P, I am familiar with Redboot from the Fons/AP51/OM1P however can anyone point me to info on flashing it or other routers using U-Boot?

+2 on awaiting a U-boot image for MK3, or info on how to compile one, if possible from the MK3 .squashfs and .lzma?

Thanks, Seb for all the work you do.

The current firmware will not run on the OM2P as it is an AR71x board.

There is no problem for me to support it but I am still waiting for my own OM2P to actually test if it all works. Before that I would rather not release firmware which may brick others devices.

I will make a U-Boot image available relatively soon.

My pleasure!

Best,

Seb

Link to comment
Share on other sites

First of all,

thanks for the good work you have done here.

After flasing the 1.9 Firmware x times via Redboot, it never worked as intended,

so tried it again with the ap51 utility, which was never able to detect my interfaces correctly (drop down,list always empty),

but this time it worked - i have no idea why but MK3 is now working on my 2202 but i have a few questions regarding fimware.

First i was wondering if it is possible to use the stock webinterface from backfire as well as the pineapple ui?

I tried to get passwordless authentication via private key file / authorized_keys in dropbear but this seems to be different from

the configuration of sshd .

The USB led is lit all the time, maybe i missed something to read? I think when using Backfire 10.03.1 the leds were working

correctly but i'm not fully sure, will investigate this later.

On our pineapple-wiki, there are .ipk files for use with a stock openwrt-distro, is this still applying to the latest mk3 firmware?

Maybe it is possible to use both webui's when just adding the missing packages? (mk3 uses opkg and not itsy right?)

And one last question about the error message when accessing the ip directly:

The redirect.php includes a error.html, but there is only a error.php. Maybe i did not understand how it works yet, maybe there

is something missing?

cheers phk

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...