Jump to content

Mark 3 Web Interface Problem


Recommended Posts

what's up guys.. it took me a couple weeks but i finally was able to ssh into my pineapple, add the configuration files and packages from wifipineapple.com .

im only having 1 issue.. i added the configuration files for the web interface into /www but now it wont let me connect anymore.. maybe it disabled the web service ? i dont know exactly what service it's using for that but i would like a little help trying to understand. i've gotten this far, i know i can get the rest of this working..

BusyBox v1.15.3 (2010-04-06 03:13:33 CEST) built-in shell (ash)

Enter 'help' for a list of built-in commands.

_______ ________ __ \

| |.-----.-----.-----.| | | |.----.| |_ \ \

| - || _ | -__| || | | || _|| _| \ \ \

|_______|| __|_____|__|__||________||__| |____| <, .v , // ) ) ) ) )

|__| W I R E L E S S F R E E D O M \\; \// // / / /

ATTITUDE ADJUSTMENT (bleeding edge, r27575) ---------- ;\\|||//; / /

* 1/4 oz Vodka Pour all ingredients into mixing ,'<\/><\/` /

* 1/4 oz Gin tin with ice, strain into glass.,.`X/\><\\>`

* 1/4 oz Amaretto ;>/>><\\><\/`

* 1/4 oz Triple sec |<\\>>X/<>/\|

* 1/4 oz Peach schnapps `<\/><\/><\\;

* 1/4 oz Sour mix '/\<>/\<>/'

* 1 splash Cranberry juice `<\/><;`

-----------------------------------------------------WiFi_Pineapple MKIII

root@Pineapple:~# pwd

/root

root@Pineapple:~# cd /www

root@Pineapple:/www# ls

cgi-bin index.html luci-static redirect.php

error.php index.php pineapple resources

root@Pineapple:/www# cd pineapple

root@Pineapple:/www/pineapple# ls

about.php ngrep.sh stopdnsspoof.php

advanced.php phish.log stopkarma.php

arp ping.php stopngrep.php

associations.log spoofhost stopurlsnarf.php

config.php startairmon.php traceroute.php

deauth.php startairmon.sh update-associations.sh

dhcp startdnsspoof.php update-ngrep.sh

dnsspoof.log startkarma.php update-urlsnarf.sh

dnsspoof.sh startkarma.sh urlsnarf-clean.log

index.php startngrep.php urlsnarf.log

jquery.min.js starturlsnarf.php urlsnarf.sh

ngrep-clean.log stopairmon.php version

ngrep.log stopairmon.sh wait.php

root@Pineapple:/www/pineapple#

the /www folder's permissions are set as :

drwxrwxrwx

when i try to open http://172.16.42.1/pineapple/

Unable to connect

Firefox can't establish a connection to the server at 172.16.42.1.

i know im doing somethin wrong, but i dont know the exact way everything operates in the pineapple itself. however i do know quite a bit about linux...

any help would be awesome right now.. i flashed my pineapple and couldn't use it for a week, finally figured out how to get it back up. flashed, pineapple software installed, ICS perfect.. ssh is working excellent...

can't stop now !

Link to comment
Share on other sites

couple more things to show you guys :

root@Pineapple:~# ping yahoo.com

PING yahoo.com (72.30.2.43): 56 data bytes

64 bytes from 72.30.2.43: seq=0 ttl=249 time=26.004 ms

64 bytes from 72.30.2.43: seq=1 ttl=249 time=24.991 ms

64 bytes from 72.30.2.43: seq=2 ttl=249 time=24.932 ms

^C

--- yahoo.com ping statistics ---

3 packets transmitted, 3 packets received, 0% packet loss

round-trip min/avg/max = 24.932/25.309/26.004 ms

yah i have internet access in the pineapple... also..

root@Pineapple:~# ps x

PID USER VSZ STAT COMMAND

1 root 1364 S init

2 root 0 SW< [kthreadd]

3 root 0 SW< [ksoftirqd/0]

4 root 0 SW< [events/0]

5 root 0 SW< [khelper]

8 root 0 SW< [async/mgr]

26 root 0 SW< [kblockd/0]

56 root 0 SW [pdflush]

57 root 0 SW [pdflush]

58 root 0 SW< [kswapd0]

59 root 0 SW< [aio/0]

60 root 0 SW< [crypto/0]

81 root 0 SW< [mtdblockd]

226 root 0 SWN [jffs2_gcd_mtd2]

241 root 1364 S init

255 root 1368 S syslogd -C16

257 root 1348 S klogd

271 root 772 S /sbin/hotplug2 --override --persistent --set-worker /

511 root 1144 S /usr/sbin/dropbear -P /var/run/dropbear.1.pid -p 22

552 root 1360 S watchdog -t 5 /dev/watchdog

555 root 1200 R /usr/sbin/dropbear -P /var/run/dropbear.1.pid -p 22

556 root 1368 S -ash

562 root 1356 R ps x

root@Pineapple:~#

Pinging 172.16.42.1 with 32 bytes of data:

Reply from 172.16.42.1: bytes=32 time=1ms TTL=64

Reply from 172.16.42.1: bytes=32 time=1ms TTL=64

Reply from 172.16.42.1: bytes=32 time=1ms TTL=64

Scanning 172.16.42.1 [1 port]

Completed ARP Ping Scan at 19:26, 0.20s elapsed (1 total hosts)

Initiating Parallel DNS resolution of 1 host. at 19:26

Completed Parallel DNS resolution of 1 host. at 19:27, 2.58s elapsed

Initiating SYN Stealth Scan at 19:27

Scanning 172.16.42.1 [1000 ports]

Discovered open port 22/tcp on 172.16.42.1

sshd open only...

and my client cannot get an ip anymore from the pineapple.. the pineapple shows as it's online and broadcasting a signal.. i cannot get an ip from my phone anymore. first i didn't have internet access, but now i just can't connect at all . lol

Edited by allisonmagic
Link to comment
Share on other sites

You know I just realized after running into a similar issue porting the mk3 interface to the mk2. It seems the default /etc/config/wireless contains:

option macaddr 00:c0:ca:32:90:94

Which is the mac address of my first dev mk3. This will need to be changed to *your pineapple's mac*.

Find the sticker on the bottom of your AP51 and increment the last octet of the shown hardware address by 1 (the listed mac is ethernet, wifi is +1). This is what should be listed in your /etc/config/wireless file - which is why your wireless network isn't working

also try ifconfig and see what's going on with wlan0. If you don't see it listed, this is why. Fix the config file and reboot. Hope that helps!

Link to comment
Share on other sites

dude, my mac is 87:8f

root@Pineapple:~# ifconfig

ath0 Link encap:Ethernet HWaddr 00:C0:CA:32:87:90

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:87 errors:0 dropped:87 overruns:0 frame:0

TX packets:25 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:5460 (5.3 KiB) TX bytes:6226 (6.0 KiB)

br-lan Link encap:Ethernet HWaddr 00:C0:CA:32:87:8F

inet addr:172.16.42.1 Bcast:172.16.42.255 Mask:255.255.255.0

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:1663 errors:0 dropped:0 overruns:0 frame:0

TX packets:1587 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:82856 (80.9 KiB) TX bytes:101881 (99.4 KiB)

eth0 Link encap:Ethernet HWaddr 00:C0:CA:32:87:8F

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:1578 errors:0 dropped:0 overruns:0 frame:0

TX packets:1611 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:99584 (97.2 KiB) TX bytes:108706 (106.1 KiB)

Interrupt:4 Base address:0x1000

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

UP LOOPBACK RUNNING MTU:16436 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wifi0 Link encap:UNSPEC HWaddr 00-C0-CA-32-87-90-00-00-00-00-00-00-00-00-00 -00

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:217 errors:0 dropped:0 overruns:0 frame:26

TX packets:137 errors:9 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:195

RX bytes:25735 (25.1 KiB) TX bytes:17809 (17.3 KiB)

Interrupt:3 Memory:b0000000-b000ffff

should i increment the last octet of the wifi0 and ath0 or just change it to my pineapple mac ? and should it be 8G instead of 8F ? or 9F

Edited by allisonmagic
Link to comment
Share on other sites

http://172.16.42.1/index.php

Unable to connect

Firefox can't establish a connection to the server at 172.16.42.1.

this is really annoying as well

i know is is for the old firmware, but do i still have to add any of these for the new one ?

(See the openwrt repository at downloads.openwrt.org/kamikaze/8.09.2/atheros/packages. The default package on the WiFi Pineapple is X-WRT, a web based management interface, and its dependency haserl.)

Edited by allisonmagic
Link to comment
Share on other sites

@allisonmagic Do you have a web server installed at all? Sorry if I misunderstood, but it seems like you haven't installed all of the packages required for all of this to work.

Darren has a long list of packages on the wiki you will need to download, transfer onto the router and install using "opkg install *".

If you have done all of that and it still does not work, report back!

Best,

Seb

Link to comment
Share on other sites

@allisonmagic Do you have a web server installed at all? Sorry if I misunderstood, but it seems like you haven't installed all of the packages required for all of this to work.

Darren has a long list of packages on the wiki you will need to download, transfer onto the router and install using "opkg install *".

If you have done all of that and it still does not work, report back!

Best,

Seb

ok here's the situation... i got the web interface up, i got ngrep and aircrack installed. the only thing not working is airodump... i tried to run karma, but i guess there's no package for karma here to install...i tried to install jasager but after you flash the jasager package then the router doesn't want to work after that... if i go with the packages darren uploaded to wifipineapple.com everything works fine, but karma isn't installed... the pineapple also keeps resetting itself and inside the advanced tab "command" prompt, when you enter commands there's no response from the pineapple and i've still got darren's old ngrep logs in my interface.. everything installed, nothing works except ICS in backtrack.

what more detail can i post ?

Edited by allisonmagic
Link to comment
Share on other sites

If you don't mind, I recommend you flash my firmware. You can find it in this forum.

That will install all of the packages you need for you.

Best,

Seb

just so you know, im using the mark3. thanks for that, im gonna go grab it right now. that's awesome information. didn't you port that firmware to the mk2 ?

Edited by allisonmagic
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...