Jump to content

Internet Sharing Problems


MDauer
 Share

Recommended Posts

Sorry to post what is probably a really stupid question, but I can not for the life of me figure out how to do this. I am trying to set up my Fon+ so that the settings are as follows:

Internet > Router > (wireless connection)Laptop > (ethernet connection) Fon+ > (Wireless Connection) "Victims"

For some reason my "Victims", being in my case my cellphone, can not connect outside and I can not figure out what I am doing wrong. Would someone please be able to help me with this either by showing me where I can find a guide or by looking at my config files. I can post what ever you would need to look at.

Currently my home router with access to the internet has an ip of 192.168.1.1

My laptop has an IP of 192.168.1.109

My Fon+ router has an IP of 10.110.0.2 after following the guide pinned to the boards.

Also, per the guides instruction, my "/etc/config/dhcp" file looks like this on my FON+

config 'dnsmasq'

option 'domainneeded' '1'

option 'boguspriv' '1'

option 'filterwin2k' '0'

option 'localise_queries' '1'

option 'local' '/lan/'

option 'domain' 'lan'

option 'expandhosts' '1'

option 'nonegcache' '0'

option 'authoritative' '1'

option 'readethers' '1'

option 'leasefile' '/tmp/dhcp.leases'

option 'resolvfile' '/tmp/resolv.conf.auto'

config 'dhcp' 'lan'

option 'interface' 'lan'

option 'start' '100'

option 'limit' '150'

option 'leasetime' '720m'

option 'ignore' '0'

list 'dhcp_option' '3,10.110.0.1' # This is the IP address of . .

#. . The Host Laptop's Net-Interface acting as GW

list 'dhcp_option' '6,10.110.0.2,8.8.8.8' # This is Option 6 define the DNS server, . .

# . . Then IP of Pineapple, Then Googles DNS IP

config 'dhcp' 'wan'

option 'interface' 'wan'

option 'ignore' '1'

option 'start' '100'

option 'limit' '150'

option 'leasetime' '720m'

Finally, I also changed the LAN setting from "/cgi-bin/webif/network.sh" as per the guide:

Connection Type = Static IP

Type = Bridged

IP Address = 10.110.0.2

Netmask = 255.255.255.0

Default Gateway = 10.110.0.1

After all is said and done, when I try and connect as a victim, the internet just times out and nothing happens....

Any help would be GREATLY appreciated.

Link to comment
Share on other sites

These are my install/setup notes I made when I built my Fon2100 Jasager/Pineapple.

See if they help: My Notes

Thanks for the notes. I was able to get to the portion where you have

login to Jasager interface http://192.168.169.169:1471

turn on ath0 button

add your ssid your laptop is getting internet from to the blacklist

enable karma

but when I try and goto 192.168.169.169:1471 my browser times out and wont let me connect.

At this point I have completed everything above this, I am connect to my home network on WLAN0 and connected to the FON+ through eth0. The cable is going from my laptop to the WAN port on the router. I have also tried connecting it to the LAN port instead but I get the same results... (The browser just sits there then times out)

Link to comment
Share on other sites

You need to find out where the break is. Try to ping the router from the victim machine, then try to ping eth0 on the attacking machine, then wlan0, and so on. IE if you can ping 8.8.8.8 successfully but cannot ping google.com, it's a DNS problem. If you can ping eth0 (I assume thats 10.110.0.1) of the attacking machine but not wlan0 of the attacking machine it's a problem in the bridging (probably something in iptables). Be more specific with your problem.

Link to comment
Share on other sites

Thanks for the notes. I was able to get to the portion where you have

but when I try and goto 192.168.169.169:1471 my browser times out and wont let me connect.

At this point I have completed everything above this, I am connect to my home network on WLAN0 and connected to the FON+ through eth0. The cable is going from my laptop to the WAN port on the router. I have also tried connecting it to the LAN port instead but I get the same results... (The browser just sits there then times out)

Did you set your IP of the router to 192.168.169.169? Check your config files vs mine.

Also you may need to reboot the router after you make those changes.

Another option is you may need to us an actual crossover cable instead of a "straight through" network cable.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...