Jump to content

[Encoder] Duckencode.jar Ubuntu


Sleven
 Share

Recommended Posts

Some what of a noob to Ubuntu. I am using 11.04 and Sun Java 6 is installed. While in device directory I execute java -jar duckencoder.jar -h. It returns this "Unable to access jarfile duckencoder.jar" After doing some searching I tried to make it executable but it would not let me. I also used the chmod c +x command with the filename with no luck. Any help is appreciated.

Link to comment
Share on other sites

Now on to my next issue. Any ideas?

:~/Desktop$ java -jar ./duckencode.jar -i Lock.txt -o /media/0007-4B18/inject.bin

Error with input file!

Exception in thread "main" java.lang.reflect.InvocationTargetException

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

at java.lang.reflect.Method.invoke(Method.java:616)

at org.eclipse.jdt.internal.jarinjarloader.JarRsrcLoader.main(JarRsrcLoader.java:58)

Caused by: java.lang.NullPointerException

at Encoder.main(Encoder.java:111)

... 5 more

Link to comment
Share on other sites

Try ./Lock.txt for input file aswell..

./ means current directory

../ means directory above

you can string them together...

../../../../../../root/lock.txt

for example...

This worked.

java -jar ./duckencode.jar -i filename -o inject.bin

Link to comment
Share on other sites

I'm just going to post here rather than make a whole new thread. Just tell me off if I'm derailing your thread. Anyways..

I got my duck today and I've been trying to get my payloads to work all night. When I plug the duck in my Win7 it sees it fine and installs drivers fine although my payloads don't run. Not even the simple bart simpson payload.

After I run my java command java -jar /duckencode.jar -i reverse.txt -o /media/0007-545F/inject.bin

I ran cat on my inject.bin file and there was no data in it. No unintelligible binary code or anything in sight. So I think my inject.bin file is not being created or something. Please help.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...