Jump to content

Adito/openvpn Als Webserver Port Forwarding


myswordnu
 Share

Recommended Posts

I have installed Adito/OpenVPN server onto my system. Program works fine no problems at all and I seem to understand all of the settings/options. My problem is I can only load the webserver within my LAN using my LAN/localhost IP. I have changed the Adito webserver to run on port 8080/443 and it does within my LAN. Now I have opened both ports 443/8080 within my router and ran my Adito server then checked if ports where open with service running using http://canyouseeme.org. It replays back saying successful port is open and allowing connections. But when I load my external IP into the browser on port 8080 nothing loads.???? I dont get it it loads only within my LAN even after port forwarding the server ports on my router. And I know my ISP does not block port forwarding because I have port forwarded other servers/services just fine. Please help I will post a Image below with my settings.

ZkTFY.png

Link to comment
Share on other sites

What error do you get when attempting to connect externally. Also does it work externally just using https? It sounds like maybe you might have another device on the network with port 8080 opened along with a port forward rule as well. Another good test to make sure it's reachable would be to use nmap externally and make sure that 8080 does show open.

Link to comment
Share on other sites

Attempting to connect to the servers external IP via browser using http protocal gives the basic Unable to connect. Same error page for both firefox and IE are displayed also when using https/port on external IP in browser. I have also checked the router and no other system has port forward settings in place other then myself. Now when I use a port scanner like n-map it says my port is open with service running. But everytime I attempt to connect it acts as if its not even there it makes absolutely no sense its making me crazy lol. O and I also have my firewall disabled so I know I dont have a firewall blocking it.

***UPDATE***

Ok I downloaded and ran n-map on a external system and im glad I did at-least now I understand why its only working within my LAN. Basically its like this I do have port 8080/443 open but only via a UPnP-NAT-PMP tunnel port. I dont have login access to my router to enable direct port forwarding. So I use a nice program I have had for a while that does not require login access if router is UPnP/NAT-PMP enabled. Problem is it does not really open these ports just tunnels them through the UPNP open port.

Edited by myswordnu
Link to comment
Share on other sites

What model router are you using? Also I had a similar issue along time ago with Adito and I think I ended up adding 0.0.0.0 to the list of addresses to listen on and for whatever reason that seem to have got things working. So you don't possibly have remote management turned on in your router which by default is usually port 8080?

Link to comment
Share on other sites

What model router are you using? Also I had a similar issue along time ago with Adito and I think I ended up adding 0.0.0.0 to the list of addresses to listen on and for whatever reason that seem to have got things working. So you don't possibly have remote management turned on in your router which by default is usually port 8080?

The problem has been resolved now thank you. It is a problem within the Adito/openvpn server itself not my system. it does not support UPnP NAT-PMP port forwarding. Which is pretty understandable seeing as how it has to internally/externally link all those server files with IP/Port. Sadly at the current moment I dont have login access to the router to setup port forwarding directly. Iv managed to get around doing so via UPnP its currently my only option of port forwarding. Looks like im just gonna have to reset the router and login to it with default.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...