Jump to content

Wifi Stops Working After A While


Recommended Posts

Just wanted to ask here if anyone else have the same problem...

I have got everything working with the PineappleV2 with my netbook, as well as via a virtual BT5 on my MacBookPro. Just tried the jasagerPwn script and it works like a charm as well. But I have noticed some problems with the Wifi-connection after a while. The wifi-connection is broken and I can't get a new connection at all. I can still access the Pineapple through ethernet and bringing the interface down and up again doesnt do anything. Everything looks allright. With Karma off I can see the ESSID on my clients, but not possible to connect. Only thing that seems to fix it is to reboot the unit. Then it will work for a while again. An hour maybe. Then having to reboot again. I am running it on a 5V/2A poweradaptor. No batteries.

Any thoughts about that?

Link to comment
Share on other sites

Not sure about this Jasagerpwn script everyone keeps talking about, I just setup ICS (Internet Connection Sharing) manually each time and do what I need to do without the needs for extra scripts. Try setting the IP forwarding up manually instead. If you search through my posts I have linked my setup notes from building the FON2100 pineapple I made in many places on the forum.

Link to comment
Share on other sites

Well, Yes, I usually run the pineapple without jasagerPwn. That was just a test I was doing yesterday. The unit itself seems to run as it should. When I log in to WebIf or via SSH it all looks ok.

Have to correct my initial post. The ESSID is not broadcasted and can not be seen on the clients when not running Karma.

Link to comment
Share on other sites

The jasagerPwn script has some good ideas but I don't need dsniff, urlsnarf, and all the apps running simultaneously. I also had a lot of connectivity problems with jasagerPwn. I found it to be much more effective to take whatever attack I was doing, manually add the iptables entries, then manually start the corresponding programs. For me, one of the main problems with this script was that in starts your wireless interface in monitor mode, and I don't know why, but when mon0 is created it can cause other issues (for example, on my machine nmap will not work if the card's in monitor mode), not to mention you don't need mon0 for the majority of attacks it runs.

When using basic ICS with jasagerPwn the connection dies out a few minutes after for me also. I don't know what it is.

I don't know why, but many times my eth0 will change it's ip on it's own (for example from 172.20.0.1 to 172.20.0.27), and this completely messes things up since that IP is added in several config files on the router and is required for functionality. Check to see if your interface is changing IP's without your permission. To stop this from happening, I open a terminal and ping the pineapple from eth0 and just let it run until I'm finished what I'm doing.

Regarding karma, you'll see so-so results on a good day. It still has several bugs, you'll just have to pray to the local area gods and hope it doesn't mess anything up : )

Link to comment
Share on other sites

  • 2 weeks later...

Actually it starts the wireless attack interface in monitor mode. Not the gateway interface. And you should downgrade to a non-beta version of NMAP and then you would not get that route_dst error.

ICS is the same thing as the IPtables functions and ipv4 forwarding within jasagerPwn. I have had it running on pentests for over 5 hours with no stability issues. It may be the Indian and not the arrow.

It does have a lot of "Extra" stuff. If you don't want them, comment out those lines, not very hard. But I find when on pentests using rogueAPs, I am generally trying to gather as many credentials and information as possible or trying to establish a reverse connection to another IP in order to gain access to internal networks.

Manual configurations and implementations are ALWAYS more reliable. At least for myself, the script works 95% as reliable as my manual implementations, but then again I coded it.

EDIT: Yeah, I have not done any testing at all in BT5r1.

Edited by leg3nd
Link to comment
Share on other sites

jasagerPwn works just fine for me, i find it the easyiest solution, and it saves me alot of time, and have had it running for 2ish hours no problem. the only problem i've had is i turn karma on, deauth a test machine of mine, and it just ends up reconecting back to the original access point it was on (of course this is nothing to do with jasagerPwn, probably something dumb im doing). and i've been trying to figure out is how to use easytether0 (my tethering interface from my phone) as my default gateway instead of wlan0. i've changed the variable in the script, but still nothing, i think its just something to do with easytether. not sure. also tried connecting to backtrack from the ad-hoc network off my phone, and that was a no go as well. googleing around, it seems like alot of people have the same problem with ad-hoc and linux.

Link to comment
Share on other sites

soka80, Stupid question but you are able to tether normally with it? Personally I have no been able to mess with tethering as my gateway ever since I upgraded my phone a while back..

When I was tethering with "Wired Tether" on droid 1, It was by far the most reliable gateway for the pineapple I have ever used. Sadly I don't have that luxury anymore.

A friend got his working on Droid X using ad-hoc mode like your talking about, so could be on the right track. As long as the interface when you run "ifconfig" is actually "easytether0", and stays consistent, I don't see any reason it should not work in the script.

If you wanna talk about it PM me or somethin, don't want to hijack this guys thread.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...