Jump to content

Problems With Installing Katana


niels
 Share

Recommended Posts

Hey everybody,

this week I was trying to "install" katana on a usb key I bought recently.

The usb key is a HP v210w 8gb. Now my problem is I can't run the bootinst.sh of bootinstbat.

I first formatted the usb key on my mac en tried to run the bootinst.sh, then I get this output :

egrep: /proc/mounts: No such file or directory

egrep: /proc/mounts: No such file or directory

egrep: /proc/mounts: No such file or directory

Can't find device to install to.

Make sure you run this script from a mounted device.

Then I tried the same thing on a Windows 7 pc. Formatted the usb key, unrared the katana rar, tried to run the bootstrap.bat, getting the message that it can't be performed because the device is read-only.

So I made sure that the all files weren't read-only but that didn't worked either.

Can anybody come up with some advise ?

Thanks in advance,

Niels

Edited by niels
Link to comment
Share on other sites

Format as fat32, use unetbootin to make bootable, point to katana iso to install on usb drive. You can also try http://sites.google.com/site/shamurxboot/tipsntrick but requires windows with .net to make the drive bootable off the iso. .net not required to use the bootbable drive, just to create it from windows.

Link to comment
Share on other sites

  • 1 year later...

So here is my tale of the Katana install failures:

I downloaded the .rar and extracted everything without a fuss. Threw it onto a USB in the root (just like the site said, USB is formatted for fat32), then still following the site's install how-to, I find my way to the boot directory on the USB , and try to call ./bootinst.sh (running on Ubuntu 12.10)

Tried changing the permissions to make it an executable (it was only read/write), chmod u+x bootinst.sh , chmod +x and even 777 & 755. No changes regardless of sudo.

so then (with a little creativity) I called sudo bash ./bootinst.sh. Magic!! It succeeded.

Now for the problem:

"Flushing filesystem buffers, this may take a while....

Setting up MBR on /dev/sdc...

bootinst.sh: line 55 ./boot/syslinux/lilo: Permission denied"

And I've even gone so far as to copy the .sh file over to my linux HDD, change permissions, and tried coppying it back. Nothing there.

Cycle ended there. Wha-hu??? :blink::mellow:

Edited by Bountyhunter50
Link to comment
Share on other sites

  • 1 month later...

SOLUTION

I've had this problem over and over again and I finally figured out how to fix it. So maybe this will make me internet famous.

The take home lesson here though is that FAT16 and FAT32 do not understand Linux file permissions. So you can't change them on the drive. Well, there's another lesson here too. Ubuntu doesn't automatically mount thumb drives with root permission.

I'm going to go into a lot of detail for my own personal edification here.

All these instructions were performed in UBUNTU, but should be similar on other *nix distributions.

STEP 1: Mount the USB Thumb Drive

  1. Plug in USB Thumb Drive
  2. Open Terminal
  3. cd /media (This is where Ubuntu automatically mounts external media)
  4. If you can see the USB's file system (it's a folder/directory), perform "umount instert_name_of_folder"
  5. Now perform "sudo mkdir what_ever_your_pleasure", (I believe it's necessary to escalate in this area of the file system.)
  6. Here's where the magic happens, perform "sudo mount /dev/sdb1 whatever_your_pleasure"
  7. The USB Thumb Drive is now mounted to "whatever_your_pleasure" with full privileges.

A little extra note here: /dev is the directory where information on all devices connected to the system is kept. So even if you're flash drive isn't mounted, but connected to your PC there should be an sdb1 or sdb whatever number it happens to be in the /dev folder.

STEP 2: Install Katana

The install after this is exactly as the guide says it is.

  1. Navigate to "whatever_your_pleasure/boot"
  2. sudo ./bootinst.sh
  3. Follow on screen instructions
  4. Katana should be installed.

STEP 3: TIDY UP

  1. Navigate to /media
  2. "sudo umount whatever_your_pleasure" to unmount the drive
  3. "sudo rmdir whatever_your_pleasure" to get rid of the directory.
Edited by breadin
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...