Jump to content

Wpa Hacking: Invalid Output Format: Ivs And Pcap Format Cannot Be Used Together.


macrophage001
 Share

Recommended Posts

airodump-ng is throwing this strange error at me every time I try to save a capture file as a .pcap or .cap instead of a .ivs

I have been searching for hours now on how to fix this to no avail.

commands already tried:

airodump-ng -o pcap -w $cap_file_name --channel $channel_num --bssid $bssid -i $net_interf

airodump-ng -o pcap -w $cap_file_name --channel $channel_num -i $net_interf

airodump-ng -o pcap -w $cap_file_name -i $net_interf

now I don't think the problem is caused by the way i type the commands in. I think it's something else but I haven't been able to find it.

This started happening a day ago. I have no idea what caused it since I never even thought about using ivs for anything. It used to be that when I typed:

airodump-ng -w $cap_file_name --channel $channel_num -i $net_interf

It would automatically save to a .cap file or .pcap file.

Link to comment
Share on other sites

The default format is a pcap, so you shouldn't even need to worry about using -o. Just use "airodump-ng -w filename -c #channel -i interface" where filename is what you want to save the capture as(will automatically make extensions in multiple formats), #channel is the specific channel you want to listen on and interface is your wireless nics id (wlan0, etc).

By the way, can you post the entire messages, like a screenshot showing the commands and error output?

Edited by digip
Link to comment
Share on other sites

Yeah that's what I meant to say. I know it's supposed to default to pcap but with mine it defaults to ivs. Which is why I use the -o option.

using the -o option is what makes the error pop. The error is in the title of this topic.

when I use:

airodump-ng -w $cap_file_name -i $net_interf

the file that is saved is a .ivs file

when I use:

airodump-ng -o pcap -w $cap_file_name -i $net_interf

the scan doesn't even start and the error message I get is:

"Invalid Output Format: Ivs and Pcap Format Cannot be Used Together"

Link to comment
Share on other sites

Here is the think though. IVS are used with WEP cracking. WPA, uses a 4 way handshake and the SSID to be brute forced via aircrack after sending the deauth to capture the handshake, so not sure what you mean it defaults to IVS. When set to capture, it gathers EVERYTHING the card sees in monitor mode. Are you actually using "$cap_file_name" and "$net_interf" and not something like file-dump and wlan0. Or are you trying to script this, like a shell script, and those are variables it prompts you for?

Link to comment
Share on other sites

lol no I am not using those as actual names i was using those because I felt that it was irrelevant what name I used or network interface as long as it's in monitor mode (I am using mon0 btw)

I know all of that. What I am saying is that when I exit out of airodump-ng, it saves to an ivs file instead of a pcap file. it is defaulted to save to an ivs file. I don't why. It should save to a pcap file, I know that. But for some odd reason it won't. Even if I use the -o option to modify the output format. It won't let me. I get the error in the title of this topic whenever I try to use -o

Link to comment
Share on other sites

And when you leave out the -o option, and use just the -w, what happens? it should create several files(from memory, not sure exactly all the files it creates). It could just be an old bug. Try updating everything and try again.

http://forum.aircrack-ng.org/index.php?PHPSESSID=7ed9560afdc154cb5d148949612ee751&topic=5685.0

Or could be you just have the order and syntax wrong - This is why I asked for a screen shot.

http://www.backtrack-linux.org/forums/old-latest-public-release-backtrack4-beta/18917-ivs-pcap-format-cannot-used-together.html

Edited by digip
Link to comment
Share on other sites

You can, but aircrack will still use the IVS file when not specifying th e -o, you just point to the pcap, and it will automcatically search the ivs. Never had issue cracking wep that way, will still work, regardless of how may files -w will create, it will still work, just means more files to cleanup. For all I know, -o might be depricated.

Link to comment
Share on other sites

  • 2 years later...

airodump-ng is throwing this strange error at me every time I try to save a capture file as a .pcap or .cap instead of a .ivs

I have been searching for hours now on how to fix this to no avail.

commands already tried:

airodump-ng -o pcap -w $cap_file_name --channel $channel_num --bssid $bssid -i $net_interf

airodump-ng -o pcap -w $cap_file_name --channel $channel_num -i $net_interf

airodump-ng -o pcap -w $cap_file_name -i $net_interf

now I don't think the problem is caused by the way i type the commands in. I think it's something else but I haven't been able to find it.

This started happening a day ago. I have no idea what caused it since I never even thought about using ivs for anything. It used to be that when I typed:

airodump-ng -w $cap_file_name --channel $channel_num -i $net_interf
It would automatically save to a .cap file or .pcap file.

I ran into this same problem over the weekend. And you have a syntax error in your code.

Try loosing the -i for you interface and it should work.

airodump-ng -w wificapture --channel 7 mon0

or ath0 or mon1 whatever you are using fro your monitor

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...