Jump to content

Ngrep Stdout Problem?


RandomClown
 Share

Recommended Posts

After a bunch of Googleing, I think I am the only one writing about this problem. [probably not]

I'm on Windows, so maybe its not a prob for Linux users, but I cannot get anything to read the stdout of ngrep.

I tried piping it to grep, & tried writing a program to read from stdout. Neither worked.

Example of no pipe:

C:\Users\RandomClown>ngrep -lq -d 2 chat

interface: \Device\NPF_{2FB734B8-ABFC-4779-A9DF-CD35123692B0} (192.168.1.0/255.255.255.0)
match: chat

T 174.129.144.232:47627 -> 192.168.1.92:1118 [AP]
  ...?.C...o.......crowd.chat......p...testing.. ...Randomclownx.

If I pipe the results to anything, I get nothing. Example of searching for the letter "a":

C:\Users\RandomClown>ngrep -lq -d 2 chat | grep a

That should at least show the interface device line.

I am confused to why I cant read from stdout

Anyone know about this prob?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...