Jump to content

Vpn, 2011


RandomClown
 Share

Recommended Posts

Hello everyone,

I remember way back when, Hak5 talked about Adito as a good VPN tool.

...Well, now is the future, & it wont start on Windows. It basically does nothing after I configure it like before.

I loved it for its features, but I need to part with it because the newest version is the same version they introduced to us. [its long dead]

==============

VPN tools I tried:

- Adito: It is not stable & wont even start on a clean install of windows.

- OpenVPN: The tools to set up certs seems to have internal issue.

- Window's built in: Client cannot reach the VPN server.

==============

Anyone have a recommendation for something thats actually alive?

I would prefer to use Window's built in VPN since its the most simple way to do it, but no idea why it wont work.

Info on my setup for Windows built in:

- Both OS = Windows 7 Enterprise 64bit

- I have a CrapWire, I mean a 2Wire modem/router.

- I set up one side to accept a VPN connection

- Forwarded 1723 & 443

- Set up client side to connect to the server address

I tried it by clicking the network icon in the tray & clicking on the connection under "Dial-up and VPN", but it could not reach the server.

I get the feeling my router is just crap.

Link to comment
Share on other sites

Port 500 needs to be forward too since Windows IPSec needs this to communicate. Port 1723 I think is PPTP. Make sure IPSec service is up as well on the machines, but should be by default unless you've done something to disable them. I'm prety sure with respect to a router though, you don't port forward port 500, but instead check settings to allow VPN Passthrough, since this is a trusted port for VPN traffic, and it just allows stuff to pass through it when enabled on the router settings for VPN passthrough.

Check out this persons video tutorial for Windows 7 VPN setup:

Link to comment
Share on other sites

Not sure what kind of problems you had with OpenVPN certificates but when I first set it up, I encountered no problems at all. I don't mind Adito but I find OpenVPN a better and easier solution for securing a connection.

Link to comment
Share on other sites

  • 2 weeks later...

Ok, so the update for OpenVPN DID fix my problem. W00T!

..but I have an issue which probably could be solved with Google...cept not quite sure what to search for from my log.

- I updated OpenVPN on all computers

- Port forwarded 1194 UDP

- Made sure OpenVPN is allowed in firewall

- Created the VPN certificates

- Set up server config file

- Ran the server's VPN [icon is green]

- Gave the client certs to the intended clients

- Set up the client config files

- Ran OpenVPN GUI [icon is yellow]

It would not connect.

I use my domain name to connect. I know the address is up to date since I am remotely controlling it right now.

I'm using my phone's tether, so there should not be anything blocking it.

==============

Log:

The client log window shows this when I attempt to connect:

Wed Jul 20 18:12:17 2011 OpenVPN 2.2.1 Win32-MSVC++ [SSL] [LZO2] built on Jul  1 2011
Wed Jul 20 18:12:17 2011 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Wed Jul 20 18:12:18 2011 LZO compression initialized
Wed Jul 20 18:12:18 2011 Control Channel MTU parms [ L:1574 D:138 EF:38 EB:0 ET:0 EL:0 ]
Wed Jul 20 18:12:18 2011 Socket Buffers: R=[8192->8192] S=[8192->8192]
Wed Jul 20 18:12:18 2011 Data Channel MTU parms [ L:1574 D:1450 EF:42 EB:135 ET:32 EL:0 AF:3/1 ]
Wed Jul 20 18:12:18 2011 Local Options hash (VER=V4): 'd79ca330'
Wed Jul 20 18:12:18 2011 Expected Remote Options hash (VER=V4): 'f7df56b8'
Wed Jul 20 18:12:18 2011 UDPv4 link local: [undef]
Wed Jul 20 18:12:18 2011 UDPv4 link remote: **IP**:**Port**

After a while of waiting, it says:

Wed Jul 20 18:13:19 2011 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Wed Jul 20 18:13:19 2011 TLS Error: TLS handshake failed
Wed Jul 20 18:13:19 2011 TCP/UDP: Closing socket
Wed Jul 20 18:13:19 2011 SIGUSR1[soft,tls-error] received, process restarting
Wed Jul 20 18:13:19 2011 Restart pause, 2 second(s)

==============

Any ideas? My attempt at Google only revealed the things I thought of.

Thanks for reading.

Edited by RandomClown
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...