Jump to content

Backtrack 5 Kde Hates Me


Kerberos
 Share

Recommended Posts

To skip the back-story, kindly forward your attention down to the section titled "tl;dr". There may, however, be valuable information in the steps I've taken thus far and so the story may actually prove beneficial in some way. You never know.

{From The Beginning}

So I got my Ubertooth One today. I was super excited to get it up and running and so I immediately ripped open the package, spent a few minutes oo-ing and ah-ing at how much better it looks with all the parts and pieces assembled than the bare PCB I got initially (yes, I have both the kickstarter backer bare PCB as well as a newly bought, fully assembled version, why not?). Then I proceeded to fire up VirtualBox, where I run BackTrack 5 out of on my second monitor. I must say it works very nicely (or it has thus-far). I hastily, yet carefully plugged my shiny new hardware into a spare USB port, set up the USB filter in VirtualBox, and started installing the various dependencies noted in various forum posts and README files as required to run the different Ubertooth One tools. I had a few hiccups with some dependencies that refused to install alongside apt-get spitting out some rather strange errors I haven't seen before. Something about different versions of ubuntu. From what I gathered, the dependencies I was missing required a different version of ubuntu. Fair enough, I fumbled my way around it and found some alternative ways to set up the dependencies.

Eventually I got everything set up, only to find I couldn't access the Ubertooth One for some odd reason. LIBUSB errors were standing in my way and I couldn't find any information on them no matter how hard I googled. I looked around for some specific Ubertooth One related errors and found a forum post of Darren's mentioning having problems accessing the device from within a VM. Bummer... So I waited a few hours for my current batch of torrents to complete, shut down my computer, disconnected my hard drive (just for that added sense of isolation to supplement the nice, clean install) and connected a different hard drive, and threw my BT5 disc into the DVD drive. Upon rebooting into the live CD, I got as far as "startx" before running into my next issue. No desktop, it just crashed back to the console. Crap. Then I remembered about removing the icon cache files. I was back in business, "startx" appeared to be loading the desktop. Joy, oh joy! Or not.

{tl;dr}

So now we're all caught up. The issue I'm currently unrelentingly failing to solve appears to be a various mixture of problems culminating in either my monitor feeds (both monitors, HDMI and DVI) cutting out (and never coming back), but the eventual sound of the desktop loading albeit without the video, or the core of the X system loading only to have everything else crash and burn (literally crash). Now in between these problem popping up and trying to fix them, I managed to mangle KDE badly enough on the live CD to get some default desktop to load (that had absolutely no semblance of BackTrack 5 on it whatsoever, even the menu was messed up) and to get BT5 installed onto the hard drive I hooked up. But since then I haven't seen the slightest hint of a desktop other than a black screen with far too many crash notifications. As a matter of fact, I can't even get my monitors to register a single thing after "startx" most of the time, they just turn off (no signal, out of range, etc). Now, an important piece of information is that my graphics card is an ATI Radeon HD5770, which I'm pretty sure is 99% of the problem, if not the entire problem. I've tried multiple "fixes", including, but not limited to:

- Grub modification: "radeon.modeset=0"

- Grub modification: "i915.modeset=1"

- Installing ATI's Radeon linux drivers from the console (the installer aborted near the end, no clue why)

- "Xorg -configure" to generate a new X config to use (which almost works)

- Generating a failsafe X config to use

- Generating a new X config and changing the "driver" under the section "device" from "radeon" to "vesa"

- Probably a few other things I can't think of. I tried a lot of things.

Now, the attachment shows the crash notifications I managed to get a few times. They mention "floating point exception", which makes me wonder if I'm not making some extremely elementary mistake due to my partial lack of knowledge of certain aspects of the linux environment. I can't think of anything that might be terribly simple that I haven't tried or thought of, but that's the problem: it's always the last thing you think of. I'm running out of things to try, and with no other computers to even test my Ubertooth One on, it's going to end up in a box in my closet for a few years until I'm out of university and have some money to buy a laptop. I'm very happy I at least have the hardware, as long as it stays in good shape, but I'll be fairly disappointed if I don't get the chance to use it for quite some time.

So that's my predicament. If anybody has any experience with any of these problems, or maybe a better understanding of linux than I have, any help would be very much appreciated. I've had a great time experimenting with the various tools in BackTrack 5 under VirtualBox, learning to use Metasploit and Meterpreter, and tampering with MITM HTTP injections to deliver payloads. But there are some things you just can't do from inside a VM. I hope I can sort this out. Sorry for the long-winded post, I've been up all night working on this and I think I'm starting to lose focus. I await the combined wisdom of the community. Thanks for any help, or even just taking a look at my post :)

post-8756-0-74781800-1308828319_thumb.jp

Link to comment
Share on other sites

Redownload the ISO from the bt site, then verify its MD5 that its not corrupt, then try again. Also, they put a lot of fixes in place, mainly KDE graphic issues. Before starting X, from the shell, do apt-get update and apt-get upgrade, then try starting X.

See my blog post here about X crashing in KDE - http://www.ticktockcomputers.com/blog/tutorial/backtrack-5-kde-x64-vmware-install-instructions/

If you have the older release of BT5, then this could be the issue, the apt-get update and upgrade should fix it, but it if doesn't, try the above link walk through, as it applies to both VM installs and native installs/live disc usage.

If all else fails, try the Gnome version of BT5 and see if that works. I have an ATI 5770, and BT5 works fine on it, but I only use it in a VM on this machine. I have it natively installed on my laptop though, and it works fine on it, which also has an ATI card for the laptop, but not sure the model of it.(possibly ATI HD 4250 but not 100% sure, don't have it powered up at the moment an rarely use it. Its new.)

By the way, uBuntu is nto BT, and vice versa. BT5 has a custom kernel, and things form the uBuntu repository, are not guaranteed to work properly. As far as I know, BT5 has support for ubertooth, just check their forums and wiki in case you need to add something to make it work.

Edited by digip
Link to comment
Share on other sites

Ah, I did try "apt-get update" from the console, but I never thought to try "apt-get upgrade" as well. That's a very good idea, not sure how I missed it. Thanks for the great advice. I'll take a look at that post and give it another try. And I didn't know that BT5 had a custom kernel, that's pretty cool. Thanks for the information.

Link to comment
Share on other sites

When the spectrum analyzer window popped up I almost had an aneurysm. Everything's up and running perfectly. Thanks for pointing me in the right direction, very much appreciated. Sorry for the oversight, I should have thought to try that. :)

Link to comment
Share on other sites

And I didn't know that BT5 had a custom kernel, that's pretty cool. Thanks for the information.

Well, its still a linux kernel, but settings are customized for hardware and tasks specific to the software and use of BT5. Backtrack uses its own repositories for this reason alone, since they keep code up to date so it won't break specifically for backtrack, they want to keep it in house so they can track the bugs and make fixes. They also offer kernel sources now as well, so if you need to add software that you have to compile on your own, you can get all them working and compiled in BT5 without issues, which was problematic in previous releases for not having all the source files to compile against.

prepare-kernel-sources
cd /usr/src/linux
cp -rf include/generated/* include/linux/

So before you go trying to add repositories and dependencies from other places, try sticking with what BT5 has shipped with. You have to remember, they built this from the ground up to be used specifically for hacking/pentesting tasks. While it can be used as an everyday desktop, and is probably the fastest and most stable release of BT I've used up to now, its not meant to be used as your entertainment or media center. Not that it can't be modified and customized for that, but its got a task in mind for what its developed for.

Also, search the repositories before trying to add from external sources. Either apt-cache search WORDTOSEARCH or aptitude search, because I was going to add packETH to try and play with it, and it was already in the repo, just not installed by default. There are a lot of other tools out there that just aren't installed by default, but can be if you search the repo.

Link to comment
Share on other sites

Would this work for a persistent usb drive? I have a 4 gig usb drive that I am running backtrack 5 kde 32 bit on. Kde works fine for a few days and then will no longer start when you type startx.

Thing about Flash media is they only have so many writes before they become unwritable any more. How old is the drive? Is it possible it got damaged in any way?

Not sure what that could be, but never hurts to try and update it, see if it then boots again. Just backup whatever you have on the drive if its important, as I recently did an update on my laptop and something failed during the update and couldn't boot afterwards. Might have been a corrupt download, but I had to run in recovery mode in order to boot it again as it kept getting a disk error. I think its mainly my HDD on the laptop though. Its been bad since I bought it, and its brand new. Windows crapped out a few times and had to reinstall it as well, so most likely a bad drive. This might be the problem with your thumb drive as well though. Might have gotten corrupted or is worn out and has bad areas of disk space on it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...