Jump to content

Ssh Problem (trying To Setup Internet Forwarding)


Recommended Posts

Hello,

I recently received my pineapple v2 and one of the first things to do is to set up internet forwarding.

My system - backtrack 5 in VirtualBox. Eth0 is wifi (to internet) and eth1 is cat5 cable to pineapple.

I first tried this:

echo 1 | sudo tee /proc/sys/net/ipv4/ip_forward > /dev/null
sudo iptables -t nat -A PREROUTING -p tcp --destination-port 80 -j REDIRECT --to-port 64123
sudo iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
sudo ifconfig eth1 192.168.0.1 netmask 255.255.255.0
sudo dhclient eth0

no luck there, so I went on to this: Best HowTo - Setup Internet

I am at the part where you have to ssh into the pineapple. I first tried in backtrack and nothing would happen. I opened up putty in windows and my access is denied. I am trying user:root and pass:pineapplesareyummy (haven't messed with the default pass yet).

What am I doing wrong?

Thanks for any help!

Link to comment
Share on other sites

Ok, so at first I thought I was supposed to ssh to the pineapple's ip. ipconfig in command prompt revealed 192.168.1.161. Like described above - access denied.

Today, I tried 192.168.1.1 and successfully logged in, seeing the OpenWRT welcome message.

Is this the proper place for me to be? Or is this just for OpenWRT?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...