Jump to content

Windows 7, Ics, And The Pineapple


Recommended Posts

1) Verify that ICS is setup correctly.

a) Verify the IP of the network connection. Windows 7 seems to default to 192.168.137.1

i) To verify (or change) default ICS IP assignment see this page:

I tried changing the IP to a different subnet after I enabled ICS, but was never successful. Your mileage may vary…

ii) Assign the FON to an IP in this range before you enable ICS (I used 192.168.137.250). The FON and your Ethernet port must be on the same subnet (192.168.137.x for example).

iii) The Wi-Fi connection that you are sharing with ICS will normally be receiving an IP automatically from the wireless router you are connecting to. This will rarely be in the 192.168.137.x range but it is possible. (Think about this if you receive a IP conflict error)

b) Connect the Ethernet port of the Victim to the Ethernet port of the Attacker.

c) Open CLI (Start > Run > type cmd) on the Victim.

d)
Ping www.google.com

e)
traceroute www.google.com

i) The first hop should be the Ethernet adapter

ii) Second hop should be the router your wireless is connected to.

f) Open up Internet Explorer and do some random surfing. Once you know that you can connect to the web, you can confidently eliminate ICS as a source of your errors or lack of connection to the internet.

2) Now connect the FON to the Attacker Ethernet port and verify its communication with the internet.

a) SSH into FON

i) Using puTTY, type in the IP address of the FON (I used 192.168.137.250)

ii) Login as
root
.

iii) Password is
pineapplesareyummy
.

b) Type
Ping www.google.com
(Ctrl + C to stop pinging)

c) Type
traceroute www.google.com

i) First hop should be the Ethernet adapter on the Attacker

ii) Second hop should be the router your wireless is connected to.

3) I did too many changes to my settings (without documenting them doh!) to recall what is different from the factory default, however, the screen shots below show what they are now. They are in no particular order.

a) I believe the most important setting change for me was when I changed the Network > Wireless >Wireless Virtual Adapter Configuration For Wireless Card wifi0 > Network = lan.

This might have been in the other tutorials, but I didn’t see it.

post-34719-0-61491400-1305044889_thumb.j

post-34719-0-74230000-1305044997_thumb.j

post-34719-0-69636200-1305045018_thumb.j

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...