Jump to content

Pineapple Problems...


Guest alan12385566960
 Share

Recommended Posts

Guest alan2796

I received my pineapple the other day thanks guys ! was well chuffed all was going good until I messed with some DHCP Settings and everything went downhill from there ! no matter what i did i couldn't connect anymore so I read as much info from there as I can and I tried setting up a dhcp server on my ubuntu machine plugging it into my router etc... so failing all that I read a post saying Re-flash it from step 11 in Darrens guide, so I re-flashed it and get it back up and running but when I come to enable the wifi

uci set wireless.wifi0.disabled=0

uci commit wireless && wifi

it throws a brick and I cant get back into it so... a few re-flashes later missing out this command I get back into jasager and openwrt but no ath0 interface,

so I tried

wlanconfig ath0 create wlandev wifi0 wlanmode ap

which brings up a ath0 interface under iwconfig, nothing in ifconfig

and if try and enable it through webif, it just says reloading wireless then locks me out completely again, I also read on openwrt docs if I have corrupted my mtd partition openwrt will boot up but wireless wont work correctly so i thought this may be what happened so i ran this command

mtd -e vmlinux.bin.l7 write openwrt-ar531x-2.4-vmlinux-CAMICIA.lzma vmlinux.bin.l7

reboot

however redboot gave me errors

mtd -e "RedBoot config" write out.hex "RedBoot config"

reboot

but I don't know if that was right or not

so now I am stuck now and am thinking I need to create a USB>Serial and go that way unless anyone can tell me where I have gone wrong ?

Link to comment
Share on other sites

Guest alan2796

A bit further on but no luck, followed the latest guide pinned to top of forum reflashed and tried and im getting webif, jasager but still no ath0 if i run uci commit wireless i get a wlan light but no broadcasts and after that it's on I can't ssh or get into webif. When I run a packet sniff on eth0 it sends a lot of gratuitios requests from router and then dosent respond to arp replys then a udp packet from one port to another which reads" dead " press reset button now to enter failsafe mode" press the button and you see another udp packet saying entering failsafe mode and I can telnet into router but unable to set a password or disable wireless. Still thinking I have bricked it and need a usb > serial flash )

Link to comment
Share on other sites

Guest alan2796

Thanks, for the reply !

I Couldn't get redboot.pl to work, unreachable for a while then : is alive but "(failed to open 192.168.1.1)".

I booted into windows and flashed, your firmware with the open-mesh-flash.exe, I am unaware if thst was acceptable or not, however I did it anyway and I rebooted and got 192.168.1.1:1471 Jasager.

Unfortunately it's still saying no ath0 interface found, I hit create and it lights the wlan light but no bssid gets broadcast and then its nolonger reachable on 192.168.1.1.

Link to comment
Share on other sites

Guest alan2796

Thanks digininja I have tried your firmware however I couldn't get reboot to start wouldnt, so I used open-mesh-flash.exe in windows which seemed to work I got firmware loaded and got Jasager without any additional packages but still no ath0 or wifi and attempts to enable it end up in being locked out of the router when doing a uci commit. any more ideas ?

Link to comment
Share on other sites

  • 2 weeks later...
Guest alan2796

Afraid i still get the same result if I try and enable through the webif interface, wlan light, comes on but then i get locked out of the thing and again get this dead packet. when i turn it off and try and reboot.

Link to comment
Share on other sites

How about trying connecting your laptop directly to the Fon, make sure your laptop is on an IP in the middle of the subnet. Connect to it and enable the wifi, see if you still get locked out. If you don't then it is an IP conflict with something else on your network. If it does lock up then I'm not sure what to suggest next. I'd probably go with a serial cable and see what happens at the terminal rather than through a network connection.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...