Jump to content

Help With Install Open-mesh Om1p With Jasager Firmware V2


bismark
 Share

Recommended Posts

I'm trying to install the Jasager firmware v2 onto a new Open-Mesh OM1P and currently I'm having no luck. I'm running OSX and so now of the easy/pretty tools work for loading, at least in my experience so far, but I'm not afraid of a little command line work in RedBoot.

So I can get access to RedBoot on the device @ 192.168.0.1 and I'm able to upload firmware through tftp on my system. I've successfully installed OpenWRT 8.09.2 and the last build of Piranha. Unfortunately I'm looking to work with the Jasager Karma modifications which do not work with the prior version and though the later seems to have the madwifi patches from DigiNinja built it, Jasager doesn't run on it.

So I'm stuck on trying to get the device to boot after loading the Jasager firmware. The firmware and kernel load itself goes fine no error messages or problems, the boot script is set to execute but when I issue reset, nothing happens it just hangs and never comes up on 192.168.1.1. I do see 192.168.0.1 appear again and can get back into RedBoot but never into OpenWRT.

I've read each of the stuck topics and searched through other forums but no luck, even tried remote gdb debugging which never connected (would be interested in this just for the curiosity factor alone (Lines of scrolling text always makes one feel better). Does anyone have any suggestions or directions that I may have missed?

Thanks,

Bismark

Link to comment
Share on other sites

I finally have a serial cable connection and I'm able to see what is going on. On boot up after flashing the OM1P, version MR3201P, keeps repeating the following line:

jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000000: 0x2d51 instead 
....

Finally ending at with the following:

Cowardly refusing to erase blocks on filesystem with no valid JFFS2 nodes
empty_blocks 91, bad_blocks 0, c->nr_blocks 112
VFS: Cannot open root device "<NULL>" or unknown-block(31,1)
Please append a correct "root=" boot option; here are the available partitions: 

Can anyone offer any insight or point me in a direction? I'd really like to get a greedy AP up and running for wireless assessments.

Link to comment
Share on other sites

  • 2 months later...

Hey nice one Sebkinne, i'll check that out. Maybe that will be a nicer way to do things anyway. Am I correct in assuming that hostapd uses the ath5k driver rather than madwifi?

As for jasager, I think that's the end of the line for me with that now on the OM1. Thought my issues would be solved once I got the serial connection going and could see what was actually happening. Having flashed it with both the open-mesh-flash utility and with Robin's recommended procedure using Reboot and TFTP i'm stumped. I may just shell out for a pre-built pineapple if I can't get hostapd working either! Feels like a massive fail though :(

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...